Slow boot of system

I was trying to enable hibernation by creating a swap partition, then decided to remove it. The system now boots in almost 60 seconds, with the Manjaro screen loading.


GRUB_CMDLINE_LINUX_DEFAULT=“quiet splash apparmor=1 security=apparmor udev.log_priority=3”

You removed the swap partition. Did you remove it in /etc/fstab?

Yes. Processor i9-11900k, clean installation of Manjaro, just any packages downloaded…


# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=***                            /boot/efi      vfat    umask=0077 0 2
UUID=*** /              ext4    defaults,noatime 0 1
tmpfs                                     /tmp           tmpfs   defaults,noatime,mode=1777 0 0
UUID= none swap defaults 0 0`


sudo update-grub

If you have deleted that swap partition:

Comment that line (like this):

#UUID= none swap defaults 0 0`

… or, remove it completely; then reboot.

Additionally, there is a back-tick character that should not be there. Cheers.



Done! Same problem…

It wasn’t meant to fix your original issue; only the issue you created by deleting the swap partition, while leaving the mount reference in /etc/fstab.

The back-tick? – it was at the end of the line you commented/removed.

Now, try sudo update-grub again, and reboot.

To create a new Grub configuration (manually):

sudo grub-mkconfig -o /boot/grub/grub.cfg

Hope this helps. Cheers.

tmpfs… do i remove it?

I suppose it depends on your use case; It’s the default entry for tmpfs, which has been questioned of late, but it should do no harm.
The rest looks fine, assuming you don’t have a separate /home partition.

If you decide to use a swap file after all, make sure to include its UUID in /etc/fstab, for example:


… replacing the X’s with your own UUID. UUID’s may be found with:

sudo blkid

You can check for errors in /etc/fstab with:

sudo mount -a

How do I see the services that start automatically?

sudo systemctl --state=active

Start with that. I’m guessing you want to disable a few services with hopes of better performance. I have no recommendations for that.

However, if you give some more information, for example, which DE you’re using, I’m sure someone can suggest where to find the GUI tools needed to find that information.

In KDE, for example:

System SettingsStartup and ShutdownAutostart

… will display applications selected to run at login, and:

System SettingsStartup and ShutdownBackground Services

… will display background services.


Good luck. Cheers.

Solved. Thanks!

update-grub is a wrapper for grub-mkconfig.

$ cat /usr/bin/update-grub
#! /bin/sh
set -e
grub-mkconfig -o /boot/grub/grub.cfg "$@"

# workaround for
# if grub is not updated in MBR/EFI dashes still won't work, hence we remove them
sed -i -e '/cryptomount -u/ {s/-//g;s/ u/ -u/g}' /boot/grub/grub.cfg

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.