Slow application start and freezes in Manjaro

Hi! Using Manjaro for some time already and have been liking it, but lately I suffer from a certain issue related to slowness in the system. The instances of it I have noticed are:

  • while browsing photos with Gwenview, it periodically (once 2-10 minutes) freezes the app on transition between two photos around 10 seconds
  • Timeshift happened to hang on starting up in a similar way before it appeared
  • Telegram less frequently hangs for similar period of time when sending a sticker in a chat
  • I feel there was something else that I simply forgot about in the process of typing…

Weirdly, the issue seems to have two side effects:

  • when the freeze happens, from what I can hear it seems like the data HDD I have in my computer starts spinning up a moment before the freeze ends, together with the fans in the case
  • the fans are probably related to how in KDE system monitor when the freeze happens, one seemingly randomly picked CPU thread goes for the freeze period on solid 100% load, yet looking through the process table trying to find out what exactly consumes that thread seems pretty futile, as nothing really appears to go beyond 3% of load.

That issue seems to be a thing since Manjaro 21.1.5 version. First it troubled me a few days ago and I thought that for some weird kind of fashion it was caused by swapping CD/DVD drives between my and another computer for utility reasons (I made the swap and very soon that started happening). Today I used BTRFS snapshots though and I loaded state of the system from 09.10.2021, when I still had 21.1.4. I played around for a couple moments, which normally would trigger the issue easily, but nothing like that happened, either with the CD drive unplugged, or plugged, so I went for updating system from that snapshot to see if it’s just a broken update process, of the update itself. For some reason the .4 version updated to .5, refusing to find the .6 in the updater (pretty conveniently for this case actually I guess) and pretty soon after getting the .5, the issue returned. In the end I just returned to the first, original “branch” of my snapshots/updates for the sake of just being up to date.

  Kernel: 5.14.10-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
  parameters: BOOT_IMAGE=/@/boot/vmlinuz-5.14-x86_64
  root=UUID=dc3b1840-1309-41c0-bf94-ac04cabb1309 rw rootflags=subvol=@ quiet
  Desktop: KDE Plasma 5.22.5 tk: Qt 5.15.2 wm: kwin_x11 vt: 1 dm: SDDM
  Distro: Manjaro Linux base: Arch Linux
  Type: Desktop System: Micro-Star product: MS-7C35 v: 1.0 serial: <filter>
  Mobo: Micro-Star model: MEG X570 ACE (MS-7C35) v: 1.0 serial: <filter>
  UEFI: American Megatrends v: 1.B0 date: 09/07/2020
  Device-1: hidpp_battery_0
  model: Logitech MX Vertical Advanced Ergonomic Mouse serial: <filter>
  charge: 55% (should be ignored) rechargeable: yes status: Discharging
  RAM: total: 31.27 GiB used: 3.13 GiB (10.0%)
  RAM Report: permissions: Unable to run dmidecode. Root privileges required.
  Info: 16-Core (2-Die) model: AMD Ryzen 9 3950X bits: 64 type: MT MCP MCM
  arch: Zen 2 family: 17 (23) model-id: 71 (113) stepping: 0
  microcode: 8701021 cache: L2: 8 MiB bogomips: 224073
  Speed: 2196 MHz min/max: 2200/3500 MHz boost: enabled Core speeds (MHz):
  1: 2196 2: 2054 3: 2197 4: 2196 5: 2200 6: 2198 7: 2197 8: 2196 9: 3598
  10: 3600 11: 2056 12: 2055 13: 2057 14: 2058 15: 3600 16: 2059 17: 2056
  18: 2200 19: 2200 20: 2199 21: 2201 22: 2199 23: 2200 24: 2058 25: 2199
  26: 2199 27: 2199 28: 2197 29: 2197 30: 2199 31: 2198 32: 2198
  Flags: 3dnowprefetch abm adx aes aperfmperf apic arat avic avx avx2 bmi1
  bmi2 bpext cat_l3 cdp_l3 clflush clflushopt clwb clzero cmov cmp_legacy
  constant_tsc cpb cpuid cqm cqm_llc cqm_mbm_local cqm_mbm_total cqm_occup_llc
  cr8_legacy cx16 cx8 de decodeassists extapic extd_apicid f16c flushbyasid
  fma fpu fsgsbase fxsr fxsr_opt ht hw_pstate ibpb ibs irperf lahf_lm lbrv lm
  mba mca mce misalignsse mmx mmxext monitor movbe msr mtrr mwaitx nonstop_tsc
  nopl npt nrip_save nx osvw overflow_recov pae pat pausefilter pclmulqdq
  pdpe1gb perfctr_core perfctr_llc perfctr_nb pfthreshold pge pni popcnt pse
  pse36 rapl rdpid rdpru rdrand rdseed rdt_a rdtscp rep_good sep sev sev_es
  sha_ni skinit smap smca sme smep ssbd sse sse2 sse4_1 sse4_2 sse4a ssse3
  stibp succor svm svm_lock syscall tce topoext tsc tsc_scale umip v_spec_ctrl
  v_vmsave_vmload vgif vmcb_clean vme vmmcall wbnoinvd wdt xgetbv1 xsave
  xsavec xsaveerptr xsaveopt xsaves
  Vulnerabilities: Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
  mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
  mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP:
  conditional, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: AMD Ellesmere [Radeon RX 470/480/570/570X/580/580X/590]
  vendor: Sapphire Limited Nitro+ driver: amdgpu v: kernel bus-ID: 2d:00.0
  chip-ID: 1002:67df class-ID: 0300
  Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver:
  loaded: amdgpu,ati unloaded: modesetting alternate: fbdev,vesa
  display-ID: :0 screens: 1
  Screen-1: 0 s-res: 4480x1080 s-dpi: 96 s-size: 1185x285mm (46.7x11.2")
  s-diag: 1219mm (48")
  Monitor-1: HDMI-A-0 res: 2560x1080 hz: 75 dpi: 96
  size: 677x290mm (26.7x11.4") diag: 736mm (29")
  Monitor-2: DVI-D-0 res: 1920x1080 hz: 60 dpi: 92
  size: 531x299mm (20.9x11.8") diag: 609mm (24")
  OpenGL: renderer: Radeon RX 580 Series (POLARIS10 DRM 3.42.0
  5.14.10-1-MANJARO LLVM 12.0.1)
  v: 4.6 Mesa 21.2.3 direct render: Yes
  Device-1: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590]
  vendor: Sapphire Limited driver: snd_hda_intel v: kernel bus-ID: 2d:00.1
  chip-ID: 1002:aaf0 class-ID: 0403
  Device-2: AMD Starship/Matisse HD Audio vendor: Micro-Star MSI
  driver: snd_hda_intel v: kernel bus-ID: 2f:00.4 chip-ID: 1022:1487
  class-ID: 0403
  Sound Server-1: ALSA v: k5.14.10-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.19 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.38 running: yes
  Device-1: Intel I211 Gigabit Network vendor: Micro-Star MSI driver: igb
  v: kernel port: e000 bus-ID: 26:00.0 chip-ID: 8086:1539 class-ID: 0200
  IF: enp38s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
  broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: link
  Device-2: Realtek RTL8125 2.5GbE vendor: Micro-Star MSI driver: r8169
  v: kernel port: d000 bus-ID: 27:00.0 chip-ID: 10ec:8125 class-ID: 0200
  IF: enp39s0 state: down mac: <filter>
  Device-3: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel bus-ID: 28:00.0
  chip-ID: 8086:2723 class-ID: 0280
  IF: wlo1 state: down mac: <filter>
  WAN IP: <filter>
  Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 1-4:2
  chip-ID: 8087:0029 class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 1 state: up address: see --recommends
  Message: No logical block device data found.
  Message: No RAID data found.
  Local Storage: total: 3.64 TiB used: 1.8 TiB (49.4%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: SSD 970 EVO 1TB
  size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
  lanes: 4 type: SSD serial: <filter> rev: 2B2QEXE7 temp: 43.9 C scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 vendor: Hitachi model: HUS724030ALE641
  size: 2.73 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
  type: HDD rpm: 7200 serial: <filter> rev: A5F0 scheme: GPT
  Optical-1: /dev/sr0 vendor: Optiarc model: DVD RW AD-5240S rev: 1.03
  dev-links: cdrom
  Features: speed: 48 multisession: yes audio: yes dvd: yes
  rw: cd-r,cd-rw,dvd-r state: running
  ID-1: / raw-size: 899.01 GiB size: 899.01 GiB (100.00%)
  used: 88.6 GiB (9.9%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  label: N/A uuid: dc3b1840-1309-41c0-bf94-ac04cabb1309
  ID-2: /boot/efi raw-size: 512 MiB size: 511 MiB (99.80%)
  used: 568 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1 label: N/A
  uuid: BF10-DB6C
  ID-3: /home raw-size: 899.01 GiB size: 899.01 GiB (100.00%)
  used: 88.6 GiB (9.9%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  label: N/A uuid: dc3b1840-1309-41c0-bf94-ac04cabb1309
  ID-4: /mnt/HDDDATA raw-size: 2.73 TiB size: 2.69 TiB (98.39%)
  used: 1.71 TiB (63.8%) fs: ext4 dev: /dev/sda1 maj-min: 8:1
  label: H_NEONdata uuid: 1e0a0afc-df78-497d-9d13-45a61fdbdbd3
  ID-5: /run/timeshift/backup raw-size: 899.01 GiB size: 899.01 GiB (100.00%)
  used: 88.6 GiB (9.9%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  label: N/A uuid: dc3b1840-1309-41c0-bf94-ac04cabb1309
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 32 GiB used: 0 KiB (0.0%) priority: -2
  dev: /dev/nvme0n1p3 maj-min: 259:3 label: N/A
  uuid: 4344342b-abea-4d58-a8fb-de929973eeae
  Message: No unmounted partitions found.
  Hub-1: 1-0:1 info: Full speed (or root) Hub ports: 6 rev: 2.0
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 1-4:2 info: Intel AX200 Bluetooth type: Bluetooth driver: btusb
  interfaces: 2 rev: 2.0 speed: 12 Mb/s power: 100mA chip-ID: 8087:0029
  class-ID: e001
  Device-2: 1-6:3 info: Logitech Unifying Receiver type: Keyboard,Mouse,HID
  driver: logitech-djreceiver,usbhid interfaces: 3 rev: 2.0 speed: 12 Mb/s
  power: 98mA chip-ID: 046d:c52b class-ID: 0300
  Hub-2: 2-0:1 info: Full speed (or root) Hub ports: 4 rev: 3.1 speed: 10 Gb/s
  chip-ID: 1d6b:0003 class-ID: 0900
  Hub-3: 3-0:1 info: Full speed (or root) Hub ports: 6 rev: 2.0
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 3-5:2 info: Micro Star MEG X570 ACE type: HID
  driver: hid-generic,usbhid interfaces: 1 rev: 1.1 speed: 12 Mb/s
  power: 500mA chip-ID: 1462:7c35 class-ID: 0300 serial: <filter>
  Hub-4: 3-6:3 info: Genesys Logic Hub ports: 4 rev: 2.0 speed: 480 Mb/s
  power: 100mA chip-ID: 05e3:0608 class-ID: 0900
  Hub-5: 4-0:1 info: Full speed (or root) Hub ports: 4 rev: 3.1 speed: 10 Gb/s
  chip-ID: 1d6b:0003 class-ID: 0900
  Hub-6: 5-0:1 info: Full speed (or root) Hub ports: 4 rev: 2.0
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 5-1:2 info: Microdia USB DEVICE type: Keyboard,Mouse
  driver: hid-generic,usbhid interfaces: 2 rev: 2.0 speed: 12 Mb/s
  power: 100mA chip-ID: 0c45:8508 class-ID: 0301
  Device-2: 5-2:3 info: Wacom PTH-651 [Intuos pro (M)] type: HID,Mouse
  driver: usbhid,wacom interfaces: 3 rev: 2.0 speed: 12 Mb/s power: 498mA
  chip-ID: 056a:0315 class-ID: 0301
  Hub-7: 6-0:1 info: Full speed (or root) Hub ports: 4 rev: 3.1 speed: 10 Gb/s
  chip-ID: 1d6b:0003 class-ID: 0900
  System Temperatures: cpu: 51.4 C mobo: N/A gpu: amdgpu temp: 51.0 C
  Fan Speeds (RPM): N/A gpu: amdgpu fan: 909
  Processes: 537 Uptime: 43m wakeups: 3 Init: systemd v: 249 tool: systemctl
  Compilers: gcc: 11.1.0 clang: 12.0.1 Packages: pacman: 1345 lib: 429
  Shell: Zsh v: 5.8 running-in: konsole inxi: 3.3.07```

Is there anything to be done about this?
1 Like

You should try nomacs, it is fast image viewer.

1 Like

Likely, but Gwenview has never been a problem for me, was working pretty much flawless for years. Additionally, it prolly solves no real issue if it’s going to help anything at all. I can imagine it would not, I feel it’s sort of similar to how years ago I had a faulty hard drive on which I was storing Spotify cache. Not only it was breaking Spotify performance back then, but even the system as a whole (from what I researched it’s goods of X11 I think). Just this time something in the system itself probably degrades stuff. So I would not really seek fault in Gwenview, but I’m actually ready to get surprised just in case.


The entire issue seems to be related to the HDD. Sort of not easy to test it; when unmounting the drive, leaving just the system SSD, it looks like there is no issue with responsiveness of anything, but I also can judge browsing images on a pretty limited scope, as I cannot really stuff all of them on the SSD for sure. While I had a handful of them on SSD though, it worked fine.

Additionally, I previously tried to execute the balooctl disable but it brought no difference to the whole issue, so I just turned it back on.

Hi, your post showed up as related to mine: HDD keeps spinning down, aggressive standby
(can’t post links…)

Seems like the same problem. Did you fix it?

I managed to fix it, check the forum post I linked above. The problem was TLP running in battery mode, I forced TLP in AC mode.

I hope it helps.

Quote from my post:

I think I found the issue. I was investigating power saving features and found that TLP (see archlinux wiki: TLP - ArchWiki) (TLP is a laptop power saving feature) is turned on (check systemd systemctl status tlp). I checked tlp-stat and found that it is running on battery mode. I don’t know if it is normal that TLP is enabled on a desktop machine, but I kept it enabled. The battery mode of TLP does what is advertises to do, saving battery on a laptop, therefore aggressively putting the HDD in standby mode.

Solution was to force TLP in AC mode. I did this by setting the following settings in /etc/tlp.conf:


The persistant default config forces TLP to use the default value and not trying to detect the power state >(battery or AC). The default mode, obviously, sets the default mode. This way after checking tlp-stat >TLP is now correctly running in AC mode.

Does someone know whether it is intended to use TLP at all on a desktop?



Hey, thanks for your reply! At that point I totally did not expect anyone to pop up and help me just like that here. I was actually going back in here to link this article to a thread on reddit I was about to write. Still I kinda lost hope, as already 3 techy friends or so did not know how to resolve that issue. So even more thanks for actually bothering to let me know in here!

So basically it seems like it’s the issue that has been causing the trouble for me, too. Once I modified the file the way you mentioned and restarted the service, the annoyance stopped. I’m good since yesterday basically, so I trust it all to be fully fine now.
And I will let myself say that it’s very stupid that in Linux you get something like this switching in some config, from user’s perspective actually randomly. And while that’s a power management setting, you cannot do anything to it from the level of KDE battery and brightness, or the settings panel. Not only that, but each time the drive stops and spins back up, it’s basically a cycle of strain put on the mechanism, so I’m certain that such shenanigans actually shorten the life span of the hard drive.

Again, thank you a lot! Marking this as solution now.


glad to hear that your issue is resolved now. I’ve been asking in my thread whether TLP is doing anything at all when on AC. @Yochanan replied it serves no purpose, therefore I disabled TLP completly because I am on a desktop computer (systemctl disable tlp).

I guess TLP shouldn’t have been turned on at all in the first place, that was the main issue. So I don’t know if there’s a buggy function that should detect whether the system is running on a notebook or a desktop computer. Maybe someone from the Manjaro team can answer that?

Oh, good! If it does not need to run, I will just shut it down, too.

And yeah, someone should definitely have a look into that.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.