Sleep on kde doesn't lock the screen

when I close my laptop lid it goes to sleep but doesn’t lock the screen, meaning that when the laptop wakes from sleep the screen is unlocked and anyone can access the laptop. this wasn’t the default behavior before. I think the last update caused that.

Hi @Graham1384,

AFAIK you have to set it in System SettingsWorkspaceScreen locking.

There’s an option for After waking from sleep. Enable that and try again.

Hope this helps!

1 Like

Mine is the same as yours. I also had to mention that it doesn’t happen always. Maybe 1 out of 3 times

1 Like

Then I think there’s some background process inhibiting the lock mechanism…I don’t know whatit could be, though. You’ll have to experiment I think.

Trying to reproduce. My bios is set to wake the computer with a lid lift but the lock screen come up, I enter the password goes to my desktop and then goes back to sleep. I was using Wayland and switched back to X11 and that issue went away. Maybe change that one setting from 5 seconds to 0 seconds might help??

I think it’s related to a bug in last update. Because it started from two days ago when I updated the system