Sleep mode + high system load = crash

Hi there,

I have an ongoing issue with my Manjaro setup (most recent version) on My MSI Notebook.

If I activate the sleep mode at high system load => e.G. Minecraft is running, or a build job is running, it goes into sleep mode properly. But if I try to wake it up, the screen remains black, and it seems to enter something like an infinity loop, with extreme high system load => fans 100%, device getting hot.

The only escape is a hard reset in these situations.

Is this a known issue ? Would appreciate any thoughts on this :slight_smile:

Hi and welcome to the forum :+1:


That could be caused by your graphics drivers not being properly initialized…
Does it resume correctly when you try without any heavy jobs?
If so it is cause by those jobs ofcourse.


PS: Suspending+Resuming while running:

  • A build job is asking for trouble by definition because you interrupt the process that depends on time data…
  • An online game is also asking for trouble because you cut off the connection by force without the game knowing about it.

If these are the cause then your system does not crash, but only “locks-up” which is something completely different technically speaking…


Try to avoid hard resets at all times to prevent bricking your system, eg, your system becoming un-bootable…
See this topic for a safer alternative:

2 Likes

Thank you for your suggestions, and I see your points. The thing is with other OSes e.g. macOS, Windows etc. this is no problem. And it should be possible to enter sleep mode in Minecraft. It is not only in Online Gaming, but also in Single Player mode.

I think you are right that it is a lock-up up, but the question is what can I do about this ?

Regarding the questions:

  • Yes it does work without heavy Jobs most of the time, not always!
  • Sometimes my system does not even halt, but locks ups during entering sleep mode :slight_smile:

And thank you very much for the warm welcome to the forum :slight_smile:

Maybe try checking some of these topics: Search results for 'laptop sleep mode freeze' - Manjaro Linux Forum :thinking:

Indeed, I found a guide (thanks to your search query which somehow found an article which I had not found yet).

I followed it through and it seems to work for now :slight_smile:

I added amd_iommu=fullflush to the boot options, which resets the IOMMU instead of disabling it completely.

Thank you for your help @TriMoon :slight_smile:

I will re-open this in case of reoccurrence.

Just incase it interests you or any other reader in future:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.