Sleep doesn't work

Suspend mode sometimes does not work. The laptop seems to fall asleep (the screen goes blank, the cooler becomes quieter), but it does not go to sleep completely: the cooler does not stop, the processor continues to warm up. At the same time, it is no longer possible to wake the laptop with any actions. Only hardreboot.

Here is the kernel log after pressing the sleep button in the bug time.
pastebin

Here is full kernel log:
pastebin

My system:
Operating System: Manjaro Linux
KDE Plasma Version: 5.24.5
KDE Frameworks Version: 5.95.0
Qt Version: 5.15.5
Kernel Version: 5.15.50-1-MANJARO (64-bit)
Graphics Platform: X11
Processors: 4 × AMD A10-5750M APU with Radeon™ HD Graphics
Memory: 10.9 ГиБ of RAM
Graphics Processor: AMD ARUBA

I see a lot of bluetooth errors. Hmm.

What if you just updated to the 5.18x kernel. I use it and it works great. See if that makes a good change.

On 5.18 my Bluetooth just doesn’t work after sleep out. I thing there is Intel firmware problem…

firmware. Yeah, could be. Damn.

in KDE energy-saving settings, there is the option to leave Bluetooth and WiFi
state unchanged while sleep. You could try check those options.

I see in the update earlier this morning bluetooth files got updated. …

can u explane? I cant find this

This is full log after sleep button pressed.

I think my trouble in this:


 kernel: Freezing user space processes ... (elapsed 0.001 seconds) done.
 kernel: OOM killer disabled.
 kernel: Freezing remaining freezable tasks ... 
 kernel: Freezing of tasks failed after 20.007 seconds (0 tasks refusing to freeze, wq_busy=1):
 kernel: Showing busy workqueues and worker pools:
 kernel: workqueue events: flags=0x0
 kernel:   pwq 0: cpus=0 node=0 flags=0x0 nice=0 active=1/256 refcnt=2
 kernel:     in-flight: 59652:rtsx_usb_update_led [rtsx_usb_sdmmc]
 kernel: workqueue events_freezable: flags=0x4
 kernel:   pwq 0: cpus=0 node=0 flags=0x0 nice=0 active=1/0 refcnt=3
 kernel:     in-flight: 88:mmc_rescan [mmc_core]
 kernel:     inactive: mmc_rescan [mmc_core]
 kernel: workqueue pm: flags=0x4
 kernel:   pwq 0: cpus=0 node=0 flags=0x0 nice=0 active=0/0 refcnt=2
 kernel:     inactive: pm_runtime_work
 kernel: pool 0: cpus=0 node=0 flags=0x0 nice=0 hung=0s workers=4 idle: 85671 83516
 kernel: 
 kernel: Restarting kernel threads ... done.

But I don’t know what is it.
After this laptop tries to sleep a few times, then wakes up, but cannot wake up completely (another bug, apparently. In the radeon driver).
It is very strang think…

I’vee tried 5.10, 5.15, 5.18.