Sleep doesn't work anymore

Hey guys,

I’m not a Linux guru one bit.
I switched to latest version of Manjaro-KDE since its the only distro that everything worked perfectly out of the box . so really loving it.

But suddenly I encounter the following issue:

I’m using the sleep option quite often and it worked perfect on my laptop for about a month.

Today i tried hibernate for the first time just to see if it works well, and it didn’t:

After computer turned off (hibernated), when turning it back on it “forgot” about being in hibernation and just booted regularly.

That’s not my problem though (although it would be nice if it would be working).

The problem is that now Sleep also stopped working. When trying Sleep now it goes to the black screen with the blinking text line, and then loops back to the login screen.

It happened litteraly after hibernation didn’t work.

What can I do to revive the Sleep option?

Thanks a lot

I had a similar issue, uninstalling tlp helped, it seems to interfere with kde’s powermanagment.

Removed tlp and sleep works again. Thanks!!

Hibernate still doesn’t work ,it has same function as shutdown