Since Firefox 85 update vaapi is broken

just like the title says after I updated to Firefox 85 my vaapi is broken.
I had it activated via this method here:

is there something I have to change or redo to activate it again?

As discussed in this thread Firefox Nightly 86 and VDPAU / Nvidia , it looks like Firefox currently has issues with hardware acceleration, in particular if you are not on a genuine VAAPI (that means Intel or AMD graphics) system.
There is a translation layer from VAAPI to VDPAU for Nvidia users but Firefox currently does not work with it.

mhhhh okay.
I’m on an Intel System (i5 7300hq) and it worked with Firefox 84. So did Mozilla botch it with the update to 85 or am I just missing a new setting or something like that?

That’s indeed possible. What you can try to do in order to verify is:

  1. Downgrade firefox to version 84 and check if it works again.
  2. Install firefox-nightly and check if it works on this version again.

Finally, one question: Are you using the graphics built in the CPU or do you have a dedicated graphics card? If so, which one?

I’m using the the graphic built in the CPU, so the Intel HD 630.
I will now try to downgrade Firefox first. Lets see if this works.

yep downgrade to 84 makes vaapi work again. But sadly it does now not let me use my old profile so all my passwords and bookmarks and what not are gone :frowning:
oh how I love linux :sweat_smile:

Strange. What error occurs? Or is the profile simply empty?

I don’t think that this is Linux-related. Looks more like an error on Firefox’s side. Fortunately, I have Firefox Sync enabled which seems to prevent me from such issues.

More general remark: While scrolling through the net and the forums, it looks like there is almost nobody using Firefox anymore. There are no responses in any Firefox related threads whatsoever.

Looks like everyone has uninstalled Firefox now because of Mozilla apparently supporting censorship: We need more than deplatforming - The Mozilla Blog

fixed the profile error with about:profiles and changing to my old profile after i upgraded again.

And i currently need Firefox due to the great Webex implementaion for university. Can’t get around this currently.

You could try to additionally set

media.rdd-vpx.enabled = false

in about:config. That made vaapi come back for me.
Don’t ask me why exactly, but it’s relatively new and apparently necessary at this point.
I wish Mozilla would get their sh** together and make video acceleration under Linux just work without all this fiddling about, but yeah…

1 Like

I just checked again. Vaapi works only now with h264. with our without the media.rdd-vpx.enabled = false. So i just have to use the h264ify addon.

Could be that your iGPU is not supporting decoding of those never codecs like VP9. You can check that with vainfo

The i5 7300hq (HD630) can decode VP9. It worked before the update. Maybe it’s a new setting that I need to change or just broken with Firefox 85 :frowning:

On my AMD laptop also VP9 content seems to work again now, even though the efficiency of FF hw decode is worse than e.g. with mpv. That seems in particular true for content with 60fps, but was the case before, as well.

At least, starting FF in the console by “MOZ_LOG=“PlatformDecoderModule:5” firefox”, I can see vaapi being used again, which was not the case anymore prior to changing the setting I mentioned earlier.