Signature from "TheCynicalLiger..." is invalid

Hi all,

I have a roccat keyboard (Roccat MKFX) and mouse (Roccat Kone EMP)

I have been trying, unsuccessfully, to update the drivers for them from the CynicalTeam repository. It installed fine from there, originally, but since then there was an upgrade and it didn’t want to install. I get the following error:

Error: libgaminggear: signature from "TheCynicalLiger <wayne6324@gmail.com>" is invalid
Error: roccat-tools-common: signature from "TheCynicalLiger <wayne6324@gmail.com>" is invalid
Error: roccat-tools-ryosmk: signature from "TheCynicalLiger <wayne6324@gmail.com>" is invalid
Error: roccat-tools-ryosmkfx: signature from "TheCynicalLiger <wayne6324@gmail.com>" is invalid
Error: Failed to commit transaction: invalid or corrupted package (PGP signature):

I am using this website, and the instructions at the bottom:

I have followed (copied and pasted) the neccesary info into /etc/pacman.conf. I have also imported the keys as described in the next step.

I have also tried pacman-key --refresh-keys and it refreshed 141 keys (I think, not exactly sure)

Seeing as everything works fine, I don’t have a problem keeping it as it is. However, there seems to be more packages that could be upgraded and never is, so I just want to make sure that this isn’t “keeping them back”, so to speak.

Any thoughts and suggestions are welcome.

(Also, I’m doing research/keeping up to date for if and when my current keyboard and mouse will need to be replaced. So any suggestions for a mechanical, preferably RGB BACKLIGHT, keyboard and preferably RGB mouse, linux compatible, would be greatly appreciated.)

EDIT:
After installing, or trying to install Testdisk just now, it seems that fear is kind of warranted. I added libgaminggear roccat-tools-common roccat-tools-ryosmk roccat-tools-ryosmkfx to IgnorePkg in /etc/pacman.conf and, lo and behold, it installed Testdisk.

Hi. I think you can just disable that repository and install the needed packages from AUR.

1 Like

Y’know what, @kainonergon?

I’, just going to go ahead and kick myself now. I didn’t think of this. Stupid, I know. But it solved it. (At least for now, will continue to monitor and take it from there.)

Thank you!

1 Like

Hi again @kainonergon!

I just did a reboot and all seems to still be well!

Thank you VERY much!

2 Likes

hey mate sorry about that im working on fixing this atm should work fine if you download the files from the site then do pacman -U packagename-file

hey mate i have fixed my package now :slight_smile: