Signal-Desktop strange launch behavior

Signal-Desktop launches oddly in this o/s. On most other operating systems, when Signal is launched with the --start-in-tray --use-tray-icon command line options, the application launches minimized. With Manjaro, however, the application launches in a regular window. It is in the tray, but it’s weird to launch in an open window.

Obviously this is a very low-priority issue; but seems like a bug, when the behavior is noticeably different from other Linux’s & Windows.


Welcome to the forum! :slight_smile:

Two things here…

  • First of all, make sure that you always start with an empty session, not with a restored session . If you have Plasma restore the previous session on login, and you had an application auto-started but running in the tray, then this application might get started a second time, and then this second session won’t be minimized to the tray.

  • I don’t use Signal Desktop, but if you right-click the title bar of the open window, then you’ll get a popup menu, from which you can choose “More Actions”, which gives you a submenu with two very important tweaking options. The one you want from that is “Special Application Settings”. You should be able to tell it there to start minimized.

Thanks for the suggestions, unfortunately none helped:

  • I normally run with an empty session at boot. But even saving a session with Signal minimized didn’t help–Signal continued to open in a normal window.
  • Setting special window or application to minimized and clicking “on” won’t stick either. It keeps reverting to minimized “off.”

What’s the next step to reporting this as a bug? I’m new to Arch/Manjaro; I’ve been in Debian based distro’s for 20 years.

Just tested this on XFCE stable. Behaviour is as expected, it starts nicely in the tray.

Disregard, there was an odd “null,” or other nearly invisible character, that had snuck into my command line options when I copied & pasted them from a how-to web site.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.