Shutdown problems, desktop freezing

kde

#1

I just recently installed Manjaro KDE. I’m having problems with Shutdown, Reboot, and Logout, whenever I attempt any of these, the desktop just freezes indefinitely and it doesn’t Shutdown, Reboot etc.
I’ve had this problem on Antergos aswell so I’m assuming it might be an Arch problem. I feel like I’ve tried everything, nothing has worked.

I’m pretty new to Linux, so I’d appreciate answers that are well explained :stuck_out_tongue:


#2

First of all we can’t help if we have no idea what your system is. :wink:

So, have a read of this post:

and then post some information here (as text), principally inxi -Fxxxz.

As a new user you should also read:

as well as looking through the other threads in the #faq section.


#3

Thanks for the quick answer.

inxi -Fxxxz seems to hang, and also my touchpad won’t work after that command, until restart.

EDIT: The touchpad thing seems to be inconsistent.


#4

Ah, this sounds like an Optimus laptop issue.

Can you boot the live installer and run it there?


#5

Actually, I can’t even do that, worked fine when I installed Manjaro yesterday, now I’m stuck at
A start job is running for LiveMedia MHWD Script.
with drivers=free and stuck at
Started TLP system startup/shutdown.
with drivers=nonfree.

Seems like my laptop is cursed with one problem after the other.


#6

Worth reading:

The other option (if it’s available) is to disable one or the other GPU in your BIOS settings. Pascal-era Nvidia GPUs are pretty light on battery use anyway.


#7

I’ve tried the solution linked above, no luck, still stuck at Started TLP system startup/shutdown.

I’ve also looked through pretty much all the BIOS settings (there aren’t a lot), and I’m pretty certain there are no options regarding the GPU.

EDIT: My laptop is an ASUS ZenBook Pro UX501VW btw, don’t know if it helps.


#8

When you get to grub, press e, then append a “3” to the line starting with Linux. This should get you into a command prompt. Then run dmesg, and journalctl -b. Look for anything funky. Lastly, try running startx from the command prompt.