Shutdown or reboot held up by Bad USB port

Hi all,

I have spent some time looking up commands to try and find which USB port is the offending USB port that holds up every shutdown or reboot for several minutes. When I run various commands no USB devices seem to match the usb6-port3 which it claims is faulty and cannot enable. No idea why it wants to enable when the system is shutting down but anyway. I have tried running a few commands but I will post the closest results below.
So what I want is to either find and fix the offending hub or disable it so I no longer get this error holding up shutdown/reboot.

Bus 006 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub

find /dev/bus:

find /sys/bus/usb/devices/usb*/ -name dev:

susb -D /dev/bus/usb/006/001:
Device: ID 1d6b:0003 Linux Foundation 3.0 root hub
Couldn’t open device, some information will be missing
Device Descriptor:
bLength 18
bDescriptorType 1
bcdUSB 3.00
bDeviceClass 9 Hub
bDeviceSubClass 0
bDeviceProtocol 3
bMaxPacketSize0 9
idVendor 0x1d6b Linux Foundation
idProduct 0x0003 3.0 root hub
bcdDevice 5.04
iManufacturer 3
iProduct 2
iSerial 1
bNumConfigurations 1
Configuration Descriptor:
bLength 9
bDescriptorType 2
wTotalLength 0x001f
bNumInterfaces 1
bConfigurationValue 1
iConfiguration 0
bmAttributes 0xe0
Self Powered
Remote Wakeup
MaxPower 0mA
Interface Descriptor:
bLength 9
bDescriptorType 4
bInterfaceNumber 0
bAlternateSetting 0
bNumEndpoints 1
bInterfaceClass 9 Hub
bInterfaceSubClass 0
bInterfaceProtocol 0 Full speed (or root) hub
iInterface 0
Endpoint Descriptor:the closest results below.
bLength 7
bDescriptorType 5
bEndpointAddress 0x81 EP 1 IN
bmAttributes 3
Transfer Type Interrupt
Synch Type None
Usage Type Data
wMaxPacketSize 0x0004 1x 4 bytes
bInterval 12
bMaxBurst 0


Try turning off USB 3.0 legacy mode in the BIOS.

You could maybe also look at your Motherboards manual to find which connector corresponds to usb6-port3
Seems your device is mentioned on this page also: Lenovo Legion 7i - ArchWiki (but not your issue with it)
(More search results)

I tried that and all it did was add the same error on booting up Manjaro.
EDIT: X99 motherboards are known for USB issues and my USB ports sometimes do have issues so its not necessarily a linux problem this one but would be nice if I could find a way to disable the offending device/hub just to get rid of this error.