Showing boot messages instead of splash on boot - pinephone

Hello! I’m trying to get pinephone to display the boot messages during boot instead of the splash screen as it often hangs and it would be useful to see if there is an error

For this I edited /boot/boot.txt under the bootargs variable and removed the splash file path and the quiet keyword. It also has loglevel=4

After adjusting this file I run pp-uboot-mkscr which doesn’t report any error.

However, now the boot shows no splash and no log messages. Only a black screen.

Do you know how to get it to display the boot messages please?

Thank you.

Hi, I’d also like to do this, but I don’t know how exactly.

The best I could do is to increase the loglevel value to 7, this causes more kernel messages which can help with some things.

I’d still like to be able to see messages from systemdm they would be a little more useful to me. I tried messing with systemd.show_status=true, but it doesn’t do anything.


/boot/boot.txt you should be able to add to a line line near the beginning:

setenv bootargs console=${console},${baudrate} root=PARTUUID=${uuid} rw rootwait

change to:

setenv bootargs console=tty1 console=${console},${baudrate} root=PARTUUID=${uuid} rw rootwait

After updating boot.txt, recreate boot.src using “mksrc”.

Hi, thanks for your response.

No luck for me, it still doesn’t show systemd boot messages.

it was from an older guide so things might have changed. Try replacing tty1 with tty0 after that i’m out of ideas.


I have tty0 and doesn’t work :frowning:

My bootargs:
console=tty0 console=${console} earlycon=uart,mmio32,0x01c28000 consoleblank=0

Then root, rootwait etc.

Any ideas?
Thank you for helping.

I can confirm, I had tty0 in there before, the result is still the same.