Shortcuts using hyper are broken, show mysterious Khmer letter instead

I recently reassigned my Caps Lock key into a Hyper key (by adding Option "XkbOptions" "caps:hyper" to /etc/X11/xorg.conf.d/00-keyboard.conf) and it worked well. However, setting custom shortcuts using this hyper key doesn’t go so well. I tried, for example, to set hyper+a to run rofi -show run from the KDE system settings, but when I do that, the GUI shows that I’ve pressed a button called “ៀ”, which is U+17C0, a Khmer language character. Subsequently, pressing hyper does show the menu (without pressing the “a” key!), and if I try to set another shortcut using hyper+w for example, it asks me if I want to reassign ៀ.

I use fcitx5, I don’t speak Khmer, and I can’t think of any reason why the Khmer language is involved in this.

EDIT: I just got the ability to add images. So here it is:

Thank you.

Qt doesn’t support hyper as modifier. See: doc.qt. io/qt-6/qt.html#KeyboardModifier-enum
It won’t be able to distinguish between meta and hyper by Qt.

Also it’s actually a known issue that this widget will show some garbage if the key event is not supported or not recognized correctly.

Oh. What do I do then? Are there any plugins to Qt that enable it to recognize hyper? Are there any alternatives to the hyper mapping? Can I switch away from Qt? What are my options here?