Shortcuts not working with some keyboard layouts

Hi everyone!
Global shortcuts in XFCE not working anymore if it using letters - while current layout is not EN (English).
Problem appears since one of the recent updates, i’m trying to find some solution on this and arch forums but working solution not found yet (

Steps to reproduce:

  1. Create shortcut with Keyboart Settings → Application Shortcuts, Super+S - gimp (for example).
    Note: shortcuts like Alt-F2 is worked normally with any layouts.
  2. Switch to any layout that not using exactly letter S on this key.
    For example, I’ve checked some of them:
    Georgian, Ukrainian, Indian - use own letters/symbols on this key, and this shortcut not worked.
    English, French, Swedish, Spanish, Polish, Czech, Latvian and others - use S letter on this key - and shortcut is working in any of them.

Any ideas?

Upd. I’ve find exactly the same problem described in other topic on forum (131597), but no working solution there too.

Upd.Upd. I’ve found some useful information about it, but… how it worked for me before many years before? :sweat_smile: Looks like some solution to this problem existed before the recent update

Keyboard shortcut handling for people using local keyboard layouts is broken (freedesktop bug 865 xkb) (this bug is now 16 years old). Not everyone lives in English-speaking countries. This doesn’t affect Wayland