Sharing problem

I just rebooted and tried the share again.
Now I have a different but similar error as follows:

‘net user’ returned error 255: net usershare add:
cannot convert name “Everyone” to a SID. (Access denied} A
process has requested access to an object but has not been
granted those access rights…

Try this:

net usershare add --long NameOfShare /path/to/shared/folder "A Comment" "Everyone:F" guest_ok=y

Keep in mind that everyone has full access and guests are allowed here. It is just for testing.

On my system it works., when apparmor is completely disabled and the module is not loaded.

I get the same error in terminal as the last error I mentioned.


Sorry, but if you had done, what I said, then it should work. However… I cannot reproduce your problem.

Maybe just remove apparmor completely:

pamac remove apparmor

Do a reboot.

Tried to remove but received error as follows:
could not satisfy dependencies:

  • removing apparmor breaks dependency ‘apparmor’ required by snapd

Well snapd needs apparmor to work. Do you really need snap packages? If so, then you have to deal with the apparmor rules and customize it yourself. I cannot help you here.

or remove everything what depends on apparmor and apparmor:

# Just show what will be removed:
pamac remove --cascade --dry-run apparmor
# Remove it:
pamac remove --cascade apparmor

Thank you megavolt for trying.
I have trouble finding what I want so I want to keep the snap source of packages.
I don’t believe that samba can’t work with apparmor being installed.

I will keep looking on the internet and maybe there is someone else on in this forum who knows more about samba than I do (which is not much).

If I cant fix this I’ll look for another rolling release distro.

Have a look at these, if you haven’t seen them already:

Thank you for the suggestions.
My browser (nemo) has Sharing Options in the context menu that I use to try to share.
The Setup and Troubleshooting link is mostly beyond me at this stage.

The error I am getting contains "cannot convert name Everyone to SID.
What does that mean? what is SID?

Edit: I have provided my password to samba with sudo smbpasswd -a user.
Where ‘user’ is my username.

I am surprised that others are not complaining about this issue.
I found a page from Manjaro about exactly this error as follows:

My installation came with Kernel 6.1.7.-1 - it behaves like above.
I downloaded Kernel 5.15.89-1 LTS - at also behaves like this.

SID → Security Identifiers
It is a Windows term. “Everyone” on Linux gets translated to “S-1-1-0”

Thank you for the link, but didn’t help.
If “Everyone” on Linux gets translated to “S-1-1-0”, they why do I get the error
“cannot convert name Everyone to SID”?
I think that this is a Majaro problem as I had no such problem, on the same machine, the same partition settings, on Linux Mint. I installed Linux Mint a week before Majaro but then discovered that there are rolling release distros.

Maybe my work around this problem will have to be going back to Linux Mint or trying another distro. Linux Mint also had much more and better GUI settings.
My reason for installing a linux distro was that my HDD crashed and after replacing the HDD, had to install something - I could have just restored Win 7 from my backup but decided to try win 10. It took about 1 hour and worked fine. Unfortunately, it is too slow on this machine to use, so decided to try a linux distro. I looked at a number of them and decided on Linux Mint. Took a week to get it to look like what I am used to and work properly. Then discovered that there are such things as rolling release distros and that’s when I decided to try Majaro. I’ve been trying to get this installation to work properly for about a week. You can see why windows users are so reluctant to even try Linux. I have actually restored my win 7 and now dual booting with Manjaro.
Sorry for the long story but it probably doesn’t belong in this thread.


Yeah I totally understand that, but ArchLinux and all ArchLinux based Systems like Manjaro share the same common goal: Simplicity, but not beginner friendliness. While you can fix problems with ease, also samba and apparmor, you need knowledge, even if it is simple. It needs more maintenance compared to Linux Mint and especially debian-based systems, because it always updates your system to the next new version while Debian often do only security updates and not feature updates.

Manjaro itself is made to be easily installed and also to configure, compare to bare ArchLinux, but it is by all mean not beginner friendly like debian based systems: Ubuntu, Linux Mint, PopOS.

Let me explain it in short:

Apparmor is a module that uses kernel techniques to sandbox samba. Apparmor rules locks samba into a jail, where it is only allowed to do what the rule says. Therefore, if it doesn’t allow samba to convert it, then it will result in an error here.

However… did you install manjaro-settings-samba ?

I can only say, that samba work perfectly well on my system, without snap and without apparmor. I don’t need both when I run this in my local network.

1 Like

Yes I did install manjaro-settings-samba but couldn’t work out how to launch it.

Tried to remove apparmor but refused due to dependency from snapd.
So tried to remove snapd and also refused due to dependency.

frank@Dell1 ~]$ pamac remove apparmor
Checking dependencies…
Error: Failed to prepare transaction:
could not satisfy dependencies:

  • removing apparmor breaks dependency ‘apparmor’ required by snapd
    [frank@Dell1 ~]$ pamac remove snapd
    Checking dependencies…
    Error: Failed to prepare transaction:
    could not satisfy dependencies:
  • removing snapd breaks dependency ‘snapd’ required by libpamac-snap-plugin
    [frank@Dell1 ~]$
pamac remove --cascade apparmor

Thank you. That did the trick. Now removed.
I rebooted, tried the share again in the context menu and guess what, it worked.
Now it shows that it is sharing.

Unfortunately that’s as far as it goes.
In the file manager, and Networks, the computer is visible now but selecting that required the password and then an error:
Unable to mount location.
Failed to retrieve share list from server: Invalid argument.

On the other computers there is no sign of this computer.

enable avahi-daemon

sudo systemctl enable --now avahi-daemon

For your information - there is several topics in the #contributions:tutorials section on samba - both setup and troubleshooting.

1 Like

It seems that you are not using gnome/nautilus, but take a look here:

Add this option under the [global] section:

    client ipc signing = auto
 then restart samba (systemctl restart smb.service) or reboot

linux-aarhus, I tried your suggestion to enable avhi-daemon.
It didn’t work. However, looking into your links I found another link about sharing NTFS on Majaro:

I tried to complete the instructions but I received ‘Failed’ in terminal.
But when I tried to access the partition on my windows machine, there it was.
It looks like it is now working as I expected in the first place.
Thank you everyone for helping.
I can now go to the next problem - I’ll start another post.
Thank you again.