Shares not mounting through fstab after update 01-01-2021

After i updated my system (Manjaro Cinnamon) nfs shares are not mounting anymore through fstab.

Tried downgrading nfs-util, no dice
Tried downgrading systemd, no dice
Tried sudo systemctl enable NetworkManager-wait-online.service, works once after reboot, won’t after that.

I ended up adding at the end of the optionlist in fstab and enabled this:
sudo systemctl enable systemd-networkd-wait-online

After this last change it seems to mount at every reboot.

I just add this to inform other users who might have the same problem.
I don’t know what this problem causes though so if anyone has a clue?

1 Like

Same problem here Works fine when I mount it manually after boot.

I get the following boot error: “Dependency failure for remote file system”

Thank you for sharing this information. I also got the same error “Dependency failure for remote file system”

I have been searching for weeks on how to fix my Synology mounts that work perfectly fine in 4 other distros via fstab. I followed your advice of adding and then sudo systemctl enable systemd-networkd-wait-online for it to finally work correctly.

Glad to be a helping hand here!

1 Like
sudo systemctl enable systemd-networkd-wait-online

I’m curious…what happens if no network is available on boot? hangs until I plug in the network cable?

1 Like