Shared SSD partition between Windows 10 and Manjaro is set to Read-Only

Hello! I’m new to Manjaro and have dual-booted my PC with it as Windows completely broke my audio and is just unreliable (imo)
I have 3 main partitions
a Windows install on my old HDD, my Manjaro Install Partition on my SSD, and an 800GB Partition on my SSD which i used along with my Windows install, i tried to mount it by modifying /etc/fstab like so:

  GNU nano 5.7                                       /etc/fstab                                        Modified  
# /etc/fstab: static file system information.
# Use 'blkid' to print the universally unique identifier for a device; this may
# be used with UUID= as a more robust way to name devices that works even if
# disks are added and removed. See fstab(5).
# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=83697b66-aefd-409b-8cb7-ce05ad61c0b9 /              ext4    defaults,noatime 0 1
UUID=142F-7985                            /boot/efi      vfat    umask=0077 0 2
UUID=DEE8446AE844434F /home/ndxdirectorscut/SSDMount ntfs-3g auto,rw,defaults,uid=1000,gid=1000,umask=022,utf8 0 0

UUID DEE8446AE844434F is my Data SSD Partition, and when mounted it is set to Read-Only

Unless Windows reset it, fast startup is already disabled.

How can i fix this?

Welcome here, @NDxDirectorsCut,

I would recommend you to use the following tutorial to mount the partition:

Just checking: Is ntfs-3g actually installed?

The kernel can only read ntfs without it.

sudo pacman -S ntfs-3g

it is installed

Will that help? the partition is mounted and i can access it, but whenever i try to change it to Read&Write, it says it’s a Read-Only filesystem.

I decided it was probably best if i follow the tutorial anyway, however im failing to mount the partition,
the mount point is the folder /home/ndxdirectorscut/ssdfiles/ and i created the file “home-ndxdirectorscut-ssdfiles.mount” and made it’s contents this:

Description=Mount SSD Partition



then when trying to do
systemctl show -p ActiveState -p SubState --value home-ndxdirectorscut-ssdfiles.mount
it outputs
inactive dead
then when trying sudo systemctl start home-ndxdirectorscut-ssdfiles.mount
it outputs Job failed. See "journalctl -xe" for details.

What ist the output of journalctl?

[N ~]# journalctl -xe
iul 02 16:20:55 N audit: BPF prog-id=18 op=LOAD
iul 02 16:20:55 N dbus-daemon[1011]: [session uid=1000 pid=1011] Activating via systemd: service name='org.gtk.v>
iul 02 16:20:55 N systemd[989]: Starting Virtual filesystem metadata service...
░░ Subject: A start job for unit UNIT has begun execution
░░ Defined-By: systemd
░░ Support:
░░ A start job for unit UNIT has begun execution.
░░ The job identifier is 211.
iul 02 16:20:55 N dbus-daemon[1011]: [session uid=1000 pid=1011] Successfully activated service 'org.gtk.vfs.Met>
iul 02 16:20:55 N systemd[989]: Started Virtual filesystem metadata service.
░░ Subject: A start job for unit UNIT has finished successfully
░░ Defined-By: systemd
░░ Support:
░░ A start job for unit UNIT has finished successfully.
░░ The job identifier is 211.
lines 2074-2092/2092 (END)

That says nothing about your systemd-mount-file

Try restart the service with
sudo systemctl restart home-ndxdirectorscut-ssdfiles.mount
and after that post what is the output of
sudo systemctl status home-ndxdirectorscut-ssdfiles.mount
journalctl -xe

When looking at the output of systemctl status, it said it was falling back to read-only despite the fact i disabled fast startup, Windows was still hibernating when shutting down, i had to use command prompt to disable hibernating and shutdown from there.

restarting the service on Manjaro after doing that not only made it work, but i can now access my NTFS Partition, thank you @Cedric_K and also huge thanks to @Wollie for the tutorial!

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.