Setup Ricoh SP312W on Pi 4

Yesterday I installed XFCE on a Ras Pi 4. Did the update.

Installed gparted and formatted a usb drive. All good.

Installed cups.

Tried lpview but it’s not in the packages available.

So I did a systemctl to try to find a reference to a printer and in the output, in RED, were the following :-

proc-sys-fs-binfmt_misc.mount
nmb.service
systemd-networkd-wait-online.service

I couldn’t find anything in the output referring to printers and so I’m a bit lost as to what to do.

Also bothers me why the things listed above are printed in RED

Perhaps I can’t see the printer because of the errors ???

So basically I’m lost.

I have searched on forum but arm printer posts seem to be about what to do AFTER the printer has been identified.

Hope this makes sense to someone. :upside_down_face:

It occured to me to push the WiFi Access Button on my Broadband router, guess what, I can now see the printer on Cups via web page.
Red lines from systemctl just mean the services are either not there or not started.

So that’s a double Numpty from me. Will mark as solved. :slight_smile:

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.