Setting up nvidia optimus; nvidia not detected

I have a fresh installation of Manjaro i3 community edition.

Unable to detect nvidia
I have bumblebee installed by default -

[reik@reik-msi ~]$ sudo mhwd -a pci nonfree 0300
> Skipping already installed config 'video-hybrid-intel-nvidia-bumblebee' for device: 0000:01:00.0 (0300:10de:1ba1) Display controller nVidia Corporation GP104M [GeForce GTX 1070 Mobile]
> Skipping already installed config 'video-hybrid-intel-nvidia-bumblebee' for device: 0000:00:02.0 (0300:8086:3e9b) Display controller Intel Corporation

But, nvidia is not detected.

[reik@reik-msi ~]$ primusrun nvidia-smi
NVIDIA-SMI has failed because it couldn't communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.
[reik@reik-msi ~]$ primusrun nvidia-settings

ERROR: NVIDIA driver is not loaded


ERROR: Unable to load info from any available system

But… I probably do not want Bumblebee to work… because of the following -

Want to install Nvidia Optimus
Going by this article - https://wiki.archlinux.org/index.php/NVIDIA_Optimus ,
The second point mentioned states -

  • using the official Optimus support included with the proprietary NVIDIA driver, which offers the best NVIDIA performance but does not allow GPU switching and can be more buggy than the open-source driver

I assume this is akin to Microsoft’s dynamic GPU switching only not as optimised? And, I should get more battery life than just using the Nvidia GPU.
What nvidia drivers would I need to set this up before I can follow the config instructions in that article? I assume I would need to remove the bumblebee drivers. Would video-nvidia and video-linux be the drivers I would need? (Reading off Manjaro Settings Manager)

try optirun nvidia-smi instead

[reik@reik-msi ~]$ sudo optirun nvidia-smi
[ 3799.888474] [ERROR]Cannot access secondary GPU - error: Could not load GPU driver

[ 3799.888545] [ERROR]Aborting because fallback start is disabled.

did you select nonfree drivers during installation?

Yes. And I even ran sudo mhwd -a pci nonfree 0300 just in case.

Some files may have been in conflict, not cleared. I suppose you didn’t use mhwd, or just did manual changes (the Arch way).
Check relevant system folders

You may want to try the Manjaro PRIME options

It is a fresh install. The only driver related install/messing around I did was - sudo mhwd -a pci nonfree 0300 which said that all the drivers were already installed.

I feel like if I can’t get bumblebee to detect nvidia, it is pointless to even try thinking about configs that have modes that solely rely on Nvidia.

EDIT : Strangely, optirun is working now. I am not sure what happened. I made no changes since then. This is really weird >< Well as long as it is working.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.