Setting larger screen resolution (Manjaro guest in Parallels host)

Hi, I am absolutely a non-technical man. I have installed Manjaro, and set the display resolution to the highest of the alternatives that are presented in the settings menu. However, I could need to increase that a bit, as I have 5k iMac display (using Parallels VM) Any hints as to do this?
regards Rolf

hey, welcome to the forum. if i understand you correctly, you have manjaro installed in a VM thats being run from OSX.

i've never used parallels or anything apple for that matter but i would start with the settings of parallels and make sure that the resolution you want is specified (if it can be), that way manjaro picks it up as a valid resolution option.

if parallels automatically resizes based on the resolution of the guest OS (manjaro) then you can manually add an undetected resolution.
https://wiki.archlinux.org/index.php/Xrandr#Adding_undetected_resolutions

to make the added resolution persistent you can add a monitor configuration to xorg and add modelines to it.

or add the xrandr commands used to add the resolution to a display setup script that autostarts with xorg

I just thought I'd add to this topic: If someone feels like reverse engineering them through the totally illegitimate means of feeding them through a disassembler or decompiler, the so-called Boot Camp drivers for the AMD R9 M290X / M295X (2014) / M390 / M395 / M395X (2015) added support for the 5k resolution late last year. So while the OS does boot in 3840x2160 mode, the driver is capable of switching to the native resolution of the 5k models, using some as yet undocumented trickery.

Presumably it also has something to do with single versus multi stream protocol internally? As far as I know, the internal display uses two displayport channels to feed the 5120x2880@60 mode, otherwise it only needs a single channel for 3840x2160@60 and lower modes it happens to support.

No progress on that matter after this post
Source - https://bbs.archlinux.org/viewtopic.php?id=223178

Hi, and thanks for engaging. I would just add this info: When running Ubuntu, or Linux Mint, with the same Parallels settings, I can choose resolutions to over 3000x2000.

boot manjaro and post output of:

inxi -Fxxxz
hwinfo --monitor
xrandr --prop
cat /etc/X11/xorg.conf.d/*.conf

use the </> button when pasting terminal output so it's formatted properly. or you could also put 3 backtics above and below the output to do the same thing.

System:
  Host: manjaro Kernel: 4.19.45-1-MANJARO x86_64 bits: 64 compiler: gcc 
  v: 8.3.0 Desktop: Cinnamon 4.0.10 dm: LightDM 1.28.0 Distro: Manjaro Linux 
Machine:
  Type: Desktop Mobo: Parallels model: Parallels Virtual Platform 
  serial: <filter> BIOS: Parallels v: 14.1.3 (45485) date: 03/12/2019 
CPU:
  Topology: Single Core model: Intel Core i5-4690 bits: 64 type: MCP 
  arch: Haswell rev: 3 L2 cache: 6144 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 bogomips: 6986 
  Speed: 3492 MHz min/max: N/A Core speed (MHz): 1: 3492 
Graphics:
  Device-1: Parallels Accelerated Virtual Video Adapter driver: N/A 
  bus ID: 01:00.0 chip ID: 1ab8:4005 
  Display: x11 server: X.Org 1.20.4 driver: vesa tty: N/A 
  OpenGL: renderer: llvmpipe (LLVM 8.0 256 bits) v: 3.3 Mesa 19.0.4 
  compat-v: 3.1 direct render: Yes 
Audio:
  Device-1: Intel 82801BA/BAM AC97 Audio vendor: Parallels 
  driver: snd_intel8x0 v: kernel bus ID: 00:1f.4 chip ID: 8086:2445 
  Sound Server: ALSA v: k4.19.45-1-MANJARO 
Network:
  Device-1: Red Hat Virtio network driver: virtio-pci v: 1 port: 8200 
"info.txt" 38 lines, 1741 characters 

Sorry, but the two other commands I could not fix.

This is interesting. I wonder why the difference...
If you have the ability to easily check, it might be worth looking for 'x' or 'X' packages (X11) that are present in mint and not in manjaro.
There is certainly a way to do this manually through xrandr .. but if it works elsewhere it should be able to work here too, something is just missing ...

my bad, xorg-xrandr package is not installed by default, im sure there is a good reason (i just dont know what that reason is :sweat_smile:). hwinfo is not either i dont think.

sudo pacman -S xorg-xrandr hwinfo
then post those outputs, im also adding 1 more command to my previous post.

Only command I managed:

Read and parsed by systemd-localed. It's probably wise not to edit this file

manually too freely.

Section "InputClass"
Identifier "system-keyboard"
MatchIsKeyboard "on"
Option "XkbLayout" "no"
Option "XkbModel" "pc105"
Option "XkbVariant" "mac"
EndSection

Generated by mhwd - Manjaro Hardware Detection

Section "Device"
Identifier "Device0"
Driver "vesa"
BusID "PCI:1:0:0"
Option "DRI" "true"
EndSection

Section "DRI"
Group "video"
Mode 0666
EndSection

Section "Extensions"
Option "Composite" "Enable"
Option "RENDER" "Enable"
EndSection

Section "InputClass"
Identifier "Keyboard Defaults"
MatchIsKeyboard "yes"
Option "XkbOptions" "terminate:ctrl_alt_bksp"
EndSection

Hi, maybe this is a litle more consistent info from your commands?!
[rolfm@manjaro ~]$ inxi -Fxxxz
System:
Host: manjaro Kernel: 4.19.28-1-MANJARO x86_64 bits: 64 compiler: gcc
v: 8.2.1 Desktop: Xfce 4.13.4git-be04da tk: Gtk 3.24.8 info: xfce4-panel
wm: xfwm4 dm: LightDM 1.28.0 Distro: Manjaro Linux
Machine:
Type: Desktop Mobo: Parallels model: Parallels Virtual Platform
serial: BIOS: Parallels v: 14.1.3 (45485) date: 03/12/2019
CPU:
Topology: Dual Core model: Intel Core i5-4690 bits: 64 type: MCP
arch: Haswell rev: 3 L2 cache: 6144 KiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3
bogomips: 13973
Speed: 3492 MHz min/max: N/A Core speeds (MHz): 1: 3492 2: 3492
Graphics:
Device-1: Parallels Accelerated Virtual Video Adapter driver: N/A
bus ID: 01:00.0 chip ID: 1ab8:4005
Display: x11 server: X.Org 1.20.4 driver: vesa resolution: 1440x1050~N/A
OpenGL: renderer: llvmpipe (LLVM 8.0 256 bits) v: 3.3 Mesa 19.0.6
compat-v: 3.1 direct render: Yes
Audio:
Device-1: Intel 82801BA/BAM AC97 Audio vendor: Parallels
driver: snd_intel8x0 v: kernel bus ID: 00:1f.4 chip ID: 8086:2445
Sound Server: ALSA v: k4.19.28-1-MANJARO
Network:
Device-1: Red Hat Virtio network driver: virtio-pci v: N/A port: 8200
bus ID: 00:05.0 chip ID: 1af4:1000
IF: enp0s5 state: up speed: -1 duplex: unknown mac:
Drives:
Local Storage: total: 64.00 GiB used: 13.74 GiB (21.5%)
ID-1: /dev/sda model: Manjaro Linux 18-0 SSD size: 64.00 GiB
speed: 1.5 Gb/s serial: rev: DF2C scheme: MBR
Partition:
ID-1: / size: 62.74 GiB used: 13.74 GiB (21.9%) fs: ext4 dev: /dev/sda1
Sensors:
System Temperatures: cpu: 63.0 C mobo: N/A
Fan Speeds (RPM): N/A
Info:
Processes: 150 Uptime: 34m Memory: 1.94 GiB used: 814.4 MiB (41.0%)
Init: systemd v: 242 Compilers: gcc: 8.3.0 Shell: bash v: 5.0.7
running in: xfce4-terminal inxi: 3.0.34
[rolfm@manjaro ~]$ inxi -Fxxxz >info.txt
[rolfm@manjaro ~]$ hwinfo --monitor
[rolfm@manjaro ~]$ xrandr --prop
xrandr: Failed to get size of gamma for output default
Screen 0: minimum 800 x 600, current 1440 x 1050, maximum 1440 x 1050
default connected 1440x1050+0+0 0mm x 0mm
non-desktop: 0
supported: 0, 1
1400x1050 0.00
1440x900 0.00
800x600 0.00
1440x1050 0.00*
[rolfm@manjaro ~]$ xrandr --prop >>info.txt
xrandr: Failed to get size of gamma for output default
[rolfm@manjaro ~]$ cat /etc/X11/xorg.conf.d/*.conf

Read and parsed by systemd-localed. It's probably wise not to edit this file

manually too freely.

Section "InputClass"
Identifier "system-keyboard"
MatchIsKeyboard "on"
Option "XkbLayout" "no"
Option "XkbModel" "pc105"
Option "XkbVariant" "mac"
EndSection

Generated by mhwd - Manjaro Hardware Detection

Section "Device"
Identifier "Device0"
Driver "vesa"
BusID "PCI:1:0:0"
Option "DRI" "true"
EndSection

Section "DRI"
Group "video"
Mode 0666
EndSection

Section "Extensions"
Option "Composite" "Enable"
Option "RENDER" "Enable"
EndSection

Section "InputClass"
Identifier "Keyboard Defaults"
MatchIsKeyboard "yes"
Option "XkbOptions" "terminate:ctrl_alt_bksp"
EndSection

[rolfm@manjaro ~]$ cat /etc/X11/xorg.conf.d/*.conf >>info.txt
[rolfm@manjaro ~]$

adding >>info.txt puts the output to a text file which is why there is no terminal output..

without doing this your pasted output is a mess and hard to read, please edit previous post and add 3 backtics above and below the terminal output

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by Bytemark