Set proper audio device names on Raspberry pi 4

As noted above in this thread, the ongoing issue is the default sound output options for Sound Settings are garbage. On my kit that is corrected with these lines added to /etc/pulse/default.pa:

### Set meaningful output device descriptions for UI
update-sink-proplist alsa_output.platform-bcm2835_audio.stereo-fallback device.description='bcm2835 HDMI 1'
update-sink-proplist alsa_output.platform-bcm2835_audio.stereo-fallback.2 device.description='bcm2835 HDMI 2'
update-sink-proplist alsa_output.platform-bcm2835_audio.stereo-fallback.3 device.description='bcm2835 Headphones'

Also as noted above, the pacmd utility should be used to determine what entries are appropriate for a particular machine.

You posted above as “Having no sound at all via the new Pi Hut Speaker”. I could only assume your speakers had no sound output at all using the Pi Hut Speaker.

This thread was about proper names not showing up as opposed to I guess you could call generic names with some DE’s in it’s “Sound Settings”. They would show up with the right names in “Pulse Audio Settings” but all sound devices worked when clicked on the generic names in the DE’s “Sound Settings”.

This idea in this thread had issues for a global config when tested with multiple DE’s and switching back and forth with kms/fkms/kde (plasma/x11) and there is now way to configure any third party addon sound devices people may have.