Set permanent dev.i915.perf_stream_paranoid=0

How to set permanentny command “dev.i915.perf_stream_paranoid=0”?

Create a file in /etc/sysctl.d/

echo dev.i915.perf_stream_paranoid=0 | sudo tee -a /etc/sysctl.d/99-i915psp.conf


I try in many was but no success.

Sorry, not sure what that means.

Many ways. Dictionary. Without success.

Which ways? What did you try?
The sysctl file did not work?

Yes. Sysctl file doesn’t work.

Not sure why not. Can you confirm the file is there? You did reboot I assume?

Please don’t be arrogant and blame others for not understanding your short, vague, misspelled posts. Bad manners are not welcome here.


I can confirm that file exist and after restart command 'sudo sysctl dec.915.perf_stream_paranoif give a score ‘dev.i915.perf_stream_paranoid=1’ .

Did the sysctl service run?

systemctl status systemd-sysctl.service

systemd-sysctl.service - Apply Kernel Variables
Loaded: loaded (/usr/lib/systemd/system/systemd-sysctl.service; static)
Active: active (exited) since Sun 2021-01-03 09:47:21 CET; 1h 0min ago
Docs: man:systemd-sysctl.service(8)
Process: 239 ExecStart=/usr/lib/systemd/systemd-sysctl (code=exited, status>
Main PID: 239 (code=exited, status=0/SUCCESS)

sty 03 09:47:21 ASUS-X540LJ systemd[1]: Starting Apply Kernel Variables…
sty 03 09:47:21 ASUS-X540LJ systemd[1]: Finished Apply Kernel Variables.
lines 1-10/10 (END)

Looks ok. Not sure why it’s not loading then.

Please post the output of:

sudo sysctl --system

And please use the text formatting option on the posted text for better readability:

* Ustawianie /usr/lib/sysctl.d/10-manjaro.conf ...
fs.inotify.max_user_instances = 1024
fs.inotify.max_user_watches = 524288
* Ustawianie /usr/lib/sysctl.d/50-coredump.conf ...
kernel.core_pattern = |/usr/lib/systemd/systemd-coredump %P %u %g %s %t %c %h
kernel.core_pipe_limit = 16
fs.suid_dumpable = 2
* Ustawianie /usr/lib/sysctl.d/50-default.conf ...
kernel.sysrq = 16
kernel.core_uses_pid = 1
net.ipv4.conf.default.rp_filter = 2
sysctl: ustawianie klucza "net.ipv4.conf.all.rp_filter": Zły argument
net.ipv4.conf.default.accept_source_route = 0
sysctl: ustawianie klucza "net.ipv4.conf.all.accept_source_route": Zły argument
net.ipv4.conf.default.promote_secondaries = 1
sysctl: ustawianie klucza "net.ipv4.conf.all.promote_secondaries": Zły argument
net.ipv4.ping_group_range = 0 2147483647
net.core.default_qdisc = fq_codel
fs.protected_hardlinks = 1
fs.protected_symlinks = 1
fs.protected_regular = 1
fs.protected_fifos = 1
* Ustawianie /usr/lib/sysctl.d/50-pid-max.conf ...
kernel.pid_max = 4194304
* Ustawianie /etc/sysctl.d/99-i916psp.conf ...
dev.i915.perf_stream_paranoid = 0