Set Nvidia as primary

Hello there, I recently use KDE as my DE. So for now I move to WM and use i3 as my choice.
I already find some reference on google and didn’t found as I wish.
I wanted to make my Nvidia GPU as primary, I tried to check to monitor my apps running my GPU but didn’t found any 1 apps. I think they running under my integrated graphics.
Thanks in advance.

First you need to install hybrid drivers for your cards, there’s many ways depending what kind your cards are, then configure them

What does hybrid mean?
I already install nvidia-prime for my drivers.
And I already tried using optimus-manager for switching to my Nvidia as GPU, but after a restart, my GPU turn back to default (intel).

Take a look at this link prime-run
or at this
Black screen prime

I’m sorry, I didn’t see little icon on the right bottom for setting optimus-manager.
And now I can set them auto Nvidia or hybrid mode when startup.
After I install optimus-manager-qt I see that.

So does that solve your problem? If it did, please don’t forget to mark visone’s answer as a solution like this:
so that the next person that has the exact same problem you just had will benefit from your post as well as your question will now be in the “solved” status.


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.