Server bei start des Desktop-Rechners wecken

Hallo,
ich versuche einen Server beim starten meines Desktop Rechner zu wecken. Leider funktioniert das so nicht wie ich es versuche.

Was ich gemacht habe:
Ich habe unter systemd/system ein service erstellt:

etherwake-unraid.service

[Unit]
Description=Starte den Unraidserver
After=sys-subsystem-net-devices-eno1.device

[Service]
Type=simple
ExecStart=/sbin/etherwake -i eno1 f8:b1:56:be:be:73

[Install]
WantedBy=multi-user.target

Dann habe ich den service eingeschaltet
sudo systemctl enable etherwake-unraid.service

und neugeladen
sudo systemctl daemon-reload

Der Befehl funktioniert im Terminal einwandfrei. Beim starten des Desktoprechners wird der Server aber nicht geweckt.
Was mache ich falsch, oder gibt es bessere Methoden den Server beim starten zu wecken?

Hier wäre Type=oneshot besser.

Das k√∂nnte zu fr√ľh sein. Grunds√§tzlich ist zwar kein volles Netzwerk f√ľr den Befehl n√∂tig, aber es k√∂nnte besser zu sein zu warten bis das Netzwerk vollst√§ndig da ist.

Also z.B. After=network-online.target verwenden. Damit network-online.target funktioniert muss es aktiviert werden. Falls du den NetworkManager verwendet, schalte NetworkManager-wait-online.service ein (enable).


Manjaro verwendet schon immer nur /usr/bin/. Wir sind hier nicht in der Debian Welt. Nat√ľrlich wird /sbin/ auf /usr/bin/ gelinkt, aber einheitlicher w√§re die Verwendung von /usr/bin/

1 Like

Unterst√ľtzt die Hardware des Servers √ľberhaupt Wake-on-LAN?

Versuchs mal so:

[Unit]
Description=Starte den Unraidserver
Require=NetworkManager-wait-online.service
After=NetworkManager-wait-online.service

[Service]
Type=simple
ExecStart=/sbin/etherwake -i eno1 f8:b1:56:be:be:73

[Install]
WantedBy=multi-user.target

Stellt damit sicher, dass NetworkManager eine Verbindung hergestellt hat und dann der Service startet.

Ja.

Der Befehl funktioniert im Terminal einwandfrei.

Vielen Dank, ich bin bisher in der Tat bei Debian ausschließlich unterwegs gewesen. Ich werde versuchen mich dran zu gewöhnen und es zu beachten.

Es hat jetzt funktioniert.
Der Service schaut jetzt so auch bei mir:

[Unit]
Description=Starte den Unraidserver
Requires=NetworkManager-wait-online.service
After=NetworkManager-wait-online.service

[Service]
Type=oneshot
ExecStart=/usr/bin/etherwake -i eno1 f8:b1:56:be:be:73

[Install]
WantedBy=multi-user.target

Vielen Dank f√ľr Eure Unterst√ľtzung!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.