Seit upgrades - boot prozess sehr langsam und kernel fehler meldungen


#1

Habe eine Dual Boot mit KDE Neon, seit den letzten Manjaro Upgrades ist der Bootprozess von 3 sec. auf ca. 60 sec. angestiegen:
KDE Neon weiterhin ca. 4 sec. Manjaro war vorher ca. 3 Sec. bis zum sddm Screen, jetzt brauchsts wirklich eine gute Minute.
Auch beim shutdown sehe ich hier irgendwelche Kernel Fehler … kann jemand weiterhelfen?

                                                  #20 0x00007ff704ea158c _ZN10QEventLoop4execE6QFlagsINS_17ProcessEventsFlagEE (libQt5Core.so.5)
                                                  #21 0x00007ff704ea9896 _ZN16QCoreApplication4execEv (libQt5Core.so.5)
                                                  #22 0x0000562caa454404 n/a (ksmserver-logout-greeter)
                                                  #23 0x00007ff7048f4223 __libc_start_main (libc.so.6)
                                                  #24 0x0000562caa4545be _start (ksmserver-logout-greeter)
                                                  
                                                  Stack trace of thread 15371:
                                                  #0  0x00007ff7049c0c21 __poll (libc.so.6)
                                                  #1  0x00007ff7026dd540 n/a (libglib-2.0.so.0)
                                                  #2  0x00007ff7026dd62e g_main_context_iteration (libglib-2.0.so.0)
                                                  #3  0x00007ff704ef85a9 _ZN20QEventDispatcherGlib13processEventsE6QFlagsIN10QEventLoop17ProcessEventsFlagEE (libQt5Core.so.5)
                                                  #4  0x00007ff704ea158c _ZN10QEventLoop4execE6QFlagsINS_17ProcessEventsFlagEE (libQt5Core.so.5)
                                                  #5  0x00007ff704ce55c9 _ZN7QThread4execEv (libQt5Core.so.5)
                                                  #6  0x00007ff7061f4b89 n/a (libQt5Qml.so.5)
                                                  #7  0x00007ff704ce69cc n/a (libQt5Core.so.5)
                                                  #8  0x00007ff7033e7a9d start_thread (libpthread.so.0)
                                                  #9  0x00007ff7049cbb23 __clone (libc.so.6)
                                                  
                                                  Stack trace of thread 15370:
                                                  #0  0x00007ff7049c0c21 __poll (libc.so.6)
                                                  #1  0x00007ff7026dd540 n/a (libglib-2.0.so.0)
                                                  #2  0x00007ff7026dd62e g_main_context_iteration (libglib-2.0.so.0)
                                                  #3  0x00007ff704ef85a9 _ZN20QEventDispatcherGlib13processEventsE6QFlagsIN10QEventLoop17ProcessEventsFlagEE (libQt5Core.so.5)
                                                  #4  0x00007ff704ea158c _ZN10QEventLoop4execE6QFlagsINS_17ProcessEventsFlagEE (libQt5Core.so.5)
                                                  #5  0x00007ff704ce55c9 _ZN7QThread4execEv (libQt5Core.so.5)
                                                  #6  0x00007ff70572cba6 n/a (libQt5DBus.so.5)
                                                  #7  0x00007ff704ce69cc n/a (libQt5Core.so.5)
                                                  #8  0x00007ff7033e7a9d start_thread (libpthread.so.0)
                                                  #9  0x00007ff7049cbb23 __clone (libc.so.6)
                                                  
                                                  Stack trace of thread 15369:
                                                  #0  0x00007ff7049c0c21 __poll (libc.so.6)
                                                  #1  0x00007ff70345c630 n/a (libxcb.so.1)
                                                  #2  0x00007ff70345e2db xcb_wait_for_event (libxcb.so.1)
                                                  #3  0x00007ff6feae396b n/a (libQt5XcbQpa.so.5)
                                                  #4  0x00007ff704ce69cc n/a (libQt5Core.so.5)
                                                  #5  0x00007ff7033e7a9d start_thread (libpthread.so.0)
                                                  #6  0x00007ff7049cbb23 __clone (libc.so.6)
-- Reboot --
Jan 26 17:03:11 hounddog dolphin[2046]: inotify_add_watch(/run/media/globe/backup) failed: (Permission denied)
-- Reboot --
Jan 26 17:58:52 hounddog sddm-helper[7828]: PAM unable to dlopen(/usr/lib/security/pam_elogind.so): /usr/lib/security/pam_elogind.so: Kann die Shared-Object-Datei nicht öffnen: >
Jan 26 17:58:52 hounddog sddm-helper[7828]: PAM adding faulty module: /usr/lib/security/pam_elogind.so


#2

Im Terminal

systemd-analyze
systemd-analyze blame

und zeigen :slight_smile:


#3

Ich hatte von Anfang an das System ziemlich optimal eingestellt, scheibar greifen die systemd disables gar nicht mehr, hier tauchen z.b. modem manager auf usw. die ich disabled hatte.
Aber was mir mehr Sorgen macht sind diese:

Jan 26 18:27:01 hounddog sddm-helper[655]: PAM unable to dlopen(/usr/lib/security/pam_elogind.so): /usr/lib/security/pam_elogind.so: Kann die Shared-Object-Datei nicht öffnen: D>
Jan 26 18:27:01 hounddog sddm-helper[655]: PAM adding faulty module: /usr/lib/security/pam_elogind.so

und eben der ganze Schwal von oben beim reboot oder logout:
Stack trace of thread 15369:
 #0  0x00007ff7049c0c21 __poll (libc.so.6)
 #1  0x00007ff70345c630 n/a (libxcb.so.1)
 #2  0x00007ff70345e2db xcb_wait_for_event (libxcb.so.1)
#3  0x00007ff6feae396b n/a (libQt5XcbQpa.so.5)
#4  0x00007ff704ce69cc n/a (libQt5Core.so.5)
#5  0x00007ff7033e7a9d start_thread (libpthread.so.0)
#6  0x00007ff7049cbb23 __clone (libc.so.6)
systemd-analyze
Startup finished in 2.978s (kernel) + 1.942s (userspace) = 4.921s
graphical.target reached after 1.465s in userspace

systemd-analyze blame
           956ms lvm2-monitor.service
           775ms udisks2.service
           467ms systemd-modules-load.service
           397ms dev-sda1.device
           394ms tlp.service
           351ms dev-disk-by\x2duuid-c3c0e2f3\x2dd470\x2d4a38\x2db1bd\x2dae3952a65e99.swap
           291ms upower.service
           210ms systemd-journal-flush.service
           162ms systemd-logind.service
           158ms systemd-udevd.service
           118ms user@1000.service
           102ms polkit.service
            87ms NetworkManager.service
            77ms systemd-udev-trigger.service
            71ms systemd-journald.service
            65ms avahi-daemon.service
            61ms grub-boot-indeterminate.service
            57ms dev-disk-by\x2duuid-186276a1\x2da074\x2d4c7a\x2db9b3\x2d219cf5e36036.swap
            54ms systemd-sysctl.service
            39ms systemd-fsck@dev-disk-by\x2duuid-2086cd6c\x2dd65f\x2d49a3\x2dba0b\x2d0fc2ef08431b.service
            28ms org.cups.cupsd.service
            26ms systemd-binfmt.service
            20ms systemd-tmpfiles-setup-dev.service
            17ms dev-hugepages.mount
            16ms systemd-tmpfiles-setup.service
            14ms home.mount
            10ms dev-mqueue.mount
            10ms kmod-static-nodes.service
             8ms systemd-remount-fs.service
             8ms systemd-random-seed.service
             8ms sys-kernel-debug.mount
             8ms systemd-update-utmp.service
             6ms systemd-user-sessions.service
             5ms rtkit-daemon.service
             5ms tmp.mount
             3ms proc-sys-fs-binfmt_misc.mount
             3ms sys-kernel-config.mount


#4

habe hier diese ganze Liste disabled:

sudo systemctl disable ureadahead.service
sudo systemctl disable ModemManager.service
sudo systemctl disable pppd-dns.service
sudo systemctl disable NetworkManager-wait-online.service
sudo systemctl disable lvm2-monitor.service
sudo systemctl disable vboxweb.service
sudo systemctl disable vboxballoonctrl.service
sudo systemctl disable vboxautostart-service.service
sudo systemctl disable speech-dispatcher.service
sudo systemctl disable avahi.service
sudo systemctl disable bluetooth.service
balooctl disable

#5

Ich sehe da nur 4,921s :wink:

Wird was im Netzwerkgesucht? NAS? RasPi? ???

fstab in Ordnung? Alle Platten/Swap UUID korrekt?


#6

Kenne ich alles nicht, musste mal die Suchmaschine deines Vertrauens befragen.


#7

neeh, lief ja vor dem Upgrade alles …warum sollte auf einmal die fstab verstellt sein … wie gesagt ich habe Tage damit verbracht das System zu optimieren …jetz ist hat ein fettes Upgrade von KDE eingespielt worden, ein neuer Kernel und ein neuer Nvidia Driver - habe eine Nvidia Karte in Betrieb … kann noch mal versuchen auf den ganz neuen Kernel umzustellen ider auf den alten von vorher … jedenfalls ist das System seit dem Update zerschossen. Auch in einer V-Box mit Manjaro KDE und Update während der Installation ist die Boottime total lahm geworden … das liegt daher vermutlich eher an den neuen Packages, vorher gabs ja keine Macken!


#8

Hier sieht man sehr deutlich das es bis zum sddm etwa 4,4 Sekunden dauert.

Es gab vor langer Zeit ein Problem mit der Entropie. Das führt zu einem verzögerten anzeigen vom sddm. Obwohl das System schon längst dort angekommen ist und wartet. Erscheint sddm schneller wenn du auf deiner Tastatur herumdrückst? haveged sollte da helfen.

Das ist auch ein super altes Problem von sddm (/etc/pam.d/sddm-greeter). Überprüfe ob du .pacnew Dateien in etc hast. Und vergleiche deine Version von /etc/pam.d/sddm-greeter mit der originalen.

Es sieht so aus als ob es sich um ein Qt Programm handeln würde. Die wichtigste Zeile darüber hast du leider nicht gepostet. Schaue einfach Upstream nach ob es schon einen Bugreport gibt, wenn nicht erstelle einen.


#9

das mag für die Ausgabe des Befehls ja auch zutreffen, aber wenn ich dir jetzt ein Video vom Start mache dann siehst du das es in Wirklichkeit länger als 1 Minute dauert bis der Loginscreen erscheint. Vor dem Upgrade war das alles richtig flott … ich habe das jetzt auf 3 verschiedenen PCs versucht uns 2 mal in einer V-box, da ist 100% etwas faul beim Start …veileicht gibts irgend eine neue Funktion die kurz mal ins Internez geht - call home oder wohin auch immer :wink:
Das QT Problem bzw. alle diese aufgeführten Probleme treten auch auf mit einem neu erstellten ISO, also nicht nur nach einem System Upgrade!


#10

Dann versuche mal den haveged Tipp umzusetzen.


#11

also was wirklich seltsam ist wenn ich mal den ganzen boot prozess durchgehe, die ganzen Services die ich mit systemdctl dekativiert habe, tauchen plötzlich wieder auf … als wenn das nicht mehr greift …

habe aber hier noch etwas anderes gefunden, vermutlich der Kernel Upgrade:

Jan 26 16:19:15 hounddog kernel: nvidia_modeset: module license 'NVIDIA' taints kernel.
Jan 26 16:19:15 hounddog kernel: Disabling lock debugging due to kernel taint
Jan 26 16:19:15 hounddog systemd-modules-load[298]: Inserted module 'nvidia_drm'
Jan 26 16:19:15 hounddog kernel: nvidia-modeset: Loading NVIDIA Kernel Mode Setting Driver for UNIX platforms  415.25  Wed Dec 12 10:02:42 CST 2018
Jan 26 16:19:15 hounddog kernel: [drm] [nvidia-drm] [GPU ID 0x00000100] Loading driver
Jan 26 16:19:15 hounddog kernel: [drm] Initialized nvidia-drm 0.0.0 20160202 for 0000:01:00.0 on minor 0
Jan 26 16:19:15 hounddog systemd-modules-load[298]: Inserted module 'uinput'
Jan 26 16:19:15 hounddog kernel: r8168: This product is covered by one or more of the following patents: US6,570,884, US6,115,776, and US6,327,625.
Jan 26 16:19:15 hounddog kernel: r8168  Copyright (C) 2017  Realtek NIC software team <nicfae@realtek.com> 
                                  This program comes with ABSOLUTELY NO WARRANTY; for details, please see <http://www.gnu.org/licenses/>. 
                                  This is free software, and you are welcome to redistribute it under certain conditions; see <http://www.gnu.org/licenses/>. 
Jan 26 16:19:15 hounddog kernel: ACPI Warning: SystemIO range 0x0000000000000B00-0x0000000000000B08 conflicts with OpRegion 0x0000000000000B00-0x0000000000000B0F (\SOR1) (201808>
Jan 26 16:19:15 hounddog kernel: ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver


#12

Da ist kein wirklicher Error dabei.


#13

Long delay for starting Desktop Environment

There’s a bug which is exhausting the entropy pool. This is refilled over time through e.g. disk activity and mouse movement. You can increase the fill rate with a software solution:

sudo pacman -S haveged
sudo systemctl enable haveged
sudo systemctl start haveged

An alternative method if activating the haveged service is not something you want to do is to press the shift key 8-10 times in succession.


#14

OK, habe jetzt mal haveged entfernt, also eine Zeitverkürzung zum Login Screen hat es nicht gebarcht, aber wenn ich mich einlogge wird alles danach sehr schnell aufgebaut Ohne Verzögerung.
Habe auch mal versucht die anderen Loginscreens zu entfernen, ich denke danach tritt das PAM und QT Problem auf … vorher konnte man noch das Original KDE Breeze SDDM Theme installieren jetzt nur noch das Breath Theme und dmait werden seltsamerweise gleich die anderen 4 Themes mitintsalliert … sieht für mich nach einem Problem mit dem SDDM aus …


#15

Die drei Befehle oben installieren es.


#16

OK, habe es erst mal entfernt neu gestartet - keine Änderung, dann noch mal nach deiner Empfehlung installiert neu gestartet … es ist ein wenig schneller geworden … aber noch nicht so wie es einmal war :wink:
Ich lass mir morgen nochmal was einfallen, Danke erstmal für eure Hilfe!


#17

habe hier noch den kompletten Teil bei vom reboot gefunden:- irgendetwas mit ksplashqml

Jan 26 20:07:36 hounddog systemd-coredump[993]: Process 792 (ksplashqml) of user 1000 dumped core.
                                               Stack trace of thread 792:

                                                #0  0x00007f9242e27d7f raise (libc.so.6)
                                                #1  0x00007f9242e12672 abort (libc.so.6)
                                                #2  0x00007f9242e6a878 __libc_message (libc.so.6)
                                                #3  0x00007f9242e7118a malloc_printerr (libc.so.6)
                                                #4  0x00007f9242e72b27 _int_free (libc.so.6)
                                                #5  0x00007f9243adbb51 n/a (libQt5Gui.so.5)
                                                #6  0x00007f9242e2a45c __run_exit_handlers (libc.so.6)
                                                #7  0x00007f9242e2a58e exit (libc.so.6)
                                                #8  0x00007f9242e1422a __libc_start_main (libc.so.6)
                                                #9  0x0000557d7613327e _start (ksplashqml)
                                                
                                                Stack trace of thread 795:
                                                #0  0x00007f9242ee0c21 __poll (libc.so.6)
                                                #1  0x00007f9240b25540 n/a (libglib-2.0.so.0)
                                                #2  0x00007f9240b2562e g_main_context_iteration (libglib-2.0.so.0)
                                                #3  0x00007f92434185a9 _ZN20QEventDispatcherGlib13processEventsE6QFlagsIN10QEventLoop17ProcessEventsFlagEE (libQt5Core.so.5)
                                                #4  0x00007f92433c158c _ZN10QEventLoop4execE6QFlagsINS_17ProcessEventsFlagEE (libQt5Core.so.5)
                                                #5  0x00007f92432055c9 _ZN7QThread4execEv (libQt5Core.so.5)
                                                #6  0x00007f9243c9cba6 n/a (libQt5DBus.so.5)
                                                #7  0x00007f92432069cc n/a (libQt5Core.so.5)
                                                #8  0x00007f9242017a9d start_thread (libpthread.so.0)
                                                #9  0x00007f9242eebb23 __clone (libc.so.6)


#18

Wenn es richtig schnell booten soll nimm was anderes als KDE oder Gnome. :wink: :slight_smile:

Warte jetzt hier in Ruhe den ■■■■■■■■■ ab, habe ja morgen frei :smiley:

Mein erster Balken, Respekt :wink:


#19

das ging ja auch mal mit Manjaro KDE … Antergos und KDE Neon sogar di neue Kubuntu 18.10 booten schnell …
und nach Google haben verdammt viele User momentan genau das selbe Problem … wie gesagt das fängt sofort mit einer Neu Installation an ohne irgend etwas geändert zu haben … mit schnellen SSDs.


#20

Uraltrechner mit i3, Xfce ist ein bisschen langsamer.

mint at i3 in ~
$ systemd-analyze 
Startup finished in 2.385s (kernel) + 1.772s (userspace) = 4.158s 
graphical.target reached after 1.772s in userspace

mint at i3 in ~
$ systemd-analyze blame
          1.098s udisks2.service
           845ms lightdm.service
           690ms systemd-logind.service
           509ms lvm2-monitor.service
           407ms systemd-journal-flush.service
           340ms systemd-modules-load.service
           292ms dev-sdb3.device
           261ms upower.service
           250ms systemd-tmpfiles-clean.service
           202ms ufw.service
           160ms org.cups.cupsd.service
           116ms NetworkManager.service
           111ms maia-console@tty1.service
           110ms polkit.service
           109ms ldconfig.service
            91ms systemd-udevd.service
            58ms systemd-udev-trigger.service
            57ms systemd-journald.service
            45ms user@1000.service
            26ms dev-zram0.swap
            25ms wpa_supplicant.service
            25ms systemd-tmpfiles-setup.service
            25ms accounts-daemon.service
            22ms colord.service
            21ms systemd-sysctl.service
            20ms systemd-journal-catalog-update.service
            16ms systemd-sysusers.service
            14ms systemd-tmpfiles-setup-dev.service
            11ms sys-kernel-debug.mount
            11ms systemd-rfkill.service
            11ms kmod-static-nodes.service
            11ms zram-setup@zram0.service
            11ms grub-boot-indeterminate.service
            10ms dev-hugepages.mount
             9ms tmp.mount
             9ms linux-module-cleanup.service
             7ms systemd-update-utmp.service
             6ms systemd-remount-fs.service
             6ms systemd-random-seed.service
             6ms systemd-update-done.service
             6ms user-runtime-dir@1000.service
             4ms rtkit-daemon.service
             4ms systemd-user-sessions.service
             2ms dev-mqueue.mount
             2ms sys-kernel-config.mount
             2ms sys-fs-fuse-connections.mount

$ inxi -Fz
System:    Host: i3 Kernel: 4.20.3-1-MANJARO x86_64 bits: 64 Desktop: i3 4.16 Distro: Manjaro Linux 
Machine:   Type: Desktop Mobo: ASUSTeK model: P8Z77-V DELUXE v: Rev 1.xx serial: <filter> BIOS: American Megatrends v: 2104 
           date: 08/13/2013 
CPU:       Topology: Quad Core model: Intel Core i7-3770K bits: 64 type: MT MCP L2 cache: 8192 KiB 
           Speed: 2071 MHz min/max: 1600/4100 MHz Core speeds (MHz): 1: 1672 2: 1732 3: 1749 4: 1790 5: 1694 6: 1656 7: 1715 
           8: 1700 
Graphics:  Device-1: NVIDIA GP106 [GeForce GTX 1060 6GB] driver: nvidia v: 415.27 
           Display: x11 server: X.Org 1.20.3 driver: nvidia resolution: 3840x2160~60Hz 
           OpenGL: renderer: GeForce GTX 1060 6GB/PCIe/SSE2 v: 4.6.0 NVIDIA 415.27 
Audio:     Device-1: Intel 7 Series/C216 Family High Definition Audio driver: snd_hda_intel 
           Device-2: NVIDIA GP106 High Definition Audio driver: snd_hda_intel 
           Sound Server: ALSA v: k4.20.3-1-MANJARO 
Network:   Device-1: Intel 82579V Gigabit Network driver: e1000e 
           IF: eno1 state: up speed: 1000 Mbps duplex: full mac: <filter> 
           Device-2: Broadcom and subsidiaries BCM43228 802.11a/b/g/n driver: wl 
           IF: wlp12s0 state: dormant mac: <filter> 
           Device-3: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: N/A 
Drives:    Local Storage: total: 3.07 TiB used: 32.65 GiB (1.0%) 
           ID-1: /dev/sda vendor: Samsung model: SSD 850 EVO 250GB size: 232.89 GiB 
           ID-2: /dev/sdb vendor: Corsair model: Force GT size: 111.79 GiB 
           ID-3: /dev/sdc vendor: Western Digital model: WD10EACS-22D6B1 size: 931.51 GiB 
           ID-4: /dev/sdd vendor: Seagate model: ST2000DM001-9YN164 size: 1.82 TiB 
Partition: ID-1: / size: 54.89 GiB used: 32.65 GiB (59.5%) fs: ext4 dev: /dev/sdb3 
Sensors:   System Temperatures: cpu: 29.8 C mobo: 27.8 C gpu: nvidia temp: 54 C 
           Fan Speeds (RPM): cpu: 0 gpu: nvidia fan: 0% 
Info:      Processes: 231 Uptime: 2h 57m Memory: 15.60 GiB used: 3.48 GiB (22.3%) Shell: zsh inxi: 3.0.30