Segmentation fault (core dumped)

Please run gdb vlc, and after the (gdb) prompt appears, type r, then press enter, wait for the prompt to appear again, then type bt, and press enter, then post the output.

Hi pobrn, as instructed:

$ gdb vlc
GNU gdb (GDB) 10.1
Copyright (C) 2020 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.
Type "show copying" and "show warranty" for details.
This GDB was configured as "x86_64-pc-linux-gnu".
Type "show configuration" for configuration details.
For bug reporting instructions, please see:
Find the GDB manual and other documentation resources online at:

For help, type "help".
Type "apropos word" to search for commands related to "word"...
Reading symbols from vlc...
(No debugging symbols found in vlc)
(gdb) r
Starting program: /usr/bin/vlc 
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/usr/lib/".
VLC media player Vetinari (revision
[New Thread 0x7ffff4b91640 (LWP 4644)]
[New Thread 0x7ffff3d18640 (LWP 4645)]
[New Thread 0x7ffff3c17640 (LWP 4646)]
[000055555555a5b0] main libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.
[New Thread 0x7ffff1f0a640 (LWP 4648)]
[New Thread 0x7ffff1a9b640 (LWP 4649)]
[New Thread 0x7ffff10e9640 (LWP 4650)]

Thread 5 "vlc" received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0x7ffff1f0a640 (LWP 4648)]
0x00007ffff7dba3bb in ____strtoull_l_internal () from /usr/lib/
(gdb) bt
#0  0x00007ffff7dba3bb in ____strtoull_l_internal () from /usr/lib/
#1  0x00007ffff7dd46bd in __vfscanf_internal () from /usr/lib/
#2  0x00007ffff7dd2232 in __isoc99_sscanf () from /usr/lib/
#3  0x00007ffff7e35242 in parse_offset () from /usr/lib/
#4  0x00007ffff7e35784 in __tzset_parse_tz () from /usr/lib/
#5  0x00007ffff7e37213 in __tzfile_compute () from /usr/lib/
#6  0x00007ffff7e35c5d in __tz_convert () from /usr/lib/
#7  0x00007ffff7e34141 in ranged_convert () from /usr/lib/
#8  0x00007ffff7e3448c in __mktime_internal () from /usr/lib/
#9  0x00007ffff25d5e50 in qMkTime(tm*) () from /usr/lib/
#10 0x00007ffff26ab29e in ?? () from /usr/lib/
#11 0x00007ffff26ab938 in ?? () from /usr/lib/
#12 0x00007ffff26aba40 in ?? () from /usr/lib/
#13 0x00007ffff26abf30 in ?? () from /usr/lib/
#14 0x00007ffff26ae15c in QDateTime::setMSecsSinceEpoch(long long) () from /usr/lib/
#15 0x00007ffff26b0591 in QDateTime::fromMSecsSinceEpoch(long long, Qt::TimeSpec, int) () from /usr/lib/
#16 0x00007ffff26b0ca3 in QDateTime::fromMSecsSinceEpoch(long long) () from /usr/lib/
#17 0x00007ffff26f403c in QFileInfo::fileTime(QFileDevice::FileTime) const () from /usr/lib/
#18 0x00007ffff26f41f4 in QFileInfo::lastModified() const () from /usr/lib/
#19 0x00007ffff274c2b7 in ?? () from /usr/lib/
#20 0x00007ffff274c3bc in ?? () from /usr/lib/
#21 0x00007ffff274d297 in QSettings::QSettings(QString const&, QSettings::Format, QObject*) () from /usr/lib/
#22 0x00007ffff08e2acc in Qt5CTProxyStyle::Qt5CTProxyStyle(QString const&) () from /usr/lib/qt/plugins/styles/
#23 0x00007ffff08e27d5 in Qt5CTStylePlugin::create(QString const&) () from /usr/lib/qt/plugins/styles/
#24 0x00007ffff32fe715 in QStyleFactory::create(QString const&) () from /usr/lib/
#25 0x00007ffff331fbd6 in ?? () from /usr/lib/
#26 0x00007ffff33208a5 in QProxyStyle::event(QEvent*) () from /usr/lib/
#27 0x00007ffff328d752 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/
#28 0x00007ffff27c7cda in QCoreApplication::notifyInternal2(QObject*, QEvent*) () from /usr/lib/
#29 0x00007ffff27fcbc9 in QObjectPrivate::setParent_helper(QObject*) () from /usr/lib/
#30 0x00007ffff33208a5 in QProxyStyle::event(QEvent*) () from /usr/lib/
#31 0x00007ffff328d752 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/
#32 0x00007ffff27c7cda in QCoreApplication::notifyInternal2(QObject*, QEvent*) () from /usr/lib/
#33 0x00007ffff27fcbc9 in QObjectPrivate::setParent_helper(QObject*) () from /usr/lib/
#34 0x00007ffff33208a5 in QProxyStyle::event(QEvent*) () from /usr/lib/

Please check if Qt has been recently updated: egrep -i "(upgraded|installed) qt5-base" /var/log/pacman.log

Output as per the command, it looks like it has been updated?

[2019-04-13 16:22] [ALPM] upgraded qt5-base (5.11.2-2.1 -> 5.12.2-1.1)
[2019-04-24 21:15] [ALPM] upgraded qt5-base (5.12.2-1.1 -> 5.12.2-2.1)
[2019-05-02 21:23] [ALPM] upgraded qt5-base (5.12.2-2.1 -> 5.12.3-2.1)
[2019-07-08 21:15] [ALPM] upgraded qt5-base (5.12.3-2.1 -> 5.12.4-2.2)
[2019-09-28 17:26] [ALPM] upgraded qt5-base (5.12.4-2.2 -> 5.13.0-7.1)
[2019-11-11 18:00] [ALPM] upgraded qt5-base (5.13.0-7.1 -> 5.13.1-2.1)
[2019-11-14T18:41:25+0200] [ALPM] upgraded qt5-base (5.13.1-2.1 -> 5.13.2-1)
[2019-12-31T11:04:50+0200] [ALPM] upgraded qt5-base (5.13.2-1 -> 5.14.0-1)
[2020-01-20T17:41:19+0200] [ALPM] upgraded qt5-base (5.14.0-1 -> 5.14.0-3)
[2020-03-01T12:22:09+0200] [ALPM] upgraded qt5-base (5.14.0-3 -> 5.14.1-2)
[2020-03-23T16:08:04+0200] [ALPM] upgraded qt5-base (5.14.1-2 -> 5.14.1-3)
[2020-04-11T09:45:06+0200] [ALPM] upgraded qt5-base (5.14.1-3 -> 5.14.2-1)
[2020-05-09T19:20:24+0200] [ALPM] upgraded qt5-base (5.14.2-1 -> 5.14.2-2)
[2020-06-08T11:43:06+0200] [ALPM] upgraded qt5-base (5.14.2-2 -> 5.14.2-3)
[2020-06-18T15:33:08+0200] [ALPM] upgraded qt5-base (5.14.2-3 -> 5.15.0-3)
[2020-07-22T09:01:43+0200] [ALPM] upgraded qt5-base (5.15.0-3 -> 5.15.0-4)
[2020-09-10T15:19:23+0200] [ALPM] upgraded qt5-base (5.15.0-4 -> 5.15.0-5)
[2020-10-02T09:57:38+0200] [ALPM] upgraded qt5-base (5.15.0-5 -> 5.15.1-1)
[2020-11-08T19:55:15+0200] [ALPM] upgraded qt5-base (5.15.1-1 -> 5.15.1-3)

Thank you for your help pobrn, I am surprised no one else is having similar problems. My computer was very busy when I did the upgrade and went into an error state (Oops, something went wrong) white screen. After a restart I was met with a GRUB terminal.

I then had to chroot with a live disk to be able to upgrade my packages. After which (restart) I had to go into another console (ctr+alt+F2) to successfully run the sudo pacman -Syu.

It only occurred to me now that this may be the cause, how to fix it though…

It seems it has just been updated, exactly the date which you described as the start of the problems. First of all, please reinstall qt5-base and vlc (sudo pacman -Syu qt5-base vlc) and try vlc again.

I reinstalled both, but the error persists.

You have certainly given me some insight as to what the problem is, thank you. I will try and do more debugging - I am clueless at this stage :frowning:

Delete qt5-base-5.15.1-3-.... from /var/cache/pacman/pkg and try reinstalling again.

Deleted and reinstalled but still the error. I then made the drastic step of reinstalling (overwriting) many packages. I am not entirely sure which package (by category) by doing the following:
pacman -Qqdn > pkglist_deps.txt
sudo pacman --overwrite --asdeps -S $(< pkglist_deps.txt)

This did not fix the problem either. The same error still persists.

Have you tried downgrading qt5-base to 5.15.1-1?

You did reboot the machine after the final updates?

Yes, I did a restart and tested it before and after doing package updates. Error still there.

I downgraded by deleting the file in /var/cache/pacman/pkg folder and downloading and copying version in the directory. I then ran:
sudo pacman -U /var/cache/pacman/pkg/qt5-base-5.15.1-1-x86_64.pkg.tar.zst

I am not sure which version is running, or how to check it? There is no version file in the pacman/pkg directory, but when I run egrep -i "(upgraded|installed) qt5-base" /var/log/pacman.log it still gives the same output as before.

The problem is still there. Segmentation Fault.

Thanks for your help in any case gents (and/or ladies :))

Another thing you could do is clear the cache, and reinstall all packages that have been updated on the 8th of November.

I cleared the cache by running: sudo pacman -Scc and saying yes on both counts.

Could you give me hint as to how to reinstall all the packages from a specific update? 8th of November in this case. I do not want to waste much of your time, but a quick google did not yield great answers/results.

On second thought I think I will use Timeshift to go back to before the update. That may be easiest.

Read /var/log/pacman.log and make a list of all packages that have been installed on that particular day, and reinstall them.

Well, that’s probably the easiest.

Yip, Timeshift fixed the problem. First time I used it and amazed at how easy, fast and well it worked. I may be speaking too soon, but I did open up most of the apps that gave problems and they opened with no errors or problems at all.

I will make sure I have this backup and then try and determine if something during my update process had gone off track. Meaning if I do a full update again and everything works this time around I can at least offer that as a “solution” for this thread. If that does not work I will leave this thread be.

Thanks for your assistance pobr, you have been VERY helpful. Much appreciated.

One last comment. I ran the update (which caused the Segmentation fault last time) again after reverting back to a version before the update (using Timeshift). Everything works this time around.

Somewhere during the last update something went wrong, I am pretty sure that was because of my own doing.

I was facing the same issues I kw its old and probably solved but here’s a link to the solution.

Mmm nice thanks.

I wish I could mark this as the solution but I am not sure if it will - I can’t test it. As mentioned my problem occurred because I did an update while my PC was way to busy. Pretty sure that was the reason, if only I knew your solution would solve it.

But thanks for posting it on here, hopefully it helps someone someday and they can mark it as the solution!