Second screen detection

I upgraded my UEFI and my ScreenPad to the version 2.0, and two problems, the ScreenPad is not listed in the displays and the KDE UI spams the overlay who appears when you connect a second screen, who ask what you want to display on it, it appears one time per second, so the computer is unusable with SDDM (or X or KDE or whatever you want). The keyboard just spam the "^@" key..

And i can't even login in a tty (VT), because of what the keyboard spams...

As you seem to have very new firmware and Asus is horrible in providing kernel modules, it'll depend on the community in the kernel development team to provide support for the 2.0 version of your ScreenPad.

  1. Try 5.6RC7 (the latest Release Candidate kernel out there as I'm writing this)

    sudo mhwd-kernel --install linux56
    
  2. Downgrade your UEFI / ScreenPad firmware.

:sob:

It's impossible to downgrade the ScreenPad and I don't think that the kernel dev. had done anything for us

What I've done is:

For using Intel APU: Right click on the pop-up => More actions => Configure special application settings => Minimize: Force: Yes => Apply
It sometimes still loses focus on applications but it's really less often than when it pops-up, so you can work. The problem stills with the VT, but you can use the second solution in that case (or if you're lucky you can spam left-click wherever you want and sometimes the pop-up just stops, in that case you're totally free for the session time)
For using nVidia GPU: The second screen still don't work but you doesn't have the pop-up anymore, but you don't seems to have the KDE environment too, so it's a little annoying, I use Yakuake to launch things, as far as I know how to replace KDE functions with CLI actions

1 Like

so please raise it upstream on the kernel mailing lists

1 Like

The Linux kernel one or a more specific branch?

Read the descriptions and decide for yourself please. However, usually the main list is used for users reporting bugs. If necessary you will get redirected to one of the hundreds of other lists.

Thanks but can I have something to stop the pop-up?

Because you still lose focus and it's very annoying

if someone knows

We can't help you: it's a bug and needs to be:

Therefore that's the solution and I've marked it as such.

:sob:

Forum kindly sponsored by