Second monitor wont work, after ram upgrade

Hi there kind manjaro community. I have a weird issue on hand. I installed my new ram yesterday. Its a 2x kingston fury 16gb 3600Mhz configuration. After booting the luks encryption unlock prompt now appears on my HDMI display, it was the display port one before. Weird i thought but whatever right? Unlocked my ssd and got to the login prompt. At at this point both monitors work just fine. After login, in the splash screen, both monitors go black for a second or so. Then i get to my desktop, but my HDMI Display says no input. Ok I thought, maybe the ram doesnt regonise or smth. Checked in system monitor. no, it gets correctly displayed as 32gb ram. My display gets recognized in xrandr tho. I tried
xrandr —output HDMI1 --auto. Did nothing. Also checked sudo systemctl --failed. Yesterday there was nothing. Today the following, although i dont think it has anything to do with the issue.
● archlinux-keyring-wkd-sync.service loaded failed failed Refresh existing keys of archlinux-keyring
In addition i tried switching the HDMI port to no avail. Strangely, when i go to a tty, both monitors work. They also work when i go sudo startx there. Haven´t found anything relating to this precise problem. Hope some kind stranger can help. Thanks in advance :slight_smile:

If you need more info, I´m glad to assist you.