Second monitor detected but getting no signal

i3
#1

I’m getting no signal on my second monitor even though it says connected on xrandr. I can even “move” my mouse to it, it’s just not appearing for some reason. I’m using an AMD CPU and Radeon GPU. Just fresh installed Manjaro yesterday with i3. Both monitors are connected to the graphics card via DVI. I have my computer dual booting into Windows and both screens work just fine. What can I do?

[jombo@jombo-pc ~]$ xrandr
Screen 0: minimum 320 x 200, current 3280 x 1050, maximum 16384 x 16384
DisplayPort-0 disconnected primary (normal left inverted right x axis y axis)
HDMI-0 disconnected (normal left inverted right x axis y axis)
DVI-0 connected 1600x900+0+0 (normal left inverted right x axis y axis) 442mm x 249mm
1600x900 60.00*+
1280x800 59.91
1152x864 75.00
1280x720 60.00
1024x768 75.03 70.07 60.00
832x624 74.55
800x600 72.19 75.00 60.32 56.25
640x480 75.00 72.81 66.67 59.94
720x400 70.08
DVI-1 connected 1680x1050+1600+0 (normal left inverted right x axis y axis) 474mm x 296mm
1680x1050 59.95*+
1600x1200 60.00
1400x1050 59.95
1280x1024 75.02
1440x900 74.98 59.90
1280x960 60.00
1360x768 59.95
1152x864 75.00
1024x768 75.03 70.07 60.00
832x624 74.55
800x600 72.19 75.00 60.32 56.25
640x480 75.00 72.81 66.67 59.94
720x400 70.08

#2

Figured it out and posting my solution just in case anyone else (just me in 5 years probably) runs into this problem.

The issue was that I had 2 different display resolutions, 16:10 and 16:9 and the second monitor would only show if it was 16:10. I guess Manjaro likes monitors being the same aspect ratio. But 16:10 looks ugly on a 16:9 monitor so that was not ideal. Anyway, I typed this into terminal:

sudo cvt 1600 900

Gets the output
Modeline "1600x900_60.00" 118.25 1600 1696 1856 2112 900 903 908 934 -hsync +vsync

Copy everything after Modeline into a new mode:

sudo xrandr --new-mode "1600x900_60.00" 118.25 1600 1696 1856 2112 900 903 908 934 -hsync +vsync

Then add the new resolution to the monitor

sudo xrandr --addmode DVI-0 1600x900_60.00

Output that too screen

sudo xrandr --output DVI-0 --mode 1600x900_60.00

EDIT: When you reset your computer this won’t work anymore. I actually don’t know how to edit xorg correctly to fix it permanently but made a work around.

Create a shell script with these lines but corresponding to your settings

#!/usr/bin/bash
xrandr --newmode "1600x900_60.00"  118.25  1600 1696 1856 2112  900 903 908 934 -hsync +vsync
xrandr --addmode DVI-0 1600x900_60.00
xrandr --output DVI-0 --mode 1600x900_60.00

Add this to visudo so you don’t need to run sudo on this file:
username ALL=(ALL) NOPASSWD: /home/jombo/fixmonitors.sh

Make that script run every time you startup your computer or login lol

This link helped me: https://askubuntu.com/questions/712564/why-cant-i-see-169-aspect-ratios

If anyone knows how to edit 10-monitor.conf to make this work instead of using the shell script, let me know! I haven’t figured it out (and probably won’t for a while)

4 Likes
#3

I would say, the monitor’s EDID was not ideal :wink:

Good fix!!

1 Like
#4

My original solution doesn’t work since once you reset your computer you have to do that all over again. There’s a way to edit x11’s 10-monitor.conf to keep the settings through reboots but I’m not sure how. I have the following in /usr/share/X11/xorg.conf.d/10-monitor.conf

Section "Monitor"
  Identifier "Monitor0"
  Modeline "1600x900_60.00"  118.25  1600 1696 1856 2112  900 903 908 934 -hsync +vsync
  Option "PreferredMode" "1600x900_60.00"
EndSection
Section "Screen"
  Identifier "Screen0"
  Device "DVI-0"
  Monitor "Monitor0"
  DefaultDepth 24
  SubSection "Display"
    Depth 24
    Modes "1600x900_60.00"
  EndSubSection
EndSection

Anyone know what I’m doing wrong?

#5

Did you read -->https://wiki.archlinux.org/index.php/multihead

Check if you have both monitor, right out, etc…

1 Like
closed #6

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.