Search bar is not working in gnome

gnome

#1

when I type something in search bar, just showing searching . . .
but working fine with other users account
I already installed required packages.
And gave all permissions to search.
Working in other account but not working in this account.

NOTHING IS WORKING

Please anyone help me how to fix this error.


#2

What does disable-tracker means and does ? If you know, than you know why

for the user you are showing the screenshot

Hint: it places files in /etc/skel/.config/autostart/ so all new users created after you installed disable-tracker will have those files in their ~/.config/autostart/


#3

Thank You Very Much For Your Kind Information. But I Didn’t understand what You Said(This is My First Linux Os. )
where I can find that files and how to disable them?


#4

and how please help with installing .tar.xz files.


#5

First, remove the disable-tracker since it disables the tracker … Tracker is all you need for search function to work.

The sign ~ means Home directory for the user.
.config is a hidden (by default) configuration folder in Home directory of that user.
autostart is the folder where all that user applications will autostart when logs in.

Much clear now? :slight_smile:

NO!!!
As long as i don’t know what those installs are about, i don’t know their source i will not give any information on how to go about and install them :slight_smile: A few reasons why:

  • as you stated

so i don’t want you to break your system

Fair enough? :slight_smile:


#6

Thank you!


#7

I have disabled disable-tracker. .but still not working. . .


#8

How you disable it?


#9

By Unchecking the package in pamac That’s it!


#10

But that doesn’t remove the files it put there, when was installed, in the user .config autostart folder i was mentioning …


#11


now which file is supposed to be disable/delet?


#12

Is this from the working search user or from the non working search user ?


#13

From not working search user!


#14

Ok, now go to Settings > Search and make sure all the search functions are ON.


#15


but still not working!:disappointed_relieved:


#16

Ok, now the only thing i can think of is to:
rm -r ~/.cache/tracker/*
reboot and the tracker will recreate the data base for search.


#17

But Menu at the top left corner is working fine.(I’m surviving with that)


#18

the reason is an extension called gnome fuzzy search (now everything working fine)
Thank You


#19

I wouldn’t guess in 100 years that a random installed extension, that DOESN’T come with Manjaro Gnome install, that YOU installed after but never mentioned in your posts till now, will solve your search issue by turning it OFF.


#20

good job figuring it out, i too had to learn the hard way with gnome. in the future if something gnome related is not working start by disabling all extensions, if problem is fixed, start turning them back on 1 at a time until the problem re-surfaces and then you’ll know what caused it.