Sddm登录界面中文和英文混搭

为什么只有重启是中文其它都是英文,在哪里可以修改一下,或者有什么其它的SDDM推荐的

這個在某一次 KDE 改版後就這樣了,到現在都還無解。要 KDE Plasma 那邊修改才行。

是不是可以在/usr/share/sddm/themes/这里面改呢?

就是我想:
1.把英文的部分改回中文
2.把时间改成24小时

反正同步SDDM是解决不了的

                actionItems: [
                    ActionButton {
                        iconSource: "system-suspend"
                        text: i18nd("plasma_lookandfeel_org.kde.lookandfeel","Suspend")
                        onClicked: sddm.suspend()
                        enabled: sddm.canSuspend
                        visible: !inputPanel.keyboardActive
                    },
                    ActionButton {
                        iconSource: "system-reboot"
                        text: i18nd("plasma_lookandfeel_org.kde.lookandfeel","Restart")
                        onClicked: sddm.reboot()
                        enabled: sddm.canReboot
                        visible: !inputPanel.keyboardActive
                    },
                    ActionButton {
                        iconSource: "system-shutdown"
                        text: i18nd("plasma_lookandfeel_org.kde.lookandfeel","Shutdown")
                        onClicked: sddm.powerOff()
                        enabled: sddm.canPowerOff
                        visible: !inputPanel.keyboardActive
                    },
                    ActionButton {
                        iconSource: "system-switch-user"
                        text: i18nd("plasma_lookandfeel_org.kde.lookandfeel","Different User")
                        onClicked: mainStack.push(userPromptComponent)
                        enabled: true
                        visible: !userListComponent.showUsernamePrompt && !inputPanel.keyboardActive
                    }]

摘自/usr/share/sddm/themes/breath2/Main.qml

这玩意居然是qml的吗。。
qml的话理论上把text: i18nd(...) 改成text: ”重启“就行了。