SDDM not fullscreen on ultra width screen

Hi, for a while now I have an ultra width screen which works flawless in KDE. The only exception is SDDM which only shows a low resolution rectangle in the center of the screen. Meaning it covers the height from top to bottom of the screen and a similar width, with one quarter of the screen on each side black. Workable, but not good-looking. I played around with the usual high dpi and scaling settings according to SDDM - ArchWiki, but to no avail. The scaling definitely works and I probably could get it to the correct value, but it doesn’t change the fact that it doesn’t cover the full screen. There is one situation in which everything works (fullscreen, correct resolution, correct dpi…) and this is after booting into my Windows 10 installation and then back into Manjaro. The next reboot of Manjaro resets me back to the low resolution half screen situation.

Can anybody give me a tip how to always get the correct resolution/dpi in SDDM? Any help is appreciated. Thank you.

sounds like initializing graphics in the console mode before sddm sstarts could help. Early KMS.

That is strange

  • the defaults usually work OOB
  • personally I am using a 5120x1440 display with a secondary 1920x1080
  • I have the sddm show fullscreen on both displays
  • background sized to match

That’s why I’m here asking about it. The only situation when it works is after booting into Windows and then going back to Manjaro.

Only is left to speculate then - and it is only speculation - you need to do that hard work - I have no idea

  • the issue is not common - that is certain !
  • using a custom sddm theme perhaps ?
  • customized sddm in /etc/sddm.conf or a drop-in in /etc/sddm.conf.d/ ?
  • appearing after resume from sleep or hibernate ?
  • xorg vs wayland ?
  • a custom layout in Settings Manager → Display & Monitor ?
  • reproducable with a second user ?
  • a corrupt session file in ~/.local/session ?
  • System Settings → Session ?

in addition to early kms you could also try setting sddm to use wayland instead of x11

Can you past the content of /etc/sddm.conf.d/kde_settings.conf ?

Well, you didn’t even bother to respond to my post; not even a thanks anyway; so, I’ll delete it and write it off as wasted effort.

Good luck.

Dude, I was at work and didn’t have time to check out every suggestion yet or even try it. Still thank you for trying to help. And thank you to everyone else, too.

If anyone has the same problem: Switching SDDM to Wayland solved it. Make sure you set everything under SDDM - ArchWiki or else you cannot login for some reason (password wasn’t accepted and I got a “Login failed”).

Dude, you’re welcome.

Wayland is getting better all the time, while X11 still suffers from long-ignored bugs and other annoyances. Cheers.

i only put the example /etc/sddm.conf.d/10-wayland.conf from there and it works fine

BTW did you try the early KMS? Since it worked after booting into windows, it seems the root problem was x11 and it’s handling of initializing your ultrawide monitor. So once it was initialized by windows, it worked correctly on sddm.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.