Screenshots crash Manjaro in latest update

I very recently updated to the latest manjaro version with Gnome 3.38. When I try to take screenshots, my computer crashes and I have to reboot. Is this a known issue or something that’s more or less unique to my system?

Let’s make sure was not partial update. Run from terminal:
sudo pacman-mirrors -f && sudo pacman -Syyu

What error you get if you start gnome-screenshot from terminal? Maybe you can catch it before it crashes.

How does this till me if it is a partial update?

I do get this error:
::ERROR ftp error: error_perm(‘550 Failed to change directory.’) ‘

Also somehow gnome-wallpapers is newer than community.

Run again the command and use an extra u
sudo pacman-mirrors -f && sudo pacman -Syyuu
all should get back to normal …

It still crashes just as before. However I just found that I am able to take pictures of specific windows through the gnome screenshot tool

There’s a bug in gnome screenshot with dhpi resolution not sure if its related to you or not but I filed it on github. Im using one of the other screenshot apps from the manjaro repo atm

Which one are you using, if I may ask?

UPDATE: I just tried flameshot and that didn’t work either, so it seems that the problem is not really related to gnome-screenshot in particular.

Im using pantheon-screenshot (io.elelementary). Like I said my issue is from hi-dpi and where gnome screenshot gets its resolution from, yours may well be a different issue

When I try to use pantheon-screenshot, it says “Can’t find active window” and does not capture a screenshot

Both screenshot and imagemagick import crash my computer, running gnome v3.38.1. @JoelEng did you find a solution to your problem?

It seems to be a problem with mutter and how it handles blur. I have not found a real solution, but disabling blur-my-shell solved it for me. My shell is no longer as pretty, but I suppose I will have to live with that until someone fixes the issue.

If you use Blyr or anything else rather than blur-my-shell, disabling that should give the same result.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.