Screen wakes up immediately after sleeping (screen energy saving)

I have screen energy saving on to switch my screens off after a few minutes, but instead of staying off they turn right back on again (my monitors show that there is no signal for a split second then the signal comes back).

Any applications that are fullscreen on my first monitor are moved over to my second monitor once the screens wake back up to.

I can’t find anything online. I did try turning off wifi and closing a bunch of apps to see if they were waking the screen back up, but that didn’t work.

I’m on the linux 5.11.2-1 kernel with plasmashell 5.21.2.

How can I fix the screens not staying off and stop it from moving fullscreen apps to my other monitor?

Edit: I’ve just figured out that if I turn off my second monitor, then when I click sleep it will sleep my first monitor properly (this doesn’t work vice versa so maybe something up with my second monitors configuration in KDE? Sleeping worked on my old install so It shouldn’t be anything hardware wise if it even can be).

1 Like

I have since reinstalled manjaro for a different reason and I’m still being annoyed by these two bugs. Does anyone know what may be at fault here?

I have also noticed that after waking up, animations are disabled and I have to press alt+shift+f12 to enable them again (Desktop effects have been suspended by another application.
You can resume using the ‘Alt+Shift+F12’ shortcut).

This bug occurs when KDE sleeps my screens itself and also when I run this command: xset dpms force off.

Same problem in Ubuntu 18.04 and AlmaLinux 8 with KDE and xfce4. I wrote a bash script that commands xset dpms force off in a loop if idle time less than 400ms (I do not know if there is a better way).

#!/bin/bash
sleep 1.0
for((;;));do
if [ $(xprintidle) -lt 400 ];then
break
fi
sleep 0.2
xset dpms force off
done

Be sure that xprintidle installed on your system or you have to reboot to get screen working again.

Try the following settings on your monitors:

Set “Input Select”: Auto → HDMI1
Set “DDC/CI”: Yes → No

It worked for me!