Screen tearing on XFCE with NVIDIA 940x & Intel graphics + nvidia-settings could not find the registry key


My screen tears horribly while gaming and watching videos both on VLC or through my web browser. I can fix partially the problem with video by temporarily disabling display compositing at “Window Manager Tweaks -> Compositor -> Enable display compositing” but frankly it’s a mediocre solution and I can’t activate/reactivate compositing at will and as I said, it fixes video but gaming remains the same.

I’ve seen that several users simply run sudo nvidia-settings, go to X-Server Display Configuration -> Advanced -> Activate “Force Composition Pipeline”… but when I execute that command the window I get doesn’t have the “X-Server Display Configuration” menu! and I also get an error that reads as follows:

nvidia-settings could not find the registry key file. 
This file should have been installed along with this driver at
The application profiles will continue to work, but values cannot be 
prepopulated or validated, and will not be listed in the help text.
Please see the README for possible values and descriptions

I have a feeling (just a hunch I might be wrong) that the missing menu in Nvidia Settings isn’t there because of the missing registry key file. I’d post an image or a link to how my Nvidia Settings looks like, but the forum won’t let me.

EDIT: A last piece of information. While checking the nvidia.conf file at /etc/X11/mhwd.d/, the file is empty, with the “Generated with mhwd” message and nothing else.

At this point I’m at a loss. Can you help me?

The following is my setup as per inxi-G:

  Device-1: Intel HD Graphics 620 driver: i915 v: kernel 
  Device-2: NVIDIA GM108M [GeForce 940MX] driver: nvidia v: 440.100 
  Device-3: Chicony USB 2.0 Webcam Device type: USB driver: uvcvideo 
  Display: x11 server: X.Org 1.20.8 driver: modesetting,nvidia 
  unloaded: intel resolution: 1366x768~60Hz 
  OpenGL: renderer: Mesa Intel HD Graphics 620 (KBL GT2) v: 4.6 Mesa 20.1.7 

Thank you very much for your time!

1 Like

But in your case I would guess you are using prime, so instead of the one for bumblebee

sudo optirun -b none nvidia-settings -c :8

You probably would need prime-run, ex:

sudo prime-run nvidia-settings

PS - I dont know for sure, because I avoid nvidia … but it seems pretty reasonable that on your hybrid system you need to initialize the card to use nvidia-settings just like in all other cases.

1 Like

Thank you for your response. I don’t use bumblebee (actually I want to install Optimus, but I guess that first I need the “registry key file”). I ran your second command and received the same error (nvidia didn’t find registry key file") and received the same incomplete window.

EDIT: I also receive the following error message:

(nvidia-settings:2704): GLib-GObject-CRITICAL **:
09:18:13.433: g_object_unref: assertion 'G_IS_OBJECT (object)' failed

nvidia-smi works properly.

1 Like

That only works for monitors which are directly connected to the nvidia gpu. It seems you have a hybrid configuration, and the display in question is the integrated panel. In that case, that option simply does not exist.

You might want to check this and this.


I just installed optimus and manually switching from intel to NVIDIA fixed the issue in one game (Amnesia) but Oblivion now renders slowly, starting from the top left corner and progressing throughout the screen. This is not correct, because this PC on its Windows partition (which I intend to remove as soon as I can fix this issue) runs Fallout: New Vegas with the highest settings without problems, as well as other newer games.

And I have no 20-intel.conf file at that location! It’s not as a hidden file either.

The xfwm command did fix the tearing, even with active composition! Thanks!

I solved the problem by:

  1. Installing optimus. The X-Server Dizplay is accessible only when the NVIDIA GPU is the one active, via optimus.
  2. Running the adviced xfwn command by @pobrn
  3. Starting Bethesda’s games on Proton 4.11 instead of its latest version, which removed that weird lag/stutter bug on both games.

I still have no config files, but I guess I’ll try to fix that later. Thank you all for your help.

I guess you mean bumblebee and optimus-manager ?

Guess you mean nvidia-settings … which was already covered on the wiki and above.
(yes on a dual-gpu system you need to invoke the nvidia card to use its tools…)

OK - well thats just super specific to that game, card, etc. But yay for finding a workaround.

You arent really supposed to… at least not all the ones you see referenced … You would create them if needed. (though I kinda doubt you dont have any config files … especially with your optimus-manager stuff)

Given your responses … I am still not sure you set things up as normal - such as by using mhwd, etc. Or that you quite grasp how optimus systems work - either through bumblebee or PRIME.
[it seems your solution is to install legacy bumblebee, and use optimus switch to effectively only use the nvidia card … I am not sure whether thats actually desirable or not]
But I guess if it works it works…

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.