Screen tearing appears after watching movies on VLC or using Simplescreenrecorder | SOLVED

Hello! I recently installed manjaro i3. On a fresh install there were screen tearing but i fixed it by adding tearfree option. But after watching a movie on VLC or using Simplescreenrecorder I get screen tearing again. There is 0 tearing while watching a movie or recording screen. This problem can be fixed with logging out and in again. But what actually causes this? I want to make this system 100% screen tear free.
I have Nvidia Geforce gtx m960.

The problem appears also after using musescore

reproduce the issue, then see if restarting the compositor fixes it

killall compton
compton

does it go away?
yes? possibly try other compton rendering backend/vsync settings. for example:

compton --backend xrender --vsync opengl  

no?
post output of:

inxi -Fxxxz
mhwd -li
ls -laR /etc/X11/
grep -v /etc/X11/xorg.conf.d/*.conf

Restarting compton does not fix an issue. Maybe i should try different driver? Ayway, here is output of all those 4 commands:
https://pastebin.com/tCSqtc0U

so you did try or you did not try?

there are a couple things you can try with xorg configuration.
in /etc/X11/mhwd.d/intel.conf

DRI=true enables DRI “2” . and dri 3 is the default so try that first, if thats not enough, change “sna” to “uxa”

Section "Device"
    Identifier  "Device0"
    Driver      "intel"
    Option      "AccelMethod" "sna"  #<---change to uxa
    Option      "TearFree" "true" 
    Option      "DRI"    "true"  #<---change to "3"
EndSection

if after that it does not work properly, you can change your video driver configuration. i would recommend PRIME or optimus-switch. both of those will give you bettter performance than bumblebee and optimus-switch allows you to easily switch between intel-only mode and nvidia prime mode. both prime and optimus-switch use the video-nvidia drivers. no bumblebee/nouveau/bbswitch necessary.

read here for comparisons in optimus options

How would I then know a result if not by first trying suggested action? Of course I did try it. I will try options you presented once I’m back home. Thank you for response!

i only asked because the way it was worded, i wasnt sure if you tried it or if you dismissed it as nonsense (this happens alot with some folks, so i asked).

what video configuration you should use is determined by what your intended use for the laptop is.

is battery life a concern? use optimus-switch instead of PRIME
not a concern? use PRIME

im not crazy about bumblebee and it’s limitations if you cant tell. anyway if you need a hand setting up one of those options, let me know. both have easy to follow tutorials

You are very helpful person, thank you for that!
Unfortunately, changing options in AccelMethod and DRI did not result in better performance.
I am ready to use PRIME. My concern is not battery. I want this machine to be as fast as it possibly can be using manjaro i3. And of course I want it to be tearfree at all times.
I found this [HowTo] Set up PRIME with NVIDIA proprietary driver
but since I am still a Linux newbie I already have confusion on step 2:
“Use mhwd or MSM to install the nvidia driver in the normal way.”

What exactly is normal way? pacman -S nvidia ?

Sure, I can use manuals but this seems kind of a recipe for breaking my system… I guess I already mentioned on a different (similar) post about my talent to break OS :smiley: … anyway, if you have a patiante for a little guidance that would be most appreciated.

ok, following that tutorial, uninstall any video drivers first, before anything else. and in your case using bumblebee, be sure bumblebee is disabled and removed entirely

sudo systemctl disable bumblebeed
#then remove video drivers

sudo mhwd -r pci video-linux
sudo mhwd -r pci video-hybrid-intel-nvidia-bumblebee

#if no errors, proceed

sudo mhwd -i pci video-nvidia

now, check related directories and remove any video configuration files

ls -laR /etc/X11
#remove any gpu related configurations in
/etc/X11/xorg.conf.d/
/etc/X11/mhwd.d/

then continue following the directions.

also: check to make sure there are no bbswitch packages installed, if there are, remove them
pacman -Qs bbswitch
if there is no output, thats good. if there is, remove those packages.

other common points of confusion i noticed helping others in the past:

  • not noticing that these are drop downs with the content for each file you create.
this is a drop down, click me

this is file content

  • at step 5, only follow the directions for the DM your using. in your case its LightDM. ignore GDM and SDDM instructions
1 Like

Holly smokes! No errors, no mistakes! Pure success! Thank you so much, dgit! :wink:

1 Like

always good to hear. glad it worked out, and your welcome.

1 Like