Screen tearing and poor perfomance with Nvidia even after trying all solutions that I found

Hey, guys. I'm a Windows user, but trying to change to Linux for a lot of reasons. First, I installed Deepin Linux, but I had some problems (non-video related like now). Then, I searched for a more mature and more used distro, so I found Manjaro.
I installed Manjaro KDE on last friday and I'm enjoying so much, but I have a problem: poor perfomance with Nvidia. I have a GTX 950 2GB and I have the following problems:

1 - Screen tearing,
2 - When I'm in heavy websites, the page get laggy for example:
If I go to Twitch.TV and try to chat in the stream, it's not smooth, it's not normal, it's like the letters has a delay to show up or if I try to change the volume, it changes but it's not smooth, it's laggy.
If I change the stream's resolution to 1080p, it freezes and only sound keeps running;

I've already try everything that I found on internet and I'm trying to solve this since friday. I have tried this:

(I'm already using property nvidia driver since installation)

1 - Create a file called kwin.sh and put it in /etc/profile.d with the following lines:

#!/bin/sh

export KWIN_TRIPLE_BUFFER=1

2 - Go to "sudo nvidia-settings" and check "Force Composition Pipeline" and save to X Configuration File in /etc/X11/mhwd.d/nvidia.conf

3 - Go to "sudo nvidia-settings" and check "Force Full Composition Pipeline" and save to X Configuration File in /etc/X11/mhwd.d/nvidia.conf

4 - Uncheck "Sync to VBlank" under OpenGL Settings

5 - Uncheck "Allow Flipping" under OpenGL Settings

6 - In Compositor change "Tearing prevention ("vsync")" to Full screen repaints

7 - In Compositor change "Tearing prevention ("vsync")" to Re-use screen content

8 - In compositor change "Rendering backend" to OpenGL 3.1

I tried all this separately and all together and nothing solved my problems. I don't know what else to do. I really don't want go back to Windows. Can anyone help me?

wait some time may be a month until kwin with nvidia support comes in manjaro.
and see if it helps
https://www.phoronix.com/scan.php?page=news_item&px=EGLStreams-Merged-KWin-5.16

That is primarily for wayland. kwin already works with nvidia on X.

I'm learning how to use the forum yet. My message was:

So, what does this mean for me? Are the problems I have unusual?

It is a matter of getting the settings right. Hopefully someone with more experience will come along and help.

I am not sure how all those settings interact, for example, I have never tried checking both "Force Composition Pipeline" and "Force Full Composition Pipeline"

I was thinking on install Manjaro XFCE. Do you think it would resolve my problems since I think its all about the KDE?

Do not use use emotional blackmail to get support. It does not matter to anybody here whether you go back to Windows or not. It is a real put off, especially for a first time poster.

I would recommend using whatever desktop you prefer and trying to get the issues fixed. Switching often just brings in a new set of challenges.

But if you like XFCE, go for it.

I think I'm not being emotional. I really don't want got back to Windows. I already tried Ubuntu, Deepin Linux and now Manjaro. I don't know why you got bothered about I'm saying "I really don't want got back to Windows".

I like both, I just want to fix it. XFCE don't use KDE, right? I just thought that changing desktop environment would fix that, I don't know if the problems I have is related to this.

Try it out. Experimentation is one of the things that makes technology fun.

Ok, thank you. I'll wait a little to someone try to help me. If I don't get an answer, I'll try XFCE. Thank you again.

After researching a little more and nothing new, I tried the last thing: install Google Chrome. I don't know why I had this problem with Firefox and I don't know what happned, but when I installed Chrome, all my problems were gone. Futhermore, I reverted all things that I mentioned on my post, in other words, I'm not using any tricky to everything work as it should. Thank you who tried to help me.

1 Like

If you did that, you have to make sure that the option is present in the nvidia.conf too, but also a second option in the Section "Device" like this:


    Option         "TripleBuffer"  "On"
    Option  "ConnectToAcpid"    "Off"

Another thing, if you want to follow the new kwin.sh thing, you could actually use:

export KWIN_TRIPLE_BUFFER=1
export __GL_YIELD=USLEEP
export __GL_MaxFramesAllowed=1

Like I said, I moved to Chrome and it's working nice. Should I do that? I wanna try some games in the future, is it going to help me?

Would switching to wayland help? Nvidia/kde user too.