Screen stopped working

Two days ago, while working on my toshiba laptop using manjaro OS, all of a sudden my screens (both my laptop screen and my external screen) stopped working. the external screen still works fine with another pc and my laptop screen works when i press ctrl-alt-del, but as soon as i log in again, the screen stops working again.
i was planning to reinstall the whole system, but i really want to back up the data on my hard disk first.
what can i do?

First, use search function!
Second, welcome :slight_smile:


i was hoping to find a way to fix the problem with the screen first. i didn't find a discussion on that topic on the forum while using search. maybe i should have been less ambiguous when i asked the question.

thank you for the tip about saving my data.

I had a similar issue since one of the last updates. The external screen would not work anymore after logging in.
Had to delete my display config:

killall xfconfd
rm ~/.config/xfce4/xfconf/xfce-perchannel-xml/displays.xml

reboot

I think it is caused by a bug in xfce (should be fixed soon I guess):

Also try disabling "Configure new displays when connected" in the display settings.

2 Likes

the problem is that the screen i get after ctrl-alt-del is literally the only screen i ever see. the monitor is black the rest of the time. i can't open a terminal to enter any commands. i first thought the problem was a hardware failure, until i notices that the lock screen after ctrl-alt-delete works without any problem.

you should be able to switch to tty and do it from there.
Ctrl + Alt + F2, log on, run commands, reboot

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by Bytemark