Screen sharing of specific application windows not working on Conference apps(Google Meet, Jitsi)

Dear fellow users of Manjaro,

I recently bought a Thinkpad E15 coming from a 8 yr old Lenovo Ideapad. I’m a teacher and have to conduct my lectures on Google Meet on Brave Browser.

I have encountered a problem that I’m not able to see any application windows to share. The other two options of sharing Entire Screen and Tab work flawlessly, but the specific window sharing is not working or rather not displaying any options (unable to show screenshots: unable to embed media items in a post error)

The feature seems to be working perfectly fine on my older laptop with the same browser version and fully updated OS. I went to all options of the browser and they are identical on both PCs.

I tried it on Firefox, Chromium and the platforms Google Meet and Jitsi, all seem to have the same problem.

If anyone can help find a solution, I’ll be deeply obliged.

Thank you.

Hello @Ace_Mcloud :slight_smile:

I use Gnome3 (Xorg) with Firefox v89 and for example Google Meets works perfectly. I can simply share a window (application).

Does something similar like this popup on Firefox when sharing a window? (it is the popup to allow sharing a window)


(Sorry, my DE is german :smiley: )

The problem could be also Xorg and Wayland? Are using only KDE?

Thank you so much for the reply.

I tried it on firefox as you suggested. I get the same popup as yours where the “Allow” button is faded out.

But if I click on the drop-down menu and change it to entire screen, it works fine (shows the small preview window and Allow button is clickable)

On chromium based browsers, it’s similar case where it allows me to choose between 3 tabs (entire screen, window or browser tab). But there are no application windows visible to choose from in the window tab.

And yes, I’m using Manjaro KDE.

Hope you understood whatever I’m stating above. The forum is not allowing me to post screenshots.

(Ich kann ein bisschen Deustch verstehen. So, das macht’s nichts. Und vielen dank für Ihre Hilfung. :smiley:)

mh… ok what is the difference…

Could you check this on the terminal?

pamac search xdg-desktop-portal --no-aur --installed

For example, I have these ones installed:

$ LANG=C pamac search xdg-desktop-portal --no-aur --installed                                                                                                               ✔ 
xdg-desktop-portal-gtk                                                                                                                                                    1.8.0-1  extra 
    A GTK+ backend for xdg-desktop-portal
xdg-desktop-portal                                                                                                                                                        1.8.1-1  extra 
    Desktop integration portals for sandboxed apps

Is your system updated?

pamac update --force-refresh

Btw… here you can test the screen share function: gUM Test Page

I checked the command below:

My output was as follows:

$ pamac search xdg-desktop-portal --no-aur --installed  
xdg-desktop-portal-kde                                                                              5.21.5-1  extra 
    A backend implementation for xdg-desktop-portal using Qt/KF5
xdg-desktop-portal-gtk                                                                              1.8.0-1   extra 
    A GTK+ backend for xdg-desktop-portal
xdg-desktop-portal                                                                                  1.8.1-1   extra 
    Desktop integration portals for sandboxed apps]

The o/p is same after the pamac update force refresh command.

I tried out gUM Test Page.

On Brave
Camera, Microphone, Screen Capture (Entire Screen and Tab) : Prints out Success! and works
Screen Capture (Window): Again no window showing and share is not clickable

“NotAllowedError: Permission denied” shows up on the gUM test page instead of the “Success!”.

On Firefox

Camera, Microphone, Screen Capture (Entire Screen) : Prints out Success! and works
Screen Capture (Select window or screen): Allow is not clickable on the dialog box.

Nothing appears on the gUM test page.
Now if I click on block, it displays “NotAllowedError: The request is not allowed by the user agent or the platform in the current context.”

I am not a KDE User and I guess it is a KDE specific issue. Since my research gave me zero answers, I would ask one of the @moderators who uses KDE everyday, if they know what the problem there is. What could it be?

It would be also good when you provide some system information:

inxi -Fazy

I get the feeling that this is some minor security toggle which has been turned off on my PC. However, its just a hunch. The experts would know better.
Nevertheless, thank you for your help @megavolt. I deeply appreciate it.

My system info:

  Kernel: 5.12.9-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.12-x86_64 
  root=UUID=6ee1cf0b-63f0-4310-a11c-9adaff35298b rw quiet udev.log_priority=3 
  Desktop: KDE Plasma 5.21.5 tk: Qt 5.15.2 wm: kwin_x11 vt: 1 dm: SDDM 
  Distro: Manjaro Linux base: Arch Linux 
  Type: Laptop System: LENOVO product: 20T8CTO1WW v: ThinkPad E15 Gen 2 
  serial: <filter> Chassis: type: 10 serial: <filter> 
  Mobo: LENOVO model: 20T8CTO1WW serial: <filter> UEFI: LENOVO 
  v: R1AET36W (1.12 ) date: 03/15/2021 
  ID-1: BAT0 charge: 42.4 Wh (99.8%) condition: 42.5/45.0 Wh (94.4%) 
  volts: 12.9 min: 11.3 model: Celxpert 5B10X026 type: Li-poly 
  serial: <filter> status: Unknown cycles: 21 
  Device-1: hidpp_battery_0 model: Logitech Wireless Mouse M185 
  serial: <filter> charge: 55% (should be ignored) rechargeable: yes 
  status: Discharging 
  Info: 6-Core model: AMD Ryzen 5 PRO 4650U with Radeon Graphics bits: 64 
  type: MT MCP arch: Zen 2 family: 17 (23) model-id: 60 (96) stepping: 1 
  microcode: 8600103 cache: L2: 3 MiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm 
  bogomips: 50322 
  Speed: 1397 MHz min/max: 1400/2100 MHz boost: enabled Core speeds (MHz): 
  1: 1397 2: 1397 3: 1397 4: 1397 5: 1397 6: 1397 7: 1397 8: 1397 9: 1397 
  10: 1397 11: 1397 12: 1397 
  Vulnerabilities: Type: itlb_multihit status: Not affected 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, IBRS_FW, 
  STIBP: conditional, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
  Device-1: AMD Renoir vendor: Lenovo driver: amdgpu v: kernel bus-ID: 04:00.0 
  chip-ID: 1002:1636 class-ID: 0300 
  Device-2: IMC Networks Integrated Camera type: USB driver: uvcvideo 
  bus-ID: 1-3:2 chip-ID: 13d3:56ff class-ID: 0e02 
  Display: x11 server: X.Org 1.20.11 compositor: kwin_x11 driver: 
  loaded: amdgpu,ati unloaded: modesetting alternate: fbdev,vesa 
  display-ID: :0 screens: 1 
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") 
  s-diag: 582mm (22.9") 
  OpenGL: renderer: AMD RENOIR (DRM 3.40.0 5.12.9-1-MANJARO LLVM 12.0.0) 
  v: 4.6 Mesa 21.1.2 direct render: Yes 
  Device-1: AMD vendor: Lenovo driver: snd_hda_intel v: kernel bus-ID: 04:00.1 
  chip-ID: 1002:1637 class-ID: 0403 
  Device-2: AMD Raven/Raven2/FireFlight/Renoir Audio Processor vendor: Lenovo 
  driver: N/A alternate: snd_pci_acp3x, snd_rn_pci_acp3x bus-ID: 04:00.5 
  chip-ID: 1022:15e2 class-ID: 0480 
  Device-3: AMD Family 17h HD Audio vendor: Lenovo driver: snd_hda_intel 
  v: kernel bus-ID: 04:00.6 chip-ID: 1022:15e3 class-ID: 0403 
  Sound Server-1: ALSA v: k5.12.9-1-MANJARO running: yes 
  Sound Server-2: JACK v: 0.125.0 running: no 
  Sound Server-3: PulseAudio v: 14.2 running: yes 
  Sound Server-4: PipeWire v: 0.3.30 running: no 
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Lenovo driver: r8168 v: 8.048.03-NAPI modules: r8169 port: 3000 
  bus-ID: 02:00.0 chip-ID: 10ec:8168 class-ID: 0200 
  IF: enp2s0 state: down mac: <filter> 
  Device-2: Realtek RTL8822CE 802.11ac PCIe Wireless Network Adapter 
  vendor: Lenovo driver: rtw_8822ce v: N/A modules: rtw88_8822ce port: 2000 
  bus-ID: 03:00.0 chip-ID: 10ec:c822 class-ID: 0280 
  IF: wlp3s0 state: up mac: <filter> 
  Device-1: Realtek Bluetooth Radio type: USB driver: btusb v: 0.8 
  bus-ID: 3-4:3 chip-ID: 0bda:c123 class-ID: e001 serial: <filter> 
  Report: rfkill ID: hci0 rfk-id: 2 state: up address: see --recommends 
  Local Storage: total: 476.94 GiB used: 26.64 GiB (5.6%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: MZALQ512HALU-000L1 
  size: 476.94 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s 
  lanes: 4 rotation: SSD serial: <filter> rev: BL1QFXV7 scheme: GPT 
  ID-1: / raw-size: 50 GiB size: 48.91 GiB (97.83%) used: 10.83 GiB (22.1%) 
  fs: ext4 dev: /dev/nvme0n1p4 maj-min: 259:4 
  ID-2: /boot/efi raw-size: 100 MiB size: 96 MiB (96.00%) 
  used: 25.2 MiB (26.3%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1 
  ID-3: /home raw-size: 286.82 GiB size: 281.26 GiB (98.06%) 
  used: 15.79 GiB (5.6%) fs: ext4 dev: /dev/nvme0n1p5 maj-min: 259:5 
  Alert: No swap data was found. 
  System Temperatures: cpu: 48.5 C mobo: 0.0 C gpu: amdgpu temp: 40.0 C 
  Fan Speeds (RPM): cpu: 0 
  Processes: 289 Uptime: 2m wakeups: 7 Memory: 14.93 GiB 
  used: 1.55 GiB (10.3%) Init: systemd v: 248 tool: systemctl Compilers: 
  gcc: 11.1.0 Packages: pacman: 1151 lib: 323 Shell: Bash v: 5.1.8 
  running-in: konsole inxi: 3.3.04 

Finally able to upload screenshots.
Entire Screen Sharing Works.

Tab sharing Works.

But Window sharing doesn’t. :confused:

@moderators kindly help me out.
If any additional info is required from my end, let me know and how to obtain it (newbie).

I have a similar problem with meet in chrome(firefox works). Try this if it works.
Ps. I’m a newb, I found this by googling.

Thanks @basudebpal . I tried looking up that link that you sent. I couldn’t make much sense of it. Newbie here too. :sweat_smile: