Screen sharing and screenshots only work with KDE/openbox, but not with KDE/X11 or KDE/Wayland

Screen sharing and screenshots only work with KDE/openbox, but not with KDE/X11 or KDE/Wayland. I had issues with screenshots for a long time, but I used them rarely, so I decided to live with that. But then I discovered, that screen sharing in zoom didn’t work either (from the app and from the browser). Tried with live-cd: Manjaro LXFCE, Ubuntu GNOME - everything works. Then I tried screen sharing with KDE/Wayland, KDE/openbox on the new user - KDE/Wayland can only share one window (when I share the whole screen, it’s just black with a cursor), and as it seems, KDE/openbox doesn’t have any issues at all. My main environment: KDE/X11 doesn’t work at all (even with one window): it doesn’t show the correct window, it lags, and constantly switches between two inactive windows. inxi -Fx output:

   Host: dan-lt Kernel: 5.15.7-1-MANJARO x86_64 bits: 64 compiler: gcc
     v: 11.1.0 Desktop: KDE Plasma 5.23.4 Distro: Manjaro Linux base: Arch Linux
   Type: Laptop System: LENOVO product: 81WE v: IdeaPad 3 15IIL05
     serial: <superuser required>
   Mobo: LENOVO model: LNVNB161216 v: NO DPK serial: <superuser required>
     UEFI: LENOVO v: EMCN47WW date: 07/29/2021
   ID-1: BAT0 charge: 9.5 Wh (29.9%) condition: 31.8/35.0 Wh (90.9%)
     volts: 7.9 min: 7.5 model: SMP L16M2PB2 status: Charging
   Info: quad core model: Intel Core i5-1035G1 bits: 64 type: MT MCP
     arch: Ice Lake rev: 5 cache: L1: 320 KiB L2: 2 MiB L3: 6 MiB
   Speed (MHz): avg: 1100 high: 1102 min/max: 400/3600 cores: 1: 1100
     2: 1101 3: 1100 4: 1100 5: 1101 6: 1102 7: 1101 8: 1100 bogomips: 19048
   Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
   Device-1: Intel Iris Plus Graphics G1 vendor: Lenovo driver: i915 v: kernel
     bus-ID: 00:02.0
   Device-2: Syntek Integrated Camera type: USB driver: uvcvideo
     bus-ID: 1-5:2
   Display: x11 server: X.Org driver: loaded: intel
     resolution: 1920x1080~60Hz
   OpenGL: renderer: Mesa Intel UHD Graphics (ICL GT1) v: 4.6 Mesa 21.2.5
     direct render: Yes
   Device-1: Intel Ice Lake-LP Smart Sound Audio vendor: Lenovo
     driver: snd_hda_intel v: kernel bus-ID: 00:1f.3
   Sound Server-1: ALSA v: k5.15.7-1-MANJARO running: yes
   Sound Server-2: JACK v: 1.9.19 running: no
   Sound Server-3: PulseAudio v: 15.0 running: yes
   Sound Server-4: PipeWire v: 0.3.40 running: yes
   Device-1: Intel Ice Lake-LP PCH CNVi WiFi driver: iwlwifi v: kernel
     bus-ID: 00:14.3
   IF: wlp0s20f3 state: up mac: e0:d4:64:08:b7:3b
   Device-1: Intel Bluetooth 9460/9560 Jefferson Peak (JfP) type: USB
     driver: btusb v: 0.8 bus-ID: 1-10:4
   Report: rfkill ID: hci0 rfk-id: 3 state: up address: see --recommends
   Local Storage: total: 476.94 GiB used: 117.98 GiB (24.7%)
   ID-1: /dev/nvme0n1 vendor: Western Digital
     model: PC SN530 SDBPMPZ-512G-1101 size: 476.94 GiB temp: 33.9 C
   ID-1: / size: 468.09 GiB used: 117.98 GiB (25.2%) fs: ext4
     dev: /dev/nvme0n1p2
   ID-2: /boot/efi size: 299.4 MiB used: 288 KiB (0.1%) fs: vfat
     dev: /dev/nvme0n1p1
   ID-1: swap-1 type: file size: 8 GiB used: 0 KiB (0.0%) file: /swapfile
   System Temperatures: cpu: 51.0 C mobo: N/A
   Fan Speeds (RPM): N/A
   Processes: 241 Uptime: 17m Memory: 7.33 GiB used: 2.04 GiB (27.8%)
   Init: systemd Compilers: gcc: 11.1.0 clang: 13.0.0 Packages: 1541
   Shell: Zsh v: 5.8 inxi: 3.3.11