Screen goes to black with "no video input" using ctrl+alt+f2 with NVidia 455

Asus Sabertooth MB, NVidia GT730 graphics card.Dual Manjaro installations bare metal, same machine -Stable on one HD, Testing on the other. Plasma 5.20 desktop. Updated both stable and testing to NVidia 455 before installing Linux510 on testing only. 510 would not install without NVidia455. Both installs run fine. Stable on 5.9/Nvidia455; Testing on 510/Nvidia 455. What has disappeared is the ability to use ctrl+alt+f2 to get TTY. At the boot screen AND from a desktop session ctrl+alt+f2, screens go to black then the message"no video input" like the computer is turned off. The computer still runs, no HD activity and only black screen afterwards. On Stable5.9 and Testing5.9 this function worked as it always has–ctrl+alt+f2 got a tty login screen from both GUI and boot screen. No longer. Most likely culprit is the NVidia 455 driver. With ctrl+alt+f2 no longer working its impossible to get to a TTY except from inside the GUI inside a terminal window (not good for doing extensive updates).

Note-- adding 3 to the end of the linux line in grub will still boot to a functional console. Just not from either the GUI logon or from inside the desktop using ctrl+alt+f2.


Im not sure kernel 5.10 works properly with nvidia drivers. Its experimental and still has some modules missing

1 Like

Saw doctor
Thanks. Understand --however considering that this functionality stopped in 5.9 after installation of the 455 driver , it might be the Nvidia driver as the problem. I dont know this only speculation.

So here is a question for the forum. Where in the system do I go to look for the code that controls what happens when ctrl+alt+f2 is pressed either from the logon screen or from inside Plasma…when the system sees this combination of key presses…where is the code that tells it to go to RL3 for a TTY login? I dont know where to start to look. Any help would be appreciated. Also is anyone else with NVidia 455 experiencing this?

No one?? OK So lets frame this a little differently. Running Plasma desktop. Open a terminal. What are the commands in Manjaro to change run levels? The Linux or UNIX commands I remember dont work…searching the forum here produces no results. When using init for example init 3 to change from GUI to terminal I get the error message “Excess arguments” Telenit doesnt work either.

sudo systemctl isolate <target>

can be used to change runlevels. Run systemctl | grep '\.target' to see the available targets. Runlevel 3 is basically “”, runlevel 5 is “”.


Hey pobrn
thanks very much. Didnt realize that init now is under the purveyance of systemctrl. So it would be something like sudo systemctl isolate or on this system. Going to do some more studying on systemctl. Thanks for pĂłinting me in the right direction.

Yes, same problem! Linux 5.9 with (Amd 5800x + Nvidia GPU) nvidia 455 drivers. ctrl+alt+F2-7 don’t work. No output to monitor.

I disabled modesetting and the framebuffer and that seemed to have fixed it - I can access non gui tty now.
But, a weird error popped up in my journalctl

NVRM: Xid (PCI:0000:2d:00): 32, pid=2380, Channel ID 00000038 intr 00200000

I didn’t check them separately. I disabled modesetting and then noticed that there’s advice for disabling the framebuffer with proprietary nvidia drivers, so I did that too.
The XID 32 error is something I probably I can’t doing anything about, having read up on it.