Screen goes black 5 seconds after booting into desktop environment from flashdrive

Hello, I attempted to install manjaro today on my windows desktop, and I am encountering a persistent problem where after booting manjaro KDE plasma from a flash drive, after about 5 seconds (the amount of time seems to vary from reboot to reboot) of being in the desktop environment, my screen goes black. I get to see the manjaro installation window and I can even interact with it in those few seconds, but invariably the screen goes black. Also, my keyboard has rgb and the rgb turns off as soon as the screen goes black as well.

While I could not find any posts describing a problem exactly the same as mine, I have tried multiple different solutions to solve my problem:

  1. Disabling secure boot, fast boot, CSM, etc. in BIOS.
  2. Booting with or without proprietary drivers.
  3. Editing grub before booting to include about a half a dozen different options.
  4. Attempting to use manjaro XFCE or even a different distro, Pop!_os, instead of manjaro KDE.
  5. Using ctrl-alt-f2 before my screen turns black, and running pacman -Sy; pacman-mirrors -f3; pacman -Syyu, then either rebooting or running startx (I’ve tried both).

None of these attempts managed to get a desktop environment to start without causing my screen to go black a few seconds after.

My basic system specs are:
CPU: AMD Ryzen 5 2600
GPU: AMD Radeon R9 390
MB: TUF Gaming X570-PLUS (wifi)

1 Like

Welcome to community!

Thank you for trying to fix that odd behavior you met. Seems to be you know Manjaro before or heard recommendations about it.

  1. Let’s verify that the image is good.
    In the place of where you download the ISO image file from, the hash sum file or SHA string value should be present. Did you tried to verify that hash file/value? That will be a guarantee that that file came to you storage undamaged.

  2. How are you “burned” ISO into your portable storage? Just in case.

  3. Please post full filename of the ISO image you used.

  4. Where are you downloaded it from?

  5. Please try different images: [Stable Update] 2021-12-10 - Kernels, Systemd, LibreOffice, Plasma, Browser, Thunderbird - #3 by philm
    with different kernels there are 3 variants.

    If none of them works for you, please try developer version: [Stable Update] 2021-12-10 - Kernels, Systemd, LibreOffice, Plasma, Browser, Thunderbird

    Get our latest daily developer images now from Github: Plasma , Gnome , XFCE .

    If developer version will be good and if you are new to Manjaro, then after installation do not install any update (your current branch of updates will be unstable), but first switch to the stable branch of updates by:

    sudo pacman-mirrors --api --set-branch stable --proto https --country Germany,Austria

    and after that do not forget the

    sudo pacman -Syyu

    which brings you available updates and warns you that some of your packages has a bit ahead version of packages. By the time goes by stable branch will got updates and that warnings count will be less and finally will absent (perhaps about 2-3 weeks).
    Please note: I mean warnings only about package versions are ahead. it could be ignored. But pay attention to other warnings (in case you will have them).

    PS List of avail. countries will be available by:

    pacman-mirrors -l

    Just choose 2-3 countries close to you in try to get maximum speed of updates downloading.

Hope some of them helps and finally you will be able install Manjaro OS.
Perhaps some drivers involved into the issue. And remember the kernel version generation which will work for you (5.4 / 5.10 / 5.15 / etc. if any).

Back to us and leave a note how it goes for you.

Thank you for your efforts!

1 Like

I won’t be able to try your recommendations tonight, but I can provide the information you asked for,

  1. I have just checked, the SHA1 hash of the two manjaro ISOs I tried match those displayed on their download page.
  2. I am using balenaEtcher on windows 10, and I am burning the iso to a flashdrive.
  3. I have tried “manjaro-kde-21.2rc1-211211-linux515.iso” and “manjaro-xfce-21.2rc1-211210-linux515.iso”.
  4. “Manjaro - KDE Plasma” and “Manjaro - XFCE” the topmost downloads.
1 Like

I saw no issues in that. Looks good.
So you already tried the 5.15 gen of the stable branch.

Please try 5.10 and 5.4 of stable
and if none of them, then development version of 5.15 kernel gen.

If nothing works I currently do not know what to try else and what possible cause could be.

Hm, but I got the idea: network connection loads when on desktop appears. What if during the time of installation to turn off Ethernet and WiFi adapters in BIOS/UEFI so thay are will be unavailable for LiveCD environment? May be if to turn them on again but on installed system will not trigger that odd behavior…

The idea origin:
5 sec delay
I remember that for the (OS for smartphones) the main problem was to find appropriate driver for cellular network device, so what if your case of network devices is the same case - network driver issue…

alright I did manage to try all of the versions you recommended, and all of them have the same issue. In the development version when I first tried it I actually got several minutes before the screen went black; it died a bit after I loaded the manjaro forums in firefox. After rebooting its back to the screen going black after only a few seconds. Disabling wifi and unplugging ethernet had no effect.

1 Like

@philm , @Aragorn , community,
could it be something suggested here?

I ran out of ideas: something which is present in all ISOs (5.15, 5.10, 5.4, a bit different in 5.15 dev version) “can’t communicate” with… (the hardware?)
How to diagnose the issue if monitor switching off and keyboard lost power (turning off its LED Lights).

@Mami , are you having a reliable power adapter / power supply unit for the PC?
May be power consumption issue while PC peaks in energy consuming into higher values, when desktop loads / desktop effects showing and firefox openning and current power source of PC can’t handle it?
Your CPU: AMD Ryzen 5 2600 looks like desktop CPU.
Try to review connected power lines you made inside of PC case, could your try to switch one 12V line into another from the same PSU (if it has several), one 5V line into another 5V line. May be you have another power cables to try to substitute running ones (possibility of power cables was damaged / has factory defect and can’t handle high / peak current values).

I got idea. Perhaps your BIOS/UEFI has some analogue of Intel’s CPU Turbo boost setting, which speeds up CPU clock frequency from base value to max. value:

Base Clock: 3.4GHz
Max. Boost Clock: Up to 3.9GHz

Try temporarily to turn off the the CPU clock boosting feature (to leave 3.4 GHz as max value) cause the more clock you have the more power draw the CPU have (and for Intel CPU for frequencies 2.0+ GHz values leads to less (CPU performance / Watts consumed) ratio, but it is an energy consumption optimization for the price of performance, let’s leave it for future need if it will need to you).
Just try to turn off the “factory CPU overclocking” - to leave 3.4 GHz is max CPU clock value. There should be a simplest switch (on / off) for that.

Default TDP: 65W

Also in the same time to lower that Thermal Design Power.
As example: for the Intel mobile CPU i5-8250U there 3 values of TDP:
-) nominal: up to 15 Watts
-) up: up to 25 W
-) down: up to 10 W

Try to set your TDP to lower value in BIOS/UEFI.

And retry to run LiveCD.

Hello @Mami and welcome :wink:

I would say it is C6 C-State problem, which does not work well with linux. You can restrict that by adding:


to the kernel parameter. It restricts the cstate from C0-C5 and ignores C6.

:notebook: C-States are powersaving states for CPUs.

It goes like that:

  1. Boot the Manjaro Install Disk.
  2. On the grub boot menu edit with E the entry and add the previous parameter at line which begins with linux.
  3. Type F10 to boot it with that parameter.

Some UEFIs are also able to disable this CState on the Settings.

Hope it works for you :wink:

1 Like

This unfortunately did not work for me.

It took a bit of digging but I believe I disabled the overclocking features you are speaking of in my BIOS. This unfortunately did not fix the problem.
I highly doubt this could be an issue with the physical power cables, as I have been using them with no issues for years on windows with the same hardware. I am not inclined to attempt to replace them unless I am reasonably sure it will fix the problem. My power supply for this PC is intentionally overspec’ed for my build so I doubt it would have trouble delivering enough power to the system either.

I remember now having a vaguely similar problem in windows specifically with games that push my gpu too hard. If I leave certain games on high graphics my gpu will burn itself out instead of thermal throttling, and as a result cause my screen to go black. I did some basic testing for this, physically monitoring the temp of my gpu, and it does not seem to even noticeably heat up when loading the linux desktop environment. So I am not fully convinced this is a related problem, but it is the only instance I can think of where I had a similar issue to this on windows.

If it is really an amdgpu issue, then it is worth a try to use the LTS Version since the driver is baked into the kernel. Which ISO version did you try?

I tried a lot of different isos, you can see the exact ones in the thread above. I do not know what the LTS version is.

The LTS (Long Term Support) versions from :

  • 5.10
  • 5.4
  • 4.19

You can check uname -r to show Linux version.

Perhaps it was already done earlier:

But, IDK with applying the megavolt’s suggestion or just to try a boot of them as I suggested before megavolt.

I’m not sure if I follow, what should I try next?