Screen freezes when changing brightness on Manjaro Gnome - Intel i915 driver

Hey guys, everything is working fine, even volume slider, but when I press Fn + Left or Right to change brightness, screen freezes for 1 or 2 seconds, then it works as it should, it freezes to make the volume slider appear, I need help fixing it…

:+1: Welcome to Manjaro! :+1:

Please read this:


and post some more information so we can see what’s really going on. Now we know the symptom of the disease, but we need some more probing to know where the origin lies…

An inxi --admin --verbosity=7 --filter --no-host would be the minimum required information… (Personally Identifiable Information like serial numbers and MAC addresses will be filtered out by the above command)

:innocent:

1 Like
System:
  Kernel: 5.8.3-2-MANJARO x86_64 bits: 64 compiler: N/A 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.8-x86_64 
  root=UUID=9cb6a6d4-92dc-491a-93b1-873211f1b763 rw udev.log_priority=3 
  Desktop: GNOME 3.36.5 tk: GTK 3.24.22 wm: gnome-shell dm: GDM 3.36.3 
  Distro: Manjaro Linux 
Machine:
  Type: Laptop System: Acer product: Aspire E5-471 v: V3.72 serial: <filter> 
  Mobo: Acer model: EA40_HB v: Type2 - A01 Board Version serial: <filter> 
  UEFI [Legacy]: Insyde v: 1.25 date: 01/15/2015 
Battery:
  ID-1: BAT1 charge: 43.8 Wh condition: 45.1/55.9 Wh (81%) volts: 12.6/11.1 
  model: SANYO AL14A32 type: Li-ion serial: <filter> status: Discharging 
Memory:
  RAM: total: 3.77 GiB used: 1.27 GiB (33.7%) 
  RAM Report: 
  permissions: Unable to run dmidecode. Root privileges required. 
CPU:
  Topology: Dual Core model: Intel Core i3-5005U bits: 64 type: MT MCP 
  arch: Broadwell family: 6 model-id: 3D (61) stepping: 4 microcode: 2F 
  L2 cache: 3072 KiB bogomips: 15971 
  Speed: 799 MHz min/max: 500/1900 MHz Core speeds (MHz): 1: 912 2: 1080 
  3: 1348 4: 1059 
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat arch_perfmon 
  avx avx2 bmi1 bmi2 bts clflush cmov constant_tsc cpuid cpuid_fault cx16 
  cx8 de ds_cpl dtes64 dtherm dts epb ept ept_ad erms est f16c flexpriority 
  flush_l1d fma fpu fsgsbase fxsr ht ibpb ibrs intel_pt invpcid 
  invpcid_single lahf_lm lm mca mce md_clear mmx monitor movbe msr mtrr 
  nonstop_tsc nopl nx pae pat pbe pcid pclmulqdq pdcm pdpe1gb pebs pge pln 
  pni popcnt pse pse36 pti pts rdrand rdseed rdtscp rep_good sdbg sep smap 
  smep ss ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow 
  tsc tsc_adjust tsc_deadline_timer vme vmx vnmi vpid x2apic xsave xsaveopt 
  xtopology xtpr 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: srbds mitigation: Microcode 
  Type: tsx_async_abort status: Not affected 
Graphics:
  Device-1: Intel HD Graphics 5500 vendor: Acer Incorporated ALI 
  driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:1616 
  Device-2: Chicony HD WebCam type: USB driver: uvcvideo bus ID: 2-7:3 
  chip ID: 04f2:b469 
  Display: x11 server: X.org 1.20.8 compositor: gnome-shell driver: intel 
  unloaded: modesetting alternate: fbdev,vesa resolution: <xdpyinfo missing> 
  OpenGL: renderer: Mesa Intel HD Graphics 5500 (BDW GT2) v: 4.6 Mesa 20.1.6 
  direct render: Yes 
Audio:
  Device-1: Intel Broadwell-U Audio vendor: Acer Incorporated ALI 
  driver: snd_hda_intel v: kernel bus ID: 00:03.0 chip ID: 8086:160c 
  Device-2: Intel Wildcat Point-LP High Definition Audio 
  vendor: Acer Incorporated ALI driver: snd_hda_intel v: kernel 
  bus ID: 00:1b.0 chip ID: 8086:9ca0 
  Sound Server: ALSA v: k5.8.3-2-MANJARO 
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Acer Incorporated ALI driver: r8169 v: kernel port: 3000 
  bus ID: 02:00.0 chip ID: 10ec:8168 
  IF: enp2s0 state: down mac: <filter> 
  Device-2: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter 
  vendor: Lite-On driver: ath9k v: kernel port: 3000 bus ID: 03:00.0 
  chip ID: 168c:0036 
  IF: wlp3s0 state: up mac: <filter> 
  IP v4: <filter> type: dynamic noprefixroute scope: global 
  broadcast: <filter> 
  IP v6: <filter> type: noprefixroute scope: link 
  WAN IP: <filter> 
Drives:
  Local Storage: total: 931.51 GiB used: 12.39 GiB (1.3%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/sda vendor: Western Digital model: WD10JPVX-22JC3T0 
  size: 931.51 GiB block size: physical: 4096 B logical: 512 B 
  speed: 6.0 Gb/s rotation: 5400 rpm serial: <filter> rev: 1A01 scheme: MBR 
  Optical-1: /dev/sr0 vendor: HL-DT-ST model: DVDRAM GUC0N rev: 1.00 
  dev-links: cdrom 
  Features: speed: 24 multisession: yes audio: yes dvd: yes 
  rw: cd-r,cd-rw,dvd-r,dvd-ram state: running 
RAID:
  Message: No RAID data was found. 
Partition:
  ID-1: / raw size: 200.00 GiB size: 195.86 GiB (97.93%) 
  used: 8.95 GiB (4.6%) fs: ext4 dev: /dev/sda2 label: N/A 
  uuid: 9cb6a6d4-92dc-491a-93b1-873211f1b763 
  ID-2: /home raw size: 725.51 GiB size: 713.12 GiB (98.29%) 
  used: 3.44 GiB (0.5%) fs: ext4 dev: /dev/sda3 label: N/A 
  uuid: cad7ebd2-28c0-4774-9010-2964254b440a 
Swap:
  Alert: No Swap data was found. 
Unmounted:
  ID-1: /dev/sda1 size: 6.00 GiB fs: swap label: N/A 
  uuid: e460ba84-f8b7-4600-bf01-dbaa80ccd5ec 
USB:
  Hub: 1-0:1 info: Full speed (or root) Hub ports: 2 rev: 2.0 
  speed: 480 Mb/s chip ID: 1d6b:0002 
  Hub: 1-1:2 info: Intel Integrated Hub ports: 8 rev: 2.0 speed: 480 Mb/s 
  chip ID: 8087:8001 
  Hub: 2-0:1 info: Full speed (or root) Hub ports: 11 rev: 2.0 
  speed: 480 Mb/s chip ID: 1d6b:0002 
  Device-1: 2-7:3 info: Chicony HD WebCam type: Video driver: uvcvideo 
  interfaces: 2 rev: 2.0 speed: 480 Mb/s chip ID: 04f2:b469 
  Hub: 3-0:1 info: Full speed (or root) Hub ports: 4 rev: 3.0 speed: 5 Gb/s 
  chip ID: 1d6b:0003 
Sensors:
  System Temperatures: cpu: 43.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 226 Uptime: 8m Init: systemd v: 246 Compilers: gcc: 10.2.0 
  Packages: pacman: 1055 lib: 292 Shell: Zsh v: 5.8 
  running in: gnome-terminal inxi: 3.1.05

You have an Intel driver which I’m not very familiar with (I’m on pure nVidia)

but for the next person that comes around please prepare the output to:

mhwd --listinstalled

(I’ve also edited your title to attract more knowledgeable people than me)

1 Like
> Installed PCI configs:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
           video-linux            2018.05.04                true            PCI


Warning: No installed USB configs!
1 Like