Screen flickering issues - All Manjaro Versions /Attempted X11 fixes

I have tried several versions of Manjaro. KDE, Gnome, Cinammon. They all have the same screen flickering issue. I have tried a few solutions, but none have worked so far.

This is the output from inxi:

  Kernel: 5.15.60-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.1.1
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.15-x86_64
    root=UUID=27d69fc7-f777-4f39-8b56-33212ec54947 rw quiet
  Desktop: KDE Plasma v: 5.24.6 tk: Qt v: 5.15.5 wm: kwin_x11 vt: 1
    dm: SDDM Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: Acer product: Aspire E5-553 v: V1.31
    serial: <superuser required>
  Mobo: Acer model: Wasp_BR v: V1.31 serial: <superuser required>
    UEFI-[Legacy]: Insyde v: 1.31 date: 03/28/2018
  ID-1: BAT1 charge: 9.6 Wh (100.0%) condition: 9.6/41.4 Wh (23.2%)
    volts: 16.4 min: 14.8 model: PANASONIC AS16A5K type: Li-ion
    serial: <filter> status: full
  Info: model: AMD A12-9700P RADEON R7 10 COMPUTE CORES 4C+6G bits: 64
    type: MT MCP arch: Excavator built: 2015 process: GF 28nm family: 0x15 (21)
    model-id: 0x65 (101) stepping: 1 microcode: 0x600611A
  Topology: cpus: 1x cores: 4 smt: enabled cache: L1: 320 KiB desc: d-4x32
    KiB; i-2x96 KiB L2: 2 MiB desc: 2x1024 KiB
  Speed (MHz): avg: 1483 high: 2060 min/max: 1300/2500 boost: enabled
    scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 1293 2: 2060
    3: 1296 4: 1285 bogomips: 19970
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed mitigation: untrained return thunk; SMT vulnerable
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl and seccomp
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, STIBP:
    disabled, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: AMD Wani [Radeon R5/R6/R7 Graphics] vendor: Acer Incorporated ALI
    driver: amdgpu v: kernel arch: GCN-3 code: Volcanic Islands
    process: TSMC 28nm built: 2014-19 ports: active: eDP-1
    empty: DP-1,HDMI-A-1 bus-ID: 00:01.0 chip-ID: 1002:9874 class-ID: 0300
  Device-2: Realtek HD WebCam type: USB driver: uvcvideo bus-ID: 2-1:2
    chip-ID: 0bda:57f3 class-ID: 0e02 serial: <filter>
  Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.3
    compositor: kwin_x11 driver: X: loaded: amdgpu gpu: amdgpu display-ID: :0
    screens: 1
  Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.21x7.99")
    s-diag: 414mm (16.31")
  Monitor-1: eDP-1 mapped: eDP model: AU Optronics 0x70ec built: 2015
    res: 1366x768 hz: 60 dpi: 101 gamma: 1.2 size: 344x193mm (13.54x7.6")
    diag: 394mm (15.5") ratio: 16:9 modes: max: 1366x768 min: 640x480
  OpenGL: renderer: AMD CARRIZO (LLVM 14.0.6 DRM 3.42 5.15.60-1-MANJARO)
    v: 4.6 Mesa 22.1.6 direct render: Yes
  Device-1: AMD Kabini HDMI/DP Audio driver: snd_hda_intel v: kernel
    bus-ID: 00:01.1 chip-ID: 1002:9840 class-ID: 0403
  Device-2: AMD Family 15h Audio vendor: Acer Incorporated ALI
    driver: snd_hda_intel v: kernel bus-ID: 00:09.2 chip-ID: 1022:157a
    class-ID: 0403
  Sound Server-1: ALSA v: k5.15.60-1-MANJARO running: yes
  Sound Server-2: sndio v: N/A running: no
  Sound Server-3: JACK v: 1.9.21 running: no
  Sound Server-4: PulseAudio v: 16.1 running: yes
  Sound Server-5: PipeWire v: 0.3.56 running: yes
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Acer
    Incorporated ALI driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 port: 2000 bus-ID: 01:00.1 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp1s0f1 state: down mac: <filter>
  Device-2: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter
    vendor: Lite-On driver: ath10k_pci v: kernel pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 bus-ID: 02:00.0 chip-ID: 168c:0042 class-ID: 0280
  IF: wlp2s0 state: up mac: <filter>
  Device-1: Lite-On Qualcomm Atheros QCA9377 Bluetooth type: USB
    driver: btusb v: 0.8 bus-ID: 1-1.3:4 chip-ID: 04ca:3015 class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 2 state: up address: see --recommends
  Local Storage: total: 931.51 GiB used: 22.22 GiB (2.4%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Toshiba model: MQ01ABD100
    size: 931.51 GiB block-size: physical: 4096 B logical: 512 B
    speed: 6.0 Gb/s type: HDD rpm: 5400 serial: <filter> rev: 3J scheme: MBR
  ID-1: / raw-size: 931.51 GiB size: 915.81 GiB (98.31%) used: 22.22 GiB
    (2.4%) fs: ext4 dev: /dev/sda1 maj-min: 8:1
  Alert: No swap data was found.
  System Temperatures: cpu: 51.8 C mobo: N/A gpu: amdgpu temp: 51.0 C
  Fan Speeds (RPM): N/A
  Processes: 214 Uptime: 14m wakeups: 1 Memory: 15.09 GiB used: 2.12 GiB
  (14.0%) Init: systemd v: 251 default: graphical tool: systemctl
  Compilers: gcc: 12.1.1 clang: 14.0.6 Packages: pacman: 1225 lib: 322
  flatpak: 0 Shell: Zsh v: 5.9 default: Bash v: 5.1.16 running-in: konsole
  inxi: 3.3.20

I have tried the solution of changing the X11 configuration by modifying:

  • /etc/X11/xorg.conf.d/20-amdgpu.conf*

and changing it to:

ection "Device"
        Identifier "AMD"
        Driver "amdgpu"
        Option "TearFree" "true"
        Option      "AccelMethod"  "uxa"

As suggested on other threads.

But the issue still persists. Checking on the Arch Linux forums, some have suggested downgrading the Kernel version. But not sure if that would help.

For the record, I come from Debian Bullseye, where the issue is not present.

Let me know if there’s anything else I could try.

What does the

inxi -G

command give you?

  Device-1: AMD Wani [Radeon R5/R6/R7 Graphics] driver: amdgpu v: kernel
  Device-2: Realtek HD WebCam type: USB driver: uvcvideo
  Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.3 driver: X:
    loaded: amdgpu gpu: amdgpu resolution: 1366x768~60Hz
  OpenGL: renderer: AMD CARRIZO (LLVM 14.0.6 DRM 3.42 5.15.60-1-MANJARO)
    v: 4.6 Mesa 22.1.6

I get this as the output.

1 Like


Section "Device"
        Identifier "AMD"
        Driver "amdgpu"
        Option "TearFree" "on"
        Option "EnablePageFlip"  "off"

uxa is for intel. on amdgpu there is only glamor.

Also try disabling opengl effects at the kde settings.

I will try this one and reply back with results. Thank you.

1 Like

I have been monitoring the screen to check if there are any changes. Unfortunately, they did not work. The screen flickering still occurs. This is how I removed any compositioning, which should remove any OpenGL calls. I right clicked on the screen, then under compositor, I disabled it on startup, then restarted the system.

However if there’s any other way or preferred way to do so let me know.

I restarted the system and applied the changes suggested to /etc/X11/xorg.conf.d/20-amdgpu.conf However the flickering is still present.

Any other possible fix that could work? Thank you.

What always had been my last resort (but is now my ‘first resort’) is to use xcompmgr as my compositor. I only run dwm, i3wm & openbox so that works for me. It may not work for you.

1 Like

I tried this with the Arch Linux guide on the wiki. I will report back if this solves the issue.

I ran

xdpyinfo | grep Composite
#checks if it's enabled, in this case it was
#added the next command to ~/.xprofile
xcompmgr -c &

#restarted the computer and then checked
inxi -Gxx | grep compositor

#The output of the last command was
# compositors: 1: xcompmgr 2: kwin_x11 driver: X: loaded: amdgpu gpu: amdgpu

After running this, I have verified that it’s indeed running, sadly, the issue persists.

What other solution could be taken into consideration?

Yes. xcompmgr is what I use. Bug free! Simple. Fairly full featured. AND I really like its fade in and out effects. I like this setting: xcompmgr -f -O .0.37, for a slow fade out. :smiley:

Hmm. Maybe try setting your monitor’s refresh rate with xrandr?
The --rate flag allows you to set your monitor’s refresh rate.

Hardware seems to not let it. It only allows it to be set at 60Hz and no other, but thanks for the help.

1 Like