Screen Energy Saving not working properly

Greetings all,

I can’t get screen energy saving to work properly with my dual HP displays.

I set “screen off after” for 2 min.
After 2 min, screens turn “off” and then turn back “on” after a few seconds.
Once they turn on, they turn back off after 2 min and then back on again.
This loops forever if I don’t intervene.

Any help on this would be most appreciated.


CPU: 6-Core Intel Core i7-5820K (-MT MCP-) speed/min/max: 1362/1200/3600 MHz Kernel: 5.9.1-1-rt19-MANJARO x86_64 Up: 15m 
Mem: 1699.5/31953.6 MiB (5.3%) Storage: 5.49 TiB (11.3% used) Procs: 324 Shell: Bash inxi: 3.3.01 
[syntheus@synthmachine-i7 ~]$ inxi -Fxxi
System:    Host: synthmachine-i7 Kernel: 5.9.1-1-rt19-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.1 
           Desktop: KDE Plasma 5.20.5 tk: Qt 5.15.2 wm: kwin_x11 dm: SDDM Distro: Manjaro Linux 
Machine:   Type: Desktop System: Gigabyte product: N/A v: N/A serial: <superuser required> 
           Mobo: Gigabyte model: X99-UD4-CF v: x.x serial: <superuser required> UEFI: American Megatrends v: F24a 
           date: 01/11/2018 
CPU:       Info: 6-Core model: Intel Core i7-5820K bits: 64 type: MT MCP arch: Haswell rev: 2 L2 cache: 15 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 79233 
           Speed: 1200 MHz min/max: 1200/3600 MHz Core speeds (MHz): 1: 1200 2: 1200 3: 2036 4: 1204 5: 2907 6: 2169 7: 3130 
           8: 1200 9: 1200 10: 1202 11: 1365 12: 3410 
Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Baffin [Radeon RX 550 640SP / RX 560/560X] vendor: Micro-Star MSI 
           driver: amdgpu v: kernel bus ID: 05:00.0 chip ID: 1002:67ff 
           Display: x11 server: X.Org 1.20.10 compositor: kwin_x11 driver: loaded: amdgpu,ati unloaded: modesetting 
           alternate: fbdev,vesa resolution: 1: 1920x1080~60Hz 2: 1920x1080~60Hz s-dpi: 96 
           OpenGL: renderer: Radeon RX 560 Series (POLARIS11 DRM 3.39.0 5.9.1-1-rt19-MANJARO LLVM 11.0.1) v: 4.6 Mesa 20.3.4 
           direct render: Yes

That looks like an application waking up your screen again.

  • Close all applications (including those in the panel line Skype, Telegram, …)
  • Try again

If the problem remains: give a shout: we’ll turn off more stuff like Bluetooth, WiFi, …

If the problem goes away:

  • Start applications one by one until you’ve found the offending application
  • Turn off “disable screen saver” in that application or if such a problem does not exist, file a bug with the application Maintainer / Developer.


I’ve got the same issue on my fresh Manjaro KDE install on my rockpro64 booted through NVME (if that changes anything). However on the rpi4 it works fine. I will try to disable some things but I don’t really have much running on there as its a fresh install.