Screen distortion after grub

Does the Desktop loads correctly after this? Share inxi -Fxxxz from terminal. Copy that text and paste it here, and use ``` above and bellow it.

System:
Host: Muaz-pc Kernel: 4.19.45-1-MANJARO x86_64 bits: 64 compiler: gcc
v: 8.3.0 Desktop: Cinnamon 4.0.10 dm: LightDM 1.28.0 Distro: Manjaro Linux
Machine:
Type: Laptop System: Hewlett-Packard product: HP ProBook 455 G1
v: A2019DD200 serial: Chassis: type: 10 serial:
Mobo: Hewlett-Packard model: 194E v: KBC Version 91.0D serial:
UEFI: Hewlett-Packard v: 68CPE Ver. F.68 date: 03/23/2018
Battery:
ID-1: BAT0 charge: 42.3 Wh condition: 43.1/43.1 Wh (100%) volts: 12.4/10.8
model: Hewlett-Packard Primary type: Li-ion serial:
status: Unknown
CPU:
Topology: Dual Core model: AMD A4-5150M APU with Radeon HD Graphics
bits: 64 type: MCP arch: Piledriver rev: 1 L2 cache: 1024 KiB
flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
bogomips: 10785
Speed: 2301 MHz min/max: 1400/2700 MHz boost: enabled Core speeds (MHz):
1: 2539 2: 2551
Graphics:
Device-1: AMD Richland [Radeon HD 8350G] vendor: Hewlett-Packard
driver: radeon v: kernel bus ID: 00:01.0 chip ID: 1002:9997
Display: x11 server: X.Org 1.20.4 driver: radeon FAILED: ati
unloaded: modesetting alternate: fbdev,vesa tty: N/A
OpenGL: renderer: AMD ARUBA (DRM 2.50.0 / 4.19.45-1-MANJARO LLVM 8.0.0)
v: 4.3 Mesa 19.0.4 compat-v: 3.1 direct render: Yes
Audio:
Device-1: AMD Trinity HDMI Audio
vendor: Hewlett-Packard ProBook 455 G1 Notebook driver: snd_hda_intel
v: kernel bus ID: 00:01.1 chip ID: 1002:9902
Device-2: AMD FCH Azalia vendor: Hewlett-Packard ProBook 455 G1 Notebook
driver: snd_hda_intel v: kernel bus ID: 00:14.2 chip ID: 1022:780d
Sound Server: ALSA v: k4.19.45-1-MANJARO
Network:
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Hewlett-Packard ProBook 450/455 driver: r8168 v: 8.047.01-NAPI
port: 4000 bus ID: 01:00.0 chip ID: 10ec:8168
IF: enp1s0 state: down mac:
Device-2: Realtek RTL8188EE Wireless Network Adapter
vendor: Hewlett-Packard driver: rtl8188ee v: kernel port: 2000
bus ID: 03:00.0 chip ID: 10ec:8179
IF: wlo1 state: up mac:
Drives:
Local Storage: total: 298.09 GiB used: 76.58 GiB (25.7%)
ID-1: /dev/sda vendor: Toshiba model: MQ01ABF032 size: 298.09 GiB
speed: 3.0 Gb/s rotation: 5400 rpm serial: rev: 2C scheme: GPT
Partition:
ID-1: / size: 47.07 GiB used: 15.61 GiB (33.2%) fs: ext4 dev: /dev/sda8
Sensors:
System Temperatures: cpu: 77.8 C mobo: N/A gpu: radeon temp: 24 C
Fan Speeds (RPM): N/A
Info:
Processes: 178 Uptime: 2h 51m Memory: 7.00 GiB used: 2.90 GiB (41.4%)
Init: systemd v: 242 Compilers: gcc: 8.3.0 Shell: bash v: 5.0.7
running in: gnome-terminal inxi: 3.0.34

No it doesn't boot after this. It freezes here. I can only boot with intramfs. It does this distortion for around a minute or less then loads. and this is the beginning. all else say ok in green

I had that happen the other day on my 32bit install. Turns out it was the kernel. Was using 419. At grub I chose 414 & the issue was gone.

Have you tried this?


Or simply install another kernel?

I installed 4.14 and same problem.

how do I install these extensions?
edit Installed them. Nothing same problem.

is this something that has always happened booting manjaro, or just recently? after an update?

there have been issues with the latest firmware breaking video though those issues resulted in the screen turning off after grub. those users were using amdgpu and your using radeon so your issue could just behave differently due to the drivers being used.

for now, the fix is to downgrade firmware until it gets fixed. first try running a full update and reinstalling video drivers. then if that doesnt take care of it, manually downgrade firmware to the previous version.

from terminal:

sudo pacman-mirrors -f8 ; sudo pacman -Syyuu
#answer yes to any prompts
sudo mhwd -a pci free 0300
#reboot after if there are no errors

still happening? downgrade following these instructions

:slightly_frowning_face: nothing changed. I have an installation of Windows 10 and Linux mint 19.1 cinnamon. No problems booting either of them. I really just want to run MS office in a VM and Use manjaro. Try to get some experience with a different flavor of Linux. It also seems significantly faster.

maybe try adding radeon to mkinitcpio.conf

sudo nano /etc/mkinitcpio.conf
edit this line, add radeon to it. post if anything is already on the line, then continue

MODULES="radeon"

save/exit
sudo mkinitcpio -P
sudo update-grub

reboot and see if it changes anything.

you could also try specifying grubs resolution buy editing /etc/default/grub (use your own resolution)

GRUB_GFXMODE="1920x1080"

save/exit
sudo update-grub

update nothing worked. Further research I was led to believe there was a possible conflict between mint Linux bootloader/grub and manjaro's customized version... anyway I deleted all partitions I was comfortable deleting including the original installation of manjaro 18 cinnamon and Linux mint. Now I have a different problem. The grub command prompt comes up and i have to type exit before it boots to the custom manjaro screen.

did you happen to install manjaro once in UEFI and then again in legacy bios?

from bios, can you select manjaro's grub bootloader to be first? do so if you can. (you should be able to)

boot manjaro > run a full update > update grub

sudo pacman-mirrors -f8 
sudo pacman -Syyu
sudo update-grub

no errors? reboot. if there are errors, dont reboot and post them here along with

inxi -MDxxxz
efibootmgr
sudo parted -l
1 Like

::ERROR ftp error: timeout('timed out') 'ftp://ftp.caliu.cat/pub/distribucions/manjaro/

[this is a previous inxi -Fxxxz]
$ inxi -MDxxxz
Machine:
Type: Laptop System: Hewlett-Packard product: HP ProBook 455 G1
v: A2019DD200 serial: Chassis: type: 10 serial:
Mobo: Hewlett-Packard model: 194E v: KBC Version 91.0D serial:
UEFI: Hewlett-Packard v: 68CPE Ver. F.68 date: 03/23/2018
Drives:
Local Storage: total: 298.09 GiB used: 66.14 GiB (22.2%)
ID-1: /dev/sda vendor: Toshiba model: MQ01ABF032 size: 298.09 GiB
speed: 3.0 Gb/s rotation: 5400 rpm serial: rev: 2C scheme: GPT

Machine:
Type: Laptop System: Hewlett-Packard product: HP ProBook 455 G1
v: A2019DD200 serial: Chassis: type: 10 serial:
Mobo: Hewlett-Packard model: 194E v: KBC Version 91.0D serial:
UEFI: Hewlett-Packard v: 68CPE Ver. F.68 date: 03/23/2018
Drives:
Local Storage: total: 298.09 GiB used: 66.14 GiB (22.2%)
ID-1: /dev/sda vendor: Toshiba model: MQ01ABF032 size: 298.09 GiB
speed: 3.0 Gb/s rotation: 5400 rpm serial: rev: 2C scheme: GPT

efibootmgr
BootCurrent: 0000
Timeout: 0 seconds
BootOrder: 0002,0001,0000
Boot0000* Windows Boot Manager
Boot0001* ubuntu
Boot0002* Manjaro

$ sudo parted -l
Model: ATA TOSHIBA MQ01ABF0 (scsi)
Disk /dev/sda: 320GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags:

Number Start End Size File system Name Flags
1 1049kB 473MB 472MB ntfs Basic data partition hidden, diag
2 473MB 578MB 105MB fat32 EFI system partition boot, esp
3 578MB 595MB 16.8MB Microsoft reserved partition msftres
4 595MB 106GB 106GB ntfs Basic data partition msftdata
5 106GB 107GB 883MB ntfs hidden, diag
7 107GB 269GB 161GB ext4
6 269GB 320GB 51.2GB ext4

looks like that mint/ubuntu loader is still around

Re: Just this..

at terminal

sudo cp /boot/grub/x86_64-efi/core.efi /boot/efi/EFI/boot/bootx64.efi
sudo efibootmgr -o 0002,0000

We'll worry about ubuntu entry later. I'm not sure if you still have ubuntu. But the grub prompt won't appear (first).

Re: your screen distortion
Others will help you with your graphics.

1 Like

if i understand correctly we just changed the order of the boot-loader which will put Manjaro first. Nice And no I don't have Linux Mint anymore. So that is an unnecessary entry. I'll give this a try.

edit tried it still had to exit out of grub but the sequence is changed
$ efibootmgr
BootCurrent: 0000
Timeout: 0 seconds
BootOrder: 0002,0001,0000
Boot0000* Windows Boot Manager
Boot0001* ubuntu
Boot0002* Manjaro

do i have to do a update- grub or something?

I edited to include 2 commands. Missed out one command. Makes sure you do both.
If you are sure you do not have Linux mInt any more, you can do the commands below ...
but it is not important and not really necessary. Just good house keeping to clear out stuff.

sudo efibootmgr -b 0001 -B
sudo rm -Rf /boot/efi/ubuntu

sorry I missed one command

And if still need to type exit, one more command (you will have 2 manjaro efientry
possibly the old one is defective.

sudo efibootmgr -c -d /dev/sda -p 2 -L "manjaro" -l "\EFI\Manjaro\grubx64.efi"

nope. same problem
$ efibootmgr
BootCurrent: 0000
Timeout: 0 seconds
BootOrder: 0001,0002,0000
Boot0000* Windows Boot Manager
Boot0001* manjaro
Boot0002* Manjaro

should i change the bootloader order?

Okay, noted. Try going to your bios and change boot sequence and priority.
Like this and check HP website for any other settings to select 'manjaro' entry as default.

ps: late here. need to log off. good luck.

1 Like

thanks for all your help. I changed the bootloader sequence using the command "sudo efibootmgr -o 0002,0001" and it worked. The bios settings on my computer doesn't give me access to the bootloader settings. Thanks A lot... now to start a new thread lol

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by Bytemark