Screen coming out of the monitor

Hi, Randomly a gap appears at the bottom of my screen, as if it had been moved a few pixels off the monitor. If I move the mouse cursor to the top of the screen, it appears in the small space that formed at the bottom. This problem does not usually appear every day, when this happens restarting the computer puts the screen back in place. The gap does not appear in screenshots.
System Information:

#################### inxi -Fxzc0 ########################

System:    Kernel: 5.8.11-1-MANJARO x86_64 bits: 64 compiler: N/A Desktop: KDE Plasma 5.19.5 
           Distro: Manjaro Linux 
Machine:   Type: Laptop System: Dell product: G7 7588 v: N/A serial: <filter> 
           Mobo: Dell model: 05KXC5 v: A00 serial: <filter> UEFI: Dell v: 1.14.0 date: 06/19/2020 
Battery:   ID-1: BAT0 charge: 45.4 Wh condition: 45.4/56.0 Wh (81%) 
           model: LGC-LGC3.553 DELL 99NF279 status: Full 
CPU:       Topology: 6-Core model: Intel Core i7-8750H bits: 64 type: MT MCP arch: Kaby Lake 
           rev: A L2 cache: 9216 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 52815 
           Speed: 885 MHz min/max: 800/4100 MHz Core speeds (MHz): 1: 1243 2: 1159 3: 1197 4: 1225 
           5: 1092 6: 1114 7: 1259 8: 993 9: 1107 10: 1202 11: 1285 12: 1251 
Graphics:  Device-1: Intel UHD Graphics 630 vendor: Dell driver: i915 v: kernel bus ID: 00:02.0 
           Device-2: NVIDIA GP107M [GeForce GTX 1050 Ti Mobile] driver: nvidia v: 450.66 
           bus ID: 01:00.0 
           Device-3: Microdia Integrated_Webcam_HD type: USB driver: uvcvideo bus ID: 1-5:3 
           Display: x11 server: X.Org 1.20.9 driver: intel,nvidia unloaded: modesetting,nouveau 
           resolution: 1920x1080~60Hz 
           OpenGL: renderer: Mesa Intel UHD Graphics 630 (CFL GT2) v: 4.6 Mesa 20.1.8 
           direct render: Yes 
Audio:     Device-1: Intel Cannon Lake PCH cAVS vendor: Dell driver: snd_hda_intel v: kernel 
           bus ID: 00:1f.3 
           Sound Server: ALSA v: k5.8.11-1-MANJARO 
Network:   Device-1: Qualcomm Atheros Killer E2400 Gigabit Ethernet vendor: Dell driver: alx 
           v: kernel port: 3000 bus ID: 3c:00.0 
           IF: enp60s0 state: down mac: <filter> 
           Device-2: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter vendor: Dell 
           driver: ath10k_pci v: kernel port: 3000 bus ID: 3d:00.0 
           IF: wlp61s0 state: up mac: <filter> 
           Device-3: Qualcomm Atheros type: USB driver: btusb bus ID: 1-7:4 
Drives:    Local Storage: total: 1.35 TiB used: 578.10 GiB (41.9%) 
           ID-1: /dev/nvme0n1 vendor: Corsair model: Force MP510 size: 447.13 GiB 
           ID-2: /dev/sda vendor: Western Digital model: WD10SPZX-75Z10T1 size: 931.51 GiB 
Partition: ID-1: / size: 98.18 GiB used: 58.54 GiB (59.6%) fs: ext4 dev: /dev/nvme0n1p7 
           ID-2: /home size: 117.61 GiB used: 91.28 GiB (77.6%) fs: ext4 dev: /dev/nvme0n1p9 
Swap:      ID-1: swap-1 type: partition size: 4.00 GiB used: 0 KiB (0.0%) dev: /dev/nvme0n1p8 
Sensors:   System Temperatures: cpu: 53.0 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Info:      Processes: 366 Uptime: 4h 47m Memory: 15.35 GiB used: 6.04 GiB (39.4%) Init: systemd 
           Compilers: gcc: 10.2.0 clang: 10.0.1 Packages: 1569 Client: KDE Plasma v: 5.19.5 
           inxi: 3.1.05

That seems a hardware problem. Try to auto tune your monitor.

1 Like

I don’t think it’s a hardware problem. I used other distros and did not observe this behavior, I have dual boot with Windows 10 and also had no problem with the screen on that system. And in addition it is a notebook, there are no adjustment options for the monitor other than brightness.

Yeah, your right, it can be an adjustment problem. Given your experience with other SOs, it also doesn’t appear to be a hardware problem.

Try to disable fast boot in Windows, then shut it down (don’t hibernate) and boot Manjaro. I’ve seen cases where Windows leaves some device settings behind which affect Linux. You can also test this by shutting the computer down, disconnecting it from the power source, removing it’s battery and plug it all again and boot Manjaro.

If the problem persists it may be better to write xorg config files and try some driver options.

I had problems with fast boot before, so it is already disabled. My system has already had updates in the graphics drivers and even in the kernel without any effect on the problematic behavior. I don’t know what the xorg config files you mentioned are, but I’ll look into it. Thanks.

So this started happening out of the blue?

I think this problem has been around since I installed the system, probably about 3 months ago. It is not a frequent thing, if it were I would have reported it before, I just have to restart the system that this problem should take a few days to manifest again. I tried to find a solution on the internet before but I didn’t find it, so the last time the gap appeared on my screen I decided to ask here.

Screen coming out of the monitor

Take off your 3D glasses. :stuck_out_tongue_winking_eye:

Good one.

Please post the output of mhwd -li

I think writing a xorg config file with tearfree option for the intel driver could potentially solve the problem. But since your computer has two graphic cards, I must know exactly what drivers you have installed.

> Installed PCI configs:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
           video-linux            2018.05.04                true            PCI
video-hybrid-intel-nvidia-455xx-prime            2020.10.04               false            PCI
     video-modesetting            2020.01.13                true            PCI


Warning: No installed USB configs!

Please post the output of

for i in $(ls /etc/X11/xorg.conf.d/); do echo $i:; cat /etc/X11/xorg.conf.d/$i; done
00-keyboard.conf:
# Written by systemd-localed(8), read by systemd-localed and Xorg. It's
# probably wise not to edit this file manually. Use localectl(1) to
# instruct systemd-localed to update it.
Section "InputClass"
        Identifier "system-keyboard"
        MatchIsKeyboard "on"
        Option "XkbLayout" "eu"
        Option "XkbModel" "pc105"
EndSection
30-touchpad.conf:
Section "InputClass"
    Identifier "touchpad"
    Driver "libinput"
    MatchIsTouchpad "on"
    Option "Tapping" "on"
EndSection
90-mhwd.conf:
##
## Generated by mhwd - Manjaro Hardware Detection
##
 
 

Ok, let’s try to write a config file. There is always the possibility of the system failing to boot. In that case press CTRL+ALT+F2, login and manually delete the file. If, for some weird reason, you can’t change tty, press e on grub menu, navigate to the line starting with linux, then press END, SPACE, write 3 and press F10 to boot to a terminal and then delete the file manually.

Let’s call the file 91-intel-nvidia.conf (the 91 is important). Put this in the file, save and then reboot:

Section "Device"
  Identifier "iGPU"
  Driver "modesetting"
  BusID           "PCI:0:2:0"
  Option          "TearFree" "true"
EndSection

Section "Screen"
  Identifier "iGPU"
  Device "iGPU"
EndSection

Section "Device"
  Identifier "dGPU"
  Driver "nvidia"
  BusID           "PCI:1:0:0"
EndSection

Source

I created the file, there was no boot failure. I will wait a few days to see if the problem has been solved. Thank you

1 Like