Screen brightness stuck at 100% on Lenovo Legion 7i


I got the Lenovo Legion 7i. I installed a few distribution on it and I’m currently testing Manjaro. Most things work great, except the screen brightness. I can’t control it and it’s stuck at 100%.

Arch wiki says it’s working out of the box.
It there something special on Manjaro that might have broken the brightness control?

Did you try other kernels? Such as Kernel 5.7 or 5.8?

You can try kernel 5.8 but even so I’m not sure it will fix it. I have the same problem with an asus with r5 3550h and even with kernel 5.8 can’t make it work.
So I made a scritp and add it to startup so every time you boot up your system it’ll launch the script automatically and change the brightness as you like.

    sleep 5 
    xrandr --output <outputname> --brightness 0.8

Change to your video output name, some like eDP1, you can check with


And 0.8 to valor you like, it goes from 0 to 1
Save the file like give it exec permissions in your /home and add it to you settings/start up section

Yes, I tried both of them. Sames results, when pressing the keys, the brightness ui/indicator appears, but the backlight doesn’t change.

I’m using Redshift for adjusting the color temperature and it can also change the brightness.
It’s only a software solution, so for battery life it’s not great.

I can confirm this still happening, running Manjaro i3 on a Lenovo X1 Carbon. Pressing the brightness keys shows the Power Manager applet (xfce4-power-manager?) at Brightness 100 percent, but it cannot be changed.

Changing the brightness with xrandr works, but I’d really prefer to have the brightness keys working as intended. The other function keys, such as the volume keys, work fine.

EDIT: Nevermind, I’m dumb. I solved it by simply opening xfce4-power-manager-settings and turning “Handle display brightness keys” on (it was off by default)

1 Like