Screen brightness resets to full after every reboot

hey there,
i’ve just started using manjaro cinnamon few weeks ago. The problem i’m facing now is every time i restart my laptop, the brightness level resets to full level again . i’ve changed the screen brightness from the panel and from the settings under power management. but i have not found an option to save this brightness. previously i have been using kde and it have option to save the brightness settings. what could i do ? am i missing anything important here ?
thanks

Hi!
Try using kernel 5.8, maybe it has a better management of backlight for your hardware.
I use kde and still have the same problem, so I made my own workaround

  1. Run xrandr an note the name of your video output, mine was eDP-0-1
  2. Make a file in your home like brightness.sh and give it executable permissions
  3. Add this to the file
!#/bin/bash
xrandr --output <name of your video output> --brightness <0.75>
  1. Change <0.75> to the value you like, you can make test in the terminal with the same command to find the best value for you.
    This is my line in that file
xrandr --output eDP-0-1 --brightness 0.75
  1. Go to your system settings and search autostart, deppend of your DE could be named differently, and add the script to there.This way anytime you start up your system it would change the brigtness to the value you set in the file.
1 Like

xrandr --output eDP --brightness 0.75

this command is working from the terminal. So i’ve added it to the startup

this is my code inside the script

!#/bin/bash
xrandr --output eDP --brightness 0.75

but after restart , it doesnt works .

also i can’t run this script from terminal , it shows an error like this

./brightness.sh: line 1: !#/bin/bash: No such file or directory

Hi!
I made a typo, sorry
It would be

#!/bin/bash
1 Like

thanks bro, now it’s working

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.