Samba Share - ls: Directory: Resource temporarily unavailable


I have got a “problem” with mounting a Samba Share.

I have a Samba Share on a Linux Server, which I want to mount on my Notebook, running Manjaro.

My fstab looks like this:

// /mnt/hp25 cifs rw,vers=3.0,credentials=/home/tobias/.smb,uid=1000,gid=1000,noauto,user 0 0

When I open Dolphin in KDE and click on the Button for this share, it gets mounted and I can access all Files.

But when I try to open /mnt/hp25 in my Shell an type ls -l I can also access all Directories and Files, but got this message:

ls: hp25: Resource temporarily unavailable

Under that message all Directories and Files are listed.

Did I something wrong in my fstab?



I would recommend you to use the systemd service instead of fstab when using Samba.

I think fstab has some limitations (I have not tried Samba in the fstab):

  • There is a lack of order between the Samba client process and the mount process.
    For example: The mount process should wait until Samba client process is activated after booting without crashing.
  • No logical management. What happens if the server is not online? → Fstab still tries to mount it without checking?

Writing your own Systemd service script could prevent two problems.

Try to create /etc/systemd/system/Your-samba.service

I created an example for the Systemd service, you should adjust it yourself:

#After=samba-client.service? # Waiting for the Samba client to start

EnvironmentFile=/etc/environment  # You add SERVER_IP= in /etc/environment
ExecStart=/usr/bin/mount -t cifs //${SERVER_IP}/data /mnt/hp25 -o credentials=/home/tobias/.smb
ExecStop=-/usr/bin/umount /mnt/hp25
# If this service fails, then it will be restarted. 


Thank you for your advice, I am going to try it.

The only Problem I have with this solution. What happen, when I am not at home and have no access to the Server? Does the Service try every 10 seconds to connect to the Samba Share?

Yes, but this service is just an example. If you do not like it, you can change it.
There are many different possible ways to customize the service to you needs. There is no single way.

Did you remount the volume after editing fstab?

sudo mount -o remount /mnt/hp25

I have the same issue :
when I do :
ls -l on mount point
I obtain :
“Resource temporarily unavailable”


Only if it fails.

These links might be of particular interest if you wish to use the systemd unit approach. Cheers.

Final Edit: Moving to Linux 6.6 LTS fixed this issue for me.

This is happening to me now as well after updating the system and restarting.

I was mounting via fstab, but I did migrate them to systemd with proper .mount and .automount unit files and the problem still occurs just as described in OP.

Files are still mostly accessible but it enumerates ‘resource temporarily unavailable’ for every single folder. and filestat doesn’t seem to work? Also seems to be a lot slower, subjectively.

When listing the mount this appears in journalctl:

kernel: CIFS: VFS: reconnect tcon failed rc = -11

My kernel:

6.1.71-1-MANJARO #1 SMP PREEMPT_DYNAMIC Fri Jan  5 17:36:36 UTC 2024 x86_64 GNU/Linux

Seems to be a widespread linux 6.1.x kernel issue?


Thank you @sjrahn, updating my Kernel to 6.6 LTS fixed it also for me!

Anyway, I am also going to check the systemd stuff.

Thanks everyone for your help.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.